LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-08-2007, 01:45 PM   #1
wendea
Member
 
Registered: Mar 2007
Distribution: Fedora
Posts: 81

Rep: Reputation: 15
Smile giving accounts...


Hi,

i'm trying to give one of my regular accounts sudo access. I have gone into the visudo and added the user like this:

username ALL=(ALL) ALL

and yet I still do not have any sudo powers with this account. Can anyone help?

thanks
 
Old 03-08-2007, 01:47 PM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Add the user to the sudoers group, for example by editing /etc/group and writing the username to the correct line.
 
Old 03-08-2007, 01:48 PM   #3
wendea
Member
 
Registered: Mar 2007
Distribution: Fedora
Posts: 81

Original Poster
Rep: Reputation: 15
ok thanks, ill try that.
 
Old 03-08-2007, 01:53 PM   #4
wendea
Member
 
Registered: Mar 2007
Distribution: Fedora
Posts: 81

Original Poster
Rep: Reputation: 15
so i went into etc/group and I put my username in like this:

root:x:0:root,username

yet I still get a error when i try a sudo command:

-bash: service: command not found
 
Old 03-08-2007, 02:04 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Are you sure sudo is on your machine? What distro are you using?

my machine (RHEL4) does not have a sudoers line in /etc/group--I think you in fact have to edit the /etc/sudoers file.
 
Old 03-08-2007, 02:25 PM   #6
wendea
Member
 
Registered: Mar 2007
Distribution: Fedora
Posts: 81

Original Poster
Rep: Reputation: 15
im running fc5, I have already edited the visudo file (/etc/sudoers).

anymore suggestions? this is being a huge pain for me, and i appreciate all your guys help.

Last edited by wendea; 03-08-2007 at 02:27 PM.
 
Old 03-08-2007, 02:31 PM   #7
wendea
Member
 
Registered: Mar 2007
Distribution: Fedora
Posts: 81

Original Poster
Rep: Reputation: 15
alright, I have fixed my problem. I was trying to run the commands like root. I didnt know when you were just a super user that you had to type in the path name as well.

thanks for all your help.
 
Old 03-08-2007, 02:33 PM   #8
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 31
The root group wouldn't be the group used for sudo. Some distro's use the wheel group, but I'm not sure which group Fedora uses. I would check the man page for sudo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Giving Up Dogman2 Linux - Newbie 56 05-08-2006 01:46 AM
samba accounts/ unix accounts Buzz88 Linux - Newbie 3 09-25-2005 08:16 AM
qmail -- new accounts can't receive mail, but old accounts can b:z *BSD 1 07-13-2005 12:42 AM
giving accounts there own ip Lenfade01 Linux - Networking 4 01-16-2004 03:10 PM
setting up/ giving out shell accounts skeletal29 Linux - Security 2 08-25-2002 02:36 AM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration