LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2012, 10:07 AM   #1
Latman
LQ Newbie
 
Registered: Jun 2012
Posts: 15

Rep: Reputation: Disabled
Git on RHEL5.5


Been asked to install Git (latest version) on to our RHEL 5.5 x64 version.
Been searching around to find this, but there seems to be so many versions around and on top of that, I do not know how to download and install it.

Can anyone please assist?
 
Old 06-19-2012, 03:11 PM   #2
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,604

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Code:
yum install git


---------- Post added 06-19-12 at 12:12 PM ----------

http://www.ralfebert.de/tutorials/git/

Info on git if you want to bookmark it..
 
Old 06-19-2012, 05:39 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
No git-1.7.11 in any repo ?

# yum install git : Version = git-1.7.10.4-1.el5.rf, "rpmforge repo"

http://wiki.centos.org/AdditionalRes...11404998926a1b
( http://ftp.is.co.za/mirror/ftp.rpmfo...6_64/dag/RPMS/ )

.
 
Old 06-19-2012, 07:53 PM   #4
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,604

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Takes time for recent releases to get added to repositories, could also be a dependency or compatibility issue with some linux distros.
 
Old 06-20-2012, 12:43 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
#4
Quote:
Takes time for recent releases to get added to repositories
It's about Redhat Enterprise Linux (EL 5) : Versions do not change !
( Except firefox and a couple of other packages.)

The most official git for EL5 is git-1.7.4.1-1.el5 from the EPEL.repo :
https://fedoraproject.org/wiki/EPEL

.
 
Old 06-20-2012, 03:50 AM   #6
Latman
LQ Newbie
 
Registered: Jun 2012
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
No git-1.7.11 in any repo ?

# yum install git : Version = git-1.7.10.4-1.el5.rf, "rpmforge repo"

http://wiki.centos.org/AdditionalRes...11404998926a1b
( http://ftp.is.co.za/mirror/ftp.rpmfo...6_64/dag/RPMS/ )

.
This is what I get:

]# yum install git : Version = git-1.7.10.4-1.el5.rf, "rpmforge repo"
Loaded plugins: rhnplugin, security
Setting up Install Process
No package git available.
No package : available.
No package Version available.
No package = available.
No package git-1.7.10.4-1.el5.rf, available.
No package rpmforge repo available.
Nothing to do
 
Old 06-20-2012, 02:59 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Please read how to add the rpmforge.repo ..
http://wiki.centos.org/AdditionalRes...11404998926a1b

The package install command is simply # yum install git
I.e. when the rpmforge.repo is enabled, you will get their version of git :
The package with the latest version number will always be preferred,
when more than one version is available.

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] git push in a git-init without --bare option? xeon123 Linux - Newbie 1 06-27-2011 04:44 AM
[SOLVED] Can't install Git repo (I don't git git ) Nemus Linux - Software 3 05-20-2011 03:09 PM
SBo-git - slackbuilds.org on git (with patches for current) ponce Slackware 47 03-12-2011 06:12 AM
why is git scm named 'git'? hottdogg Linux - General 5 02-03-2009 08:25 AM
inconsistency issue of git-clone ***/git/mesa/drm with the existing kernel source centguy Linux - Desktop 2 10-08-2008 11:36 PM


All times are GMT -5. The time now is 08:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration