LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-01-2011, 03:21 PM   #1
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Rep: Reputation: 0
Getting Xwindows to Run RHEL Server 6


I downloaded the demo for RHEL Server 6. I'd like to get Xwindows going, but have been thwarted thus far.

I have no real Linux experience, but I have been toying around with some suggestions already posted.

The last suggestion that I tried was to edit /etc/inittab file and change the value from 3 to 5. That didnt' work.

There's an X11 directory with a file called 'prefdm' that has a bunch of code in it that I have no idea what it means.

Can anyone shed some light on how to get X windows to start?
 
Old 05-01-2011, 06:13 PM   #2
plpl303a
Member
 
Registered: May 2011
Posts: 52

Rep: Reputation: 3
If you type 'startx' at the command prompt, that will start the X server. Do you get error messages from this, or does it work?
 
Old 05-01-2011, 06:30 PM   #3
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by plpl303a View Post
If you type 'startx' at the command prompt, that will start the X server. Do you get error messages from this, or does it work?
I get, 'command not found'
 
Old 05-02-2011, 10:39 AM   #4
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
I have the strong suspicion that x windows just isnt installed.

How does one go about installing the x windows from the DVD from the cmd line?
 
Old 05-02-2011, 11:07 AM   #5
elysianblue
LQ Newbie
 
Registered: Jun 2008
Posts: 3

Rep: Reputation: 0
look up yum for RHEL 6.
 
Old 05-02-2011, 12:01 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,446

Rep: Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798
Quote:
I downloaded the demo for RHEL Server 6
there might not be a gui for that
servers almost NEVER have one

everything is typed - no "point and click "

if you want a gui install gnome form the RHEL6 - desktop install
and BUY a license -- it is not free
 
Old 05-02-2011, 02:04 PM   #7
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by elysianblue View Post
look up yum for RHEL 6.
I just successfully installed X Windows guys, so it does look like X Windows supported for RHEL Server.

(I even got it to reboot after the install was complete, created a user name, setup the time/date and clicked finish.) It rebooted again after this configuration was complete.


NOW, it comes up in txt mode only, it won't go into X Windows/GNOME anymore. I execture 'startx' (as root or a normal user) and get this:


Code:
[root@redhat etc]# startx

hostname: Host name lookup failure
xauth:  creating new authority file /root/.serverauth.6816


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: x86-006 2.6.18-194.26.1.el5
Current Operating System: Linux redhat 2.6.32-71.24.1.el6.x86_64 #1 SMP Sat Mar 26 16:05:19 EDT 2011 x86_64
Kernel command line: ro root=/dev/mapper/vg_redhat-lv_root rd_LVM_LV=vg_redhat/lv_root rd_LVM_LV=vg_redhat/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=128M rhgb quiet
Build Date: 23 February 2011  07:36:44PM
Build ID: xorg-x11-server 1.7.7-26.el6_0.3
Current version of pixman: 0.18.4
        Before reporting problems, check https://www.redhat.com/apps/support/
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon May  2 13:49:31 2011
(==) Using default built-in configuration (30 lines)
(II) [KMS] Kernel modesetting enabled.

waiting for X server to shut down

[root@redhat etc]#

Here's the last little bit of the log file:

Code:
(II) RADEON(0): Monitor name: Smart Cable
(II) RADEON(0): EDID (in hex):
(II) RADEON(0):         00ffffffffffff0006cf000000000000
(II) RADEON(0):         000d01036e0000960eee91a3544c9926
(II) RADEON(0):         0f5054ffff008180814f8140714f714a
(II) RADEON(0):         71400101010164190040410026301888
(II) RADEON(0):         3600000000000018bc34009851002a40
(II) RADEON(0):         10901300000000000018000000fd0028
(II) RADEON(0):         641e5f15000a202020202020000000fc
(II) RADEON(0):         00536d617274204361626c650a2000c1
(II) RADEON(0): EDID vendor "AVO", prod id 0
(II) RADEON(0): Using EDID range info for horizontal sync
(II) RADEON(0): Using EDID range info for vertical refresh
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) RADEON(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 -hsync -vsync (80.0 kHz)
(II) RADEON(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) RADEON(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
(II) RADEON(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) RADEON(0): Modeline "640x480"x0.0   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
(II) RADEON(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
(II) RADEON(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) RADEON(0): Modeline "720x400"x0.0   35.50  720 738 846 900  400 421 423 449 -hsync -vsync (39.4 kHz)
(II) RADEON(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) RADEON(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0   44.90  1024 1032 1208 1264  768 768 772 817 interlace +hsync +vsync (35.5 kHz)
(II) RADEON(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) RADEON(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) RADEON(0): Modeline "800x600"x0.0   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) RADEON(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) RADEON(0): Modeline "1280x960"x75.0  129.86  1280 1368 1504 1728  960 961 964 1002 -hsync +vsync (75.1 kHz)
(II) RADEON(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
(II) RADEON(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
(II) RADEON(0): Modeline "1152x864"x70.0   96.77  1152 1224 1344 1536  864 865 868 900 -hsync +vsync (63.0 kHz)
(II) RADEON(0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz)
(II) RADEON(0): Printing probed modes for output VGA-0
(II) RADEON(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) RADEON(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
(II) RADEON(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 -hsync -vsync (80.0 kHz)
(II) RADEON(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) RADEON(0): Modeline "1280x960"x75.0  129.94  1280 1368 1504 1728  960 961 964 1002 -hsync +vsync (75.2 kHz)
(II) RADEON(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
(II) RADEON(0): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
(II) RADEON(0): Modeline "1152x864"x70.0   96.73  1152 1224 1344 1536  864 865 868 900 -hsync +vsync (63.0 kHz)
(II) RADEON(0): Modeline "1152x864"x60.0   81.58  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz)
(II) RADEON(0): Modeline "1024x768"x75.1   78.80  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.1 kHz)
(II) RADEON(0): Modeline "1024x768"x70.1   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
(II) RADEON(0): Modeline "832x624"x74.6   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) RADEON(0): Modeline "800x600"x72.2   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) RADEON(0): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) RADEON(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) RADEON(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
(II) RADEON(0): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 491 520 -hsync -vsync (37.9 kHz)
(II) RADEON(0): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) RADEON(0): Modeline "640x480"x66.7   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
(II) RADEON(0): Modeline "640x480"x60.0   25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) RADEON(0): Modeline "720x400"x87.8   35.50  720 738 846 900  400 421 423 449 -hsync -vsync (39.4 kHz)
(II) RADEON(0): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) RADEON(0): EDID for output VGA-1
(II) RADEON(0): EDID for output DVI-0
(II) RADEON(0): Output VGA-0 connected
(II) RADEON(0): Output VGA-1 disconnected
(II) RADEON(0): Output DVI-0 disconnected
(II) RADEON(0): Using exact sizes for initial modes
(II) RADEON(0): Output VGA-0 using initial mode 1024x768 +0+0
(II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
(II) RADEON(0): mem size init: gart size :1fdff000 vram size: s:1000000 visible:f00000
(II) RADEON(0): EXA: Driver will not allow EXA pixmaps in VRAM
(==) RADEON(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) Loading sub module "exa"
(II) LoadModule: "exa"
(II) Loading /usr/lib64/xorg/modules/libexa.so
(II) Module exa: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 2.5.0
        ABI class: X.Org Video Driver, version 6.0
(II) UnloadModule: "vesa"
(II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
(II) UnloadModule: "fbdev"
(II) Unloading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/lib64/xorg/modules/linux/libfbdevhw.so
(--) Depth 24 pixmap format is 32 bpp
(II) RADEON(0): [DRI2] Setup complete
(II) RADEON(0): Front buffer size: 3072K
(II) RADEON(0): VRAM usage limit set to 11059K
(==) RADEON(0): Backing store disabled
(II) RADEON(0): Direct rendering enabled
(II) RADEON(0): Render acceleration enabled for R100 type cards.
(II) RADEON(0): Setting EXA maxPitchBytes
(II) EXA(0): Driver allocated offscreen pixmaps
(II) EXA(0): Driver registered support for the following operations:
(II)         Solid
(II)         Copy
(II)         Composite (RENDER acceleration)
(II)         UploadToScreen
(II)         DownloadFromScreen
(II) RADEON(0): Acceleration enabled
(==) RADEON(0): DPMS enabled
(==) RADEON(0): Silken mouse enabled
(II) RADEON(0): Set up textured video
(II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) SELinux: Disabled by boolean
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized /usr/lib64/dri/radeon_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) RADEON(0): Setting screen physical size to 270 x 203
(II) config/hal: Adding input device ImExPS/2 Generic Explorer Mouse
(II) LoadModule: "evdev"
(II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.7.7, module version = 2.3.2
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0
(**) ImExPS/2 Generic Explorer Mouse: always reports core events
(**) ImExPS/2 Generic Explorer Mouse: Device: "/dev/input/event3"
(II) ImExPS/2 Generic Explorer Mouse: Found 9 mouse buttons
(II) ImExPS/2 Generic Explorer Mouse: Found scroll wheel(s)
(II) ImExPS/2 Generic Explorer Mouse: Found relative axes
(II) ImExPS/2 Generic Explorer Mouse: Found x and y relative axes
(II) ImExPS/2 Generic Explorer Mouse: Configuring as mouse
(**) ImExPS/2 Generic Explorer Mouse: YAxisMapping: buttons 4 and 5
(**) ImExPS/2 Generic Explorer Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE)
(**) ImExPS/2 Generic Explorer Mouse: (accel) keeping acceleration scheme 1
(**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration profile 0
(II) ImExPS/2 Generic Explorer Mouse: initialized for relative axes.
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105+inet"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event4"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105+inet"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event0"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105+inet"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Macintosh mouse button emulation
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event1"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) acceleration profile 0
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) ImExPS/2 Generic Explorer Mouse: Close
(II) UnloadModule: "evdev"
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) Video Bus: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
[root@redhat log]#

Last edited by afrojoe; 05-02-2011 at 02:07 PM.
 
Old 05-02-2011, 02:26 PM   #8
John VV
Guru
 
Registered: Aug 2005
Posts: 13,446

Rep: Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798
with gnome installed gdm starts the gui not startx


did you install the desktop ?
check my spelling with yum
Code:
su -
yum groupinstall " Gnome Desktop Enviroment"
to check
Code:
su -
yum grouplist
that will give you a list copy/paste the name
 
Old 05-02-2011, 02:43 PM   #9
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Code:
[root@redhat ~]# yum groupinstall "Gnome Desktop Enviroment"
Loaded plugins: rhnplugin
Setting up Group Process
Warning: Group Gnome Desktop Enviroment does not exist.
No packages in any requested group available to install or update
[root@redhat ~]#
I guess the GDE isn't installed???
 
Old 05-02-2011, 02:46 PM   #10
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Also:

Code:
[root@redhat ~]# su -
[root@redhat ~]# yum grouplist
Loaded plugins: rhnplugin
Setting up Group Process
Installed Groups:
   Additional Development
   Arabic Support
   Armenian Support
   Base
   Console internet tools
   Debugging Tools
   Desktop Debugging and Performance Tools
   Directory Client
   E-mail server
   Fonts
   General Purpose Desktop
   Georgian Support
   Graphical Administration Tools
   Hardware monitoring utilities
   Hebrew Support
   Inuktitut Support
   Java Platform
   Lao Support
   Large Systems Performance
   Legacy UNIX compatibility
   Legacy X Window System compatibility
   NFS file server
   Network file system client
   Networking Tools
   Performance Tools
   Perl Support
   Scientific support
   Server Platform
   Tajik Support
   X Window System
Available Groups:
   Afrikaans Support
   Albanian Support
   Amazigh Support
   Assamese Support
   Azerbaijani Support
   Backup Client
   Backup Server
   Basque Support
   Belarusian Support
   Bengali Support
   Bhutanese Support
   Brazilian Portuguese Support
   Breton Support
   Bulgarian Support
   CIFS file server
   Catalan Support
   Chhattisgarhi Support
   Chichewa Support
   Chinese Support
   Compatibility libraries
   Coptic Support
   Croatian Support
   Czech Support
   Danish Support
   Desktop
   Desktop Platform
   Desktop Platform Development
   Development tools
   Dial-up Networking Support
   Directory Server
   Dutch Support
   Eclipse
   Emacs
   English (UK) Support
   Esperanto Support
   Estonian Support
   Ethiopic Support
   FCoE Storage Client
   FTP server
   Faroese Support
   Fijian Support
   Filipino Support
   Finnish Support
   French Support
   Frisian Support
   Friulian Support
   Gaelic Support
   Galician Support
   German Support
   Graphics Creation Tools
   Greek Support
   Gujarati Support
   Hiligaynon Support
   Hindi Support
   Hungarian Support
   Icelandic Support
   Indonesian Support
   Infiniband Support
   Input Methods
   Interlingua Support
   Internet Browser
   Irish Support
   Italian Support
   Japanese Support
   KDE Desktop
   Kannada Support
   Kashmiri Support
   Kashubian Support
   Kazakh Support
   Khmer Support
   Kinyarwanda Support
   Konkani Support
   Korean Support
   Kurdish Support
   Latin Support
   Latvian Support
   Lithuanian Support
   Low Saxon Support
   Luxembourgish Support
   Macedonian Support
   Mainframe Access
   Maithili Support
   Malagasy Support
   Malay Support
   Malayalam Support
   Maltese Support
   Manx Support
   Maori Support
   Marathi Support
   Messaging Client Support
   Messaging Server Support
   Mongolian Support
   MySQL Database client
   MySQL Database server
   Myanmar (Burmese) Support
   Nepali Support
   Network Infrastructure Server
   Network Storage Server
   Northern Sotho Support
   Norwegian Support
   Occitan Support
   Oriya Support
   PHP Support
   Persian Support
   Polish Support
   Portuguese Support
   PostgreSQL Database client
   PostgreSQL Database server
   Print Server
   Printing client
   Punjabi Support
   Remote Desktop Clients
   Romanian Support
   Russian Support
   SNMP Support
   Sanskrit Support
   Sardinian Support
   Security Tools
   Serbian Support
   Server Platform Development
   Sindhi Support
   Sinhala Support
   Slovak Support
   Slovenian Support
   Smart card support
   Somali Support
   Southern Ndebele Support
   Southern Sotho Support
   Spanish Support
   Storage Availability Tools
   Swahili Support
   Swati Support
   Swedish Support
   System Management
   System administration tools
   Tagalog Support
   Tamil Support
   TeX support
   Technical Writing
   Telugu Support
   Tetum Support
   Thai Support
   Tibetan Support
   Tsonga Support
   Tswana Support
   TurboGears application framework
   Turkish Support
   Turkmen Support
   Ukrainian Support
   Upper Sorbian Support
   Urdu Support
   Uzbek Support
   Venda Support
   Vietnamese Support
   Virtualization
   Virtualization Client
   Virtualization Platform
   Virtualization Tools
   Walloon Support
   Web Server
   Web Servlet Engine
   Web-Based Enterprise Management
   Welsh Support
   Xhosa Support
   Zulu Support
   iSCSI Storage Client
Done
[root@redhat ~]#
 
Old 05-02-2011, 03:17 PM   #11
John VV
Guru
 
Registered: Aug 2005
Posts: 13,446

Rep: Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798
my oops sorry
i guess red hat changed some names in 6

"General Purpose Desktop" is installed

GDM is " Gnome Desktop Manager"
just like
KDM is "KDE Desktop Manager"

look under gnome in yum
Code:
 yum search gdm
- or -- 
 yum search gnome
there will be a long list for gnome


from looking at the list of what is NOT installed
this stands out "Web Server" Apache server and MySQL are not installed on a SERVER version of rhel ??? odd


have you read and reread the rhel install guides and documentation ?
-- main page
http://www.redhat.com/support/
-- docs
https://access.redhat.com/knowledge/...erprise_Linux/
-- install guide --
http://docs.redhat.com/docs/en-US/Re...ide/index.html
 
Old 05-02-2011, 04:52 PM   #12
abi0909
Member
 
Registered: Jul 2009
Distribution: Ubuntu, RedHat, VMWare, CentOS, Windows, Android, Mac
Posts: 55

Rep: Reputation: 18
Few questions:

* Have you configured the yum correctly. Does it point you to the correct yum repo server?
* What do you get when you do as root:

Quote:
rpm -qa x*
* What are you trying to do by saying

Quote:
I downloaded the demo for RHEL Server 6. I'd like to get Xwindows going, but have been thwarted thus far.
 
Old 05-02-2011, 07:14 PM   #13
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
When I run rpm -qa x* I get:

Code:
[root@redhat ~]# rpm -qa x*
xorg-x11-drv-evdev-2.3.2-8.el6.x86_64
xorg-x11-drv-wacom-0.10.5-6.el6_0.2.x86_64
xorg-x11-drv-dummy-0.3.3-1.el6.x86_64
xorg-x11-drv-trident-1.3.3-1.1.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-8.20100423git13c1043.el6.x86_64
xorg-x11-drv-mach64-6.8.2-1.1.el6.x86_64
xorg-x11-drv-vmmouse-12.6.5-3.el6.x86_64
xorg-x11-drv-apm-1.2.2-1.1.el6.x86_64
xorg-x11-drv-v4l-0.2.0-3.el6.3.x86_64
xorg-x11-drv-glint-1.2.4-1.1.el6.x86_64
xorg-x11-drv-siliconmotion-1.7.3-1.1.el6.x86_64
xulrunner-1.9.2.17-4.el6_0.x86_64
xvattr-1.3-18.el6.x86_64
xmlrpc-c-1.16.24-1200.1840.el6.x86_64
xdg-utils-1.0.2-15.20091016cvs.el6.noarch
xz-lzma-compat-4.999.9-0.3.beta.20091007git.el6.x86_64
xmlrpc-c-client-1.16.24-1200.1840.el6.x86_64
xorg-x11-xauth-1.0.2-7.1.el6.x86_64
xorg-x11-server-utils-7.4-15.el6_0.2.x86_64
xorg-x11-xkb-utils-7.4-6.el6.x86_64
xml-common-0.6.3-32.el6.noarch
xorg-x11-server-common-1.7.7-26.el6_0.3.x86_64
xorg-x11-drv-void-1.3.0-4.el6.x86_64
xorg-x11-server-Xorg-1.7.7-26.el6_0.3.x86_64
xorg-x11-drv-mouse-1.5.0-4.el6.x86_64
xorg-x11-drv-mga-1.4.12-2.el6.x86_64
xorg-x11-drv-sisusb-0.9.3-1.1.el6.x86_64
xorg-x11-drv-mutouch-1.2.1-5.el6.x86_64
xorg-x11-drv-i128-1.3.3-1.1.el6.x86_64
xorg-x11-drv-r128-6.8.1-2.el6.x86_64
xorg-x11-drv-aiptek-1.3.0-2.el6.x86_64
xorg-x11-drv-i740-1.3.2-1.1.el6.x86_64
xorg-x11-drv-vmware-10.16.7-2.1.el6.x86_64
xorg-x11-drv-rendition-4.2.2-4.1.el6.x86_64
xorg-x11-drv-fbdev-0.4.2-1.el6.x86_64
xorg-x11-drv-elographics-1.2.3-5.el6.x86_64
xorg-x11-drv-acecad-1.4.0-2.el6.x86_64
xorg-x11-drv-savage-2.3.1-1.1.el6.x86_64
xorg-x11-drv-sis-0.10.2-1.1.el6.x86_64
xorg-x11-drv-penmount-1.4.0-5.el6.x86_64
xorg-x11-drv-intel-2.11.0-7.el6.x86_64
xorg-x11-drv-ast-0.89.9-1.1.el6.x86_64
xorg-x11-drv-synaptics-1.2.1-5.el6.x86_64
xorg-x11-drv-nv-2.1.15-4.el6.x86_64
xorg-x11-xinit-1.0.9-13.el6.x86_64
xorg-x11-drv-ati-firmware-6.13.0-6.el6.noarch
xcb-util-0.3.6-1.el6.x86_64
xz-libs-4.999.9-0.3.beta.20091007git.el6.x86_64
xkeyboard-config-1.6-7.el6.noarch
xz-4.999.9-0.3.beta.20091007git.el6.x86_64
xorg-x11-drv-vesa-2.3.0-1.el6.x86_64
xorg-x11-drv-openchrome-0.2.904-1.el6.x86_64
xorg-x11-drv-keyboard-1.4.0-3.el6.x86_64
xorg-x11-drv-qxl-0.0.12-2.1.el6_0.1.x86_64
xorg-x11-drv-tdfx-1.4.3-1.1.el6.x86_64
xorg-x11-drv-ati-6.13.0-6.el6.x86_64
xorg-x11-drv-hyperpen-1.3.0-4.el6.x86_64
xorg-x11-drv-cirrus-1.3.2-1.1.el6.x86_64
xorg-x11-drv-fpit-1.3.0-5.el6.x86_64
xorg-x11-drv-s3virge-1.10.4-1.1.el6.x86_64
xorg-x11-drv-voodoo-1.2.3-1.1.el6.x86_64
xorg-x11-utils-7.4-8.el6.x86_64
xorg-x11-drivers-7.3-13.2.el6.x86_64
[root@redhat ~]#
Quote:
* What are you trying to do by saying: "I downloaded the demo for RHEL Server 6. I'd like to get Xwindows going, but have been thwarted thus far."
I downloaded RHEL Server 6 (demo version) and I'd like to install X WINDOWS & the GNOME Desktop

Last edited by afrojoe; 05-02-2011 at 07:19 PM.
 
Old 05-02-2011, 09:20 PM   #14
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
I'd guess these 2 groups
Quote:
Desktop
Desktop Platform
from the Avail Groups list need installing...
 
Old 05-02-2011, 09:57 PM   #15
afrojoe
LQ Newbie
 
Registered: Apr 2011
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chrism01 View Post
I'd guess these 2 groups

from the Avail Groups list need installing...
OMG, I think you're right!!!!!11!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to run any command on server with RHEL 3 ES due to Relocation Error. pushpa_dwivedi Linux - Server 3 10-29-2010 03:25 AM
[SOLVED] How to tell if e2fsck will automatically run when I restart RHEL server? rjo98 Linux - Newbie 7 09-30-2009 08:03 PM
trying to fix xwindows or just run command line... changing run levels dave247 Debian 2 11-18-2008 07:11 PM
How do you run tightvnc server on RHEL so that it matches your gui screen? daveb1040 Linux - Newbie 1 12-23-2006 02:50 PM
RHEL 3 update 5 with LAuS in XWindows?? Lan_61 Linux - Enterprise 0 10-03-2005 10:45 AM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration