LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2009, 02:29 PM   #1
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Rep: Reputation: 0
getting wireless connection to work


I have an old ACER ASPIRE 3000 windows XP decided not to work on. I was given a fedora 10 dvd by my brother an told to try. Every thing works well for now except I can't get a wireless connection.
 
Old 09-27-2009, 02:46 PM   #2
lhorace
Member
 
Registered: Aug 2009
Distribution: Fedora
Posts: 126

Rep: Reputation: 21
You need to post more information, what exactly do you mean it's not working. First, what desktop environment are using, Gnome or KDE. By default, gnome comes with nm-applet to connect to wireless networks. What does it say when you connect? Check you logs in /var/log, especially messages when any network errors would logged there.
 
Old 09-28-2009, 10:24 AM   #3
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Original Poster
Rep: Reputation: 0
I am using Gnome 2.24.3, processor is mobile AMD Sempron(tm). Kemel Linux 2.6.27.30-170.2.82fc10.i686
 
Old 09-28-2009, 10:40 AM   #4
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Original Poster
Rep: Reputation: 0
I also get an error nm-applet is not responding
 
Old 09-28-2009, 11:26 AM   #5
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
In terminal run the command 'lspci' without the quotes.
We need to figure out which chipset your wireless card uses. Copy and paste the results here.
 
Old 09-28-2009, 05:39 PM   #6
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Original Poster
Rep: Reputation: 0
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (r
ev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Soun
d Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev
0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev
0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Et
hernet (rev 91)
00:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (re
v 02)
00:0b.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.
11g Wireless LAN Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTra
nsport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address
Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Con
troller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscella
neous Control
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760
PCI/AGP or 662/761Gx PCIE VGA Display Adapter
[RAY@localhost ~]$
 
Old 09-28-2009, 07:23 PM   #7
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
You have a Broadcom BCM4318 wireless card. I am not a fedora man but the driver should already be installed. The driver name would be bcm43. It should be a matter of setting up the wireless network.
 
Old 09-29-2009, 12:54 PM   #8
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Original Poster
Rep: Reputation: 0
I am having trouble activating the wireless connection when I set it up. I am sure I am missing something simple but linux is new to me
 
Old 09-29-2009, 01:17 PM   #9
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,051

Rep: Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852Reputation: 852
fyi maybe fedora-11 has the driver by default ?

can you post the results of:
ifconfig
ifconfig -a
iwconfig

does the network manager applet on the top rite list any wireless access points ?
______________________

maybe the driver located here mite work: http://www.broadcom.com/support/802.11/linux_sta.php
(worked with my: 03:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01))
else yum install broadcom-wl mite do it

Last edited by schneidz; 09-29-2009 at 01:24 PM.
 
Old 09-29-2009, 03:42 PM   #10
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Original Poster
Rep: Reputation: 0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1040 (1.0 KiB) TX bytes:1040 (1.0 KiB)

wlan0 Link encap:Ethernet HWaddr 00:14:A4:38:5A:5F
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wmaster0 Link encap:UNSPEC HWaddr 00-14-A4-38-5A-5F-F4-DF-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
 
Old 09-29-2009, 03:43 PM   #11
rayhill1
LQ Newbie
 
Registered: Sep 2009
Posts: 22

Original Poster
Rep: Reputation: 0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

[RAY@localhost ~]$ ifconfig-a
bash: ifconfig-a: command not found
[RAY@localhost ~]$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Elonex one cant get wireless connection to work rodtheprod Linux - Wireless Networking 1 09-30-2009 07:33 PM
wireless connection problems & now lost lan connection & network manager wont work Rainbowserpant Linux - Wireless Networking 2 09-02-2009 05:00 AM
Gutsy wireless connection does not work/ wired works aio85 Linux - Newbie 5 01-14-2008 01:14 PM
ipw2100 - Unable to get wireless connection to work jubilee33 Linux - Wireless Networking 3 08-26-2006 11:20 AM
cannot get wireless connection to work on suse Armon Linux - Wireless Networking 0 07-11-2006 02:13 AM


All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration