LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2014, 11:24 AM   #1
wspark
LQ Newbie
 
Registered: Nov 2014
Distribution: Debian
Posts: 7

Rep: Reputation: Disabled
Getting Wifi to work -- Atheros AR9565, Debian Wheezy


Hi all,

Totally new to Linux, have always been curious and have wanted to really get into it - finally made the jump to Debian Wheezy.

It's been tricky so far, but I've manged to install, add non-free and backports repositories in my sources.list, and got most codecs, flash, etc. installed on my Acer laptop. However, Wifi is still having problems.

By typing "lspci", I see that I have an Atheros AR9565 wireless card.

I have tried "aptitude install firmware-atheros" for atheros cards in the non-free repository, but that doesn't seem to work.

I've noted someone making it work in this thread below, but I'm not versed in Linux well enough to undestand what steps I need to take to replice this user's success.
http://forums.debian.net/viewtopic.php?t=107377

I see notes about installing initramfs-tools and linux-image-3.10-0.bpo.2-amd64, but this is where my understanding about what steps they're taking isn't clear on me... Help anyone?
 
Old 11-14-2014, 11:49 AM   #2
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,387

Rep: Reputation: 173Reputation: 173
Someone new to linux should use one of pre-configured Linux distros like linux Mint, that comes with drivers pre-installed. The guy in your link also says that it works on Ubuntu. Ubuntu is not much different from Debian.

4 ways to get wifi working on linuxhttp://www.blores.com/2010/07/how-to...rivers-on.html
 
Old 11-14-2014, 01:04 PM   #3
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia 3, Debian Wheezy, Maemo, Linux Mint 14.
Posts: 200

Rep: Reputation: Disabled
Atheros drivers should be in the kernel. You probably have to install the firmware in debian. But you did that... So.

Which kernel do you have? ("uname -a")
Perhaps check in /boot/config if atheros ath9k is included, and the others. I dont know which atheroes driver your card uses.

Perhaps this could be helpful:
http://wireless.kernel.org/en/users/Drivers/Atheros

In debian it might be as simple as "ifconfig wlan0 up". What does ifconfig say exactly? Do down first and then up if it is already there. Perhaps you even have to use iwconfig, wpa_supplicant and dhcpcd.

If that is the case, do:
ifconfig wlan0 down
ifconfig wlan0 up
dhcpcd wlan0

in terminal window, as root.

Last edited by zeebra; 11-14-2014 at 01:07 PM.
 
1 members found this post helpful.
Old 11-14-2014, 01:09 PM   #4
zeebra
Member
 
Registered: Dec 2011
Distribution: Mageia 3, Debian Wheezy, Maemo, Linux Mint 14.
Posts: 200

Rep: Reputation: Disabled
Quote:
Originally Posted by yooy View Post
Someone new to linux should use one of pre-configured Linux distros like linux Mint, that comes with drivers pre-installed. The guy in your link also says that it works on Ubuntu. Ubuntu is not much different from Debian.

4 ways to get wifi working on linuxhttp://www.blores.com/2010/07/how-to...rivers-on.html
Why do you say that? What you suggest about him switching to another distro is not helpful. Good if he is a newbie and starting with debian, then atleast he can perhaps learn something along the way.
 
Old 11-14-2014, 06:16 PM   #5
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,647
Blog Entries: 8

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
If you have the firmware installed, try following the instructions on the wiki. (The wiki is a great resource for configuring the system.)
https://wiki.debian.org/WiFi/HowToUse
When I used Debian, I edited my /etc/network/interfaces file as per the wiki's instructions:

Code:
# my wifi device auto wlan0 
iface wlan0 inet dhcp 
wireless-essid [ESSID]
wireless-mode [MODE]
I did not add the wireless-mode entry. I only had to add an ESSID entry. If I remember correctly, it was simply my host name. For example; wspark.debian.org. Of course, you will need to enter whatever host name you gave your system.

Last edited by Randicus Draco Albus; 11-14-2014 at 06:18 PM.
 
Old 11-14-2014, 06:25 PM   #6
wspark
LQ Newbie
 
Registered: Nov 2014
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by zeebra View Post
Atheros drivers should be in the kernel. You probably have to install the firmware in debian. But you did that... So.

Which kernel do you have? ("uname -a")
Thanks for the advice. I have:

Linux E3-111 3.2.0-4-amd64 #1 SMP Debian 3.2.63-2+deb7u1 x86_64 GNU/Linux

Quote:
Perhaps check in /boot/config if atheros ath9k is included, and the others. I dont know which atheroes driver your card uses.
I opened config-3.2.0-4-amd64 in a text editor and searched for anything with ath9k and found this:

CONFIG_ATH9K_HW=m
CONFIG_ATH9K_COMMON=m
CONFIG_ATH9K=m
CONFIG_ATH9K_PCI=y
# CONFIG_ATH9K_AHB is not set
# CONFIG_ATH9K_DEBUGFS is not set
# CONFIG_ATH9K_LEGACY_RATE_CONTROL is not set
CONFIG_ATH9K_HTC=m
# CONFIG_ATH9K_HTC_DEBUGFS is not set

Quote:
Perhaps this could be helpful:
http://wireless.kernel.org/en/users/Drivers/Atheros
Is states under the link that:

Get the latest ath9k driver

Any distribution shipping a kernel >= 2.6.27 will have ath9k present but the ath9k driver on 2.6.32 is the oldest one recommended, anything older than that is completely unsupported.

Supported chipsets

SB = single-band 2.4GHz DB = dual-band 2.4GHz or 5GHz
...
...
AR9004:

AR9485 1x1 SB 11n PCIe
AR9462 2x2 DB 11n PCIe
AR9565 1x1 SB 11n PCIe
AR9580 3x3 DB 11n PCIe
AR9550 3x3 DB 11n

Quote:
In debian it might be as simple as "ifconfig wlan0 up". What does ifconfig say exactly? Do down first and then up if it is already there. Perhaps you even have to use iwconfig, wpa_supplicant and dhcpcd.

If that is the case, do:
ifconfig wlan0 down
ifconfig wlan0 up
dhcpcd wlan0

in terminal window, as root.
wlan0 doesn't exist so using the ...down or ...up command shows "No such device" error. And dhcpcd command produces "bash: dhcpcd: command not found" error.

Typing ifconfig shows as per below:

eth0 Link encap:Ethernet HWaddr c4:54:44:6a:d6:d3
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::c654:44ff:fe6a:d6d3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1147632 errors:0 dropped:0 overruns:0 frame:0
TX packets:713804 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1540722232 (1.4 GiB) TX bytes:60900293 (58.0 MiB)
Interrupt:103 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)
 
Old 11-14-2014, 06:52 PM   #7
wspark
LQ Newbie
 
Registered: Nov 2014
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Randicus Draco Albus View Post
If you have the firmware installed, try following the instructions on the wiki. (The wiki is a great resource for configuring the system.)
https://wiki.debian.org/WiFi/HowToUse
When I used Debian, I edited my /etc/network/interfaces file as per the wiki's instructions:

Code:
# my wifi device auto wlan0 
iface wlan0 inet dhcp 
wireless-essid [ESSID]
wireless-mode [MODE]
I did not add the wireless-mode entry. I only had to add an ESSID entry. If I remember correctly, it was simply my host name. For example; wspark.debian.org. Of course, you will need to enter whatever host name you gave your system.
Thanks, if I type "hostname" I simply get "E3-111" - as you say, what I named by system.

Code:
root@E3-111:/etc/network# hostname
E3-111
So far, I've simply added the section in /etc/network/interfaces

Code:
# my wifi device auto wlan0 
iface wlan0 inet dhcp 
wireless-essid E3-111
That hasn't done anything I noticed... (No wifi signals in icons, etc).

Last edited by wspark; 11-14-2014 at 07:02 PM. Reason: reread it...
 
Old 11-14-2014, 07:10 PM   #8
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,647
Blog Entries: 8

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
Quote:
wlan0 doesn't exist so using the ...down or ...up command shows "No such device" error.
Try wlan1.
 
Old 11-14-2014, 07:23 PM   #9
wspark
LQ Newbie
 
Registered: Nov 2014
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Randicus Draco Albus View Post
Try wlan1.
Same - there's no wlan* devices if I type ifconfig. I just see eth0 and lo.

Code:
eth0      Link encap:Ethernet  HWaddr c4:54:44:6a:d6:d3  
          inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c654:44ff:fe6a:d6d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9068 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8195 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5815280 (5.5 MiB)  TX bytes:2427225 (2.3 MiB)
          Interrupt:103 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:480 (480.0 B)  TX bytes:480 (480.0 B)
 
Old 11-14-2014, 10:12 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Have you tried
Quote:
modprobe ath9k
 
Old 11-14-2014, 11:07 PM   #11
wspark
LQ Newbie
 
Registered: Nov 2014
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
Have you tried
Just tried, and it hasn't made any noticeable difference...
 
Old 11-15-2014, 12:48 AM   #12
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
What about
Quote:
rfkill list
Quote:
iwlist wlan0 scanning
or
Quote:
iwlist wlan0 scan
Another question is E3-111 the model of laptop?
If it is try the Fn+F3 key to see if wireless is activated
Have you checked in dmesg?

Last edited by EDDY1; 11-15-2014 at 12:58 AM.
 
Old 11-15-2014, 01:31 AM   #13
wspark
LQ Newbie
 
Registered: Nov 2014
Distribution: Debian
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
What about or
Another question is E3-111 the model of laptop?
If it is try the Fn+F3 key to see if wireless is activated
Have you checked in dmesg?
Correct, E3-111 is the model.

Fn-F3 doesn't do anything noticeable. And above commands show as below (I'm assuming the last 2 commands show as below because there is no wlan* device):

Code:
root@E3-111:/home/wspark# rfkill list
bash: rfkill: command not found
root@E3-111:/home/wspark# iwlist wlan0 scanning
wlan0     Interface doesn't support scanning.

root@E3-111:/home/wspark# iwlist wlan0 scan
wlan0     Interface doesn't support scanning.

root@E3-111:/home/wspark#
 
Old 11-15-2014, 02:07 AM   #14
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Not installed
Quote:
apt-get install rfkill
also
Quote:
lsmod

Last edited by EDDY1; 11-15-2014 at 02:08 AM.
 
Old 11-15-2014, 05:21 AM   #15
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,465

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Quote:
Originally Posted by wspark View Post
I have tried "aptitude install firmware-atheros" for atheros cards in the non-free repository, but that doesn't seem to work.
^^ This?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RFkill is killing me, no wifi, soft block, Debian Wheezy, RTL8187 Rich3077 Linux - Newbie 13 07-29-2015 12:10 PM
Wifi not recognized - Debian wheezy IBM R31 eranj1 Linux - Laptop and Netbook 4 04-05-2013 10:42 PM
Trying to get Atheros Wifi to work on RaspBMC Da9L Linux - Newbie 1 11-27-2012 03:53 PM
Debian can't enable wifi. Atheros AR9285 card. Using ath9k driver. Greet Linux - Networking 3 01-05-2012 09:55 PM
Debian murdered my Atheros WiFi suChris Linux - Hardware 2 11-30-2009 08:21 PM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration