LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-14-2011, 01:07 PM   #16
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7

One odd thing I have noted from reading (and rereading and rereading ...) the log files I copied above. From the lspci command, I see:

Capabilities: [140] Virtual Channel <?>
Kernel modules: ath5k

Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-01
Kernel driver in use: r8169
Kernel modules: r8169

The first set is the bottom two lines about the wireless chip and the second set is the bottom three lines about the wired chip. I can see that the kernel has modules for both, but only the wired chip shows a driver in use. Could this be the problem? If so, how do I go about enabling the driver?

Thanks,
Toad
 
Old 06-14-2011, 11:01 PM   #17
hitmen
Member
 
Registered: Jun 2011
Distribution: Kubuntu 10.04
Posts: 158

Rep: Reputation: Disabled
If in ubuntu, goto system> preferences> network settings
do you see anything out of the ordinary?
 
Old 06-15-2011, 02:49 AM   #18
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
I can see that the kernel has modules for both, but only the wired chip shows a driver in use. Could this be the problem?
Yes
Quote:
If so, how do I go about enabling the driver?
Did you follow the link given to you at post #8 ? This tells you which modules to install, and how.
 
Old 06-15-2011, 09:05 AM   #19
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
Quote:
Originally Posted by hitmen View Post
If in ubuntu, goto system> preferences> network settings
do you see anything out of the ordinary?
The only driver which shows up is my video driver. There is no wireless driver shown.

Quote:
Originally Posted by tredegar View Post
Did you follow the link given to you at post #8 ? This tells you which modules to install, and how.
I did follow the link mentioned by snowpine. The solution listed there doesn't work, probably because my machine is an HP not an ACER. I assume the fix shown alters the order of driver loading, but if you don't have the driver that person had ... From my reading of that thread, it seems that he had two drivers in use on his wifi card. I don't have any drivers in use.

I also followed that thread even further to a closed bug report about Atheros wifi cards on IBM Thinkpads. (https://bugs.launchpad.net/ubuntu/+s...ux/+bug/461419) The bug specifies IBM hardware, but I'm seeing many of the same issues reported there. I'm a techie myself, but it's above my head in areas. There is a patch listed, and I'm still trying to figure out what to do with it. It looks like a script, but I don't know what runs it. It doesn't appear to be a shell script. I am still trying to determine if I should open a new bug referencing the old one, and indicating the problem may not be limited to IBM hardware. I'd appreciate any opinions.

I did get wicd running, but this did not solve the problem. Scanning for networks says none are available, but my Android cell phone can detect 3 powerful ones in the vicinity, one of which is mine.

I've acquired an HP DV8140US laptop, which uses the Broadcom 4318 wifi card. Same problem. Of course, both Broadcom and Atheros are widely known to have issues with Linux. Practically every wireless question on several sites involved one of those cards. I am having the same problems with it, i.e. no driver listed under system> preferences> network settings and no networks detected.

I guess no one has solved this, and the most hopeful thing I have read so far is to buy new cards. I'm planning to get Intel cards for both. They at least have a reputation for working.

Thanks for your help. If you have further suggestions, I'd be glad to try them.

Last edited by Toadbrooks; 06-15-2011 at 09:17 AM. Reason: spelling corrections
 
Old 06-15-2011, 11:47 AM   #20
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Your machine being HP and not Acer does not matter. It's the chipset that matters (Atheros AR5001 in your case it seems).

Install linux-backports-modules-headers-lucid-generic and
linux-backports-modules-wireless-lucid-generic with

Code:
sudo apt-get install linux-backports-modules-headers-lucid-generic
sudo apt-get install linux-backports-modules-wireless-lucid-generic
then

Code:
sudo modprobe -rv ath5k
sudo modprobe acer-wmi
sudo modprobe -v ath5k
If there are error messages, please post them.

Check your chipset is working with
Code:
iwlist scan
You should see at least one network (yours).

Now you should be able to use wicd to connect to your network.

Note it is worth doing this all over again, as it seems to have fixed everyone else's problems, and should yours too.

Note also that this will not survive a reboot, but if you can at least get your wireless working, we can fix the reboot issue.
 
1 members found this post helpful.
Old 06-16-2011, 07:41 AM   #21
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
... then

Code:
sudo modprobe -rv ath5k
sudo modprobe acer-wmi
sudo modprobe -v ath5k
If there are error messages, please post them.

Same as last time, when I do the "acer" line, I get:

FATAL: Error inserting acer_wmi (/lib/modules/2.6.32-32-generic/kernel/drivers/platform/x86/acer-wmi.ko): No such device

Continued with the final command, which seems to have worked. (Of course, all it did was reverse the previous one.) Then:

tom@Owl:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Failed to read scan data : Network is down

OK, if it should have worked, then something else is wrong. I am running the 64-bit Linux, since I have an AMD CPU. Would I be better off converting back to 32-bit again?

Last edited by Toadbrooks; 06-16-2011 at 07:43 AM. Reason: copy and paste removed spaces from the original. Tried to put them back.
 
Old 06-16-2011, 11:28 AM   #22
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Thanks for trying that.
Quote:
wlan0 Failed to read scan data : Network is down
I am wondering if your wireless is switched on / enabled (often shown by a blue LED somewhere on a laptop).

Please double-check for a Fn-Key combination (Eg Fn-F2), a little slider switch somewhere (noted to be loose and unrelaible on some Sony Vaio's), or try using rfkill to enable it, or un-disable it.

As for 32-bit, you could try booting from a live 32-bit CD, and see if that is any better.
 
1 members found this post helpful.
Old 06-16-2011, 02:40 PM   #23
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
Quote:
Originally Posted by tredegar View Post
Thanks for trying that.
Thanks for suggesting it. Never hurts to be sure. Besides, when it failed the first time, I was sure it was because I don't have an Acer. That's good information to know.

Quote:
Originally Posted by tredegar View Post
I am wondering if your wireless is switched on / enabled (often shown by a blue LED somewhere on a laptop).

Please double-check for a Fn-Key combination (Eg Fn-F2), a little slider switch somewhere (noted to be loose and unrelaible on some Sony Vaio's), or try using rfkill to enable it, or un-disable it.

As for 32-bit, you could try booting from a live 32-bit CD, and see if that is any better.
Well, the blue light is lit. There's a touch spot on the multimedia panel above the keyboard that turns it off (light turns orange.) With HP laptops and Linux, once wireless is turned off it has to be rebooted to get it back on (actually the light will go back to blue, but the wireless stays off. Had this same problem with Heron a few years ago.) At least that is the way it used to work. Whether it actually means the same thing with Lynx or whether the light means anything at all, I can't say for sure. My guess would have been that it does, but I've had so much trouble trying to get wireless to work that I'm not sure of anything.

I will do a man on rfkill when I get home and try that. I'll also try the live CD boot this evening. Thanks for the suggestions.

-------------------
When I was trying different things, one thing I noticed was that the wireless wouldn't even try to start up while I had a wired cable plugged in. (That was with network-manager.) Now that I have wicd, it at least looks like it's trying to scan for networks when I ask it to, but I wonder if I'd be better off unplugging and rebooting before trying to get a network connection. Any thoughts on this?

Last edited by Toadbrooks; 06-16-2011 at 02:51 PM. Reason: Spelling ...
 
Old 06-16-2011, 08:22 PM   #24
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
Quote:
Originally Posted by tredegar View Post
... try using rfkill to enable it, or un-disable it.

As for 32-bit, you could try booting from a live 32-bit CD, and see if that is any better.
Rebooted my machine with wired network unplugged.

tom@Owl:~$ dmesg (cut down to what is about the network.)
...
[ 12.566503] ath5k 0000:09:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[ 12.566516] ath5k 0000:09:00.0: setting latency timer to 64
[ 12.566605] ath5k 0000:09:00.0: registered as 'phy0'
...
[ 13.075275] ath: EEPROM regdomain: 0x64
[ 13.075278] ath: EEPROM indicates we should expect a direct regpair map
[ 13.075282] ath: Country alpha2 being used: 00
[ 13.075284] ath: Regpair used: 0x64
[ 13.082853] phy0: Selected rate control algorithm 'minstrel'
[ 13.083787] Registered led device: ath5k-phy0::rx
[ 13.083807] Registered led device: ath5k-phy0::tx
[ 13.083811] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
...
[ 19.640949] r8169: eth0: link down
[ 19.641584] ADDRCONF(NETDEV_UP): eth0: link is not ready

tom@Owl:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
tom@Owl:~$ sudo apt-get install linux-backports-modules-headers-lucid-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-backports-modules-headers-lucid-generic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
tom@Owl:~$ sudo apt-get install linux-backports-modules-wireless-lucid-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-backports-modules-wireless-lucid-generic is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 19 not upgraded.
tom@Owl:~$ sudo modprobe -rv ath5k
rmmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/ath5k.ko
rmmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/mac80211.ko
rmmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/ath.ko
rmmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/cfg80211.ko
tom@Owl:~$ sudo modprobe acer-wmi
FATAL: Error inserting acer_wmi (/lib/modules/2.6.32-32-generic/kernel/drivers/platform/x86/acer-wmi.ko): No such device
tom@Owl:~$ sudo modprobe -v ath5k
insmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/cfg80211.ko
insmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/ath.ko
insmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/mac80211.ko
insmod /lib/modules/2.6.32-32-generic/updates/compat-wireless-2.6.34/ath5k.ko
tom@Owl:~$ rfkill list
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
tom@Owl:~$ rfkill block all
tom@Owl:~$ rfkill list
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes
tom@Owl:~$ rfkill unblock all
tom@Owl:~$ rfkill list
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
tom@Owl:~$

Tried the boot from Lynx DVD. It comes up with no connection. (I unplugged the wired connection before rebooting, so it couldn't be confused by that.) I dumped a whole lot, so you wouldn't be missing anything you might later need.

ubuntu@ubuntu:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
ubuntu@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

ubuntu@ubuntu:~$ sudo lshw -C network
*-network
description: Wireless interface
product: AR5001 Wireless Network Adapter
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:09:00.0
logical name: wlan0
version: 01
serial: 00:26:5e:2d:20:6c
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
resources: irq:18 memory:d1100000-d110ffff
*-network
description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:0a:00.0
logical name: eth0
version: 02
serial: 00:23:5a:b7:b0:4d
size: 10MB/s
capacity: 100MB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
resources: irq:29 ioport:2000(size=256) memory:d1010000-d1010fff(prefetchable) memory:d1000000-d100ffff(prefetchable) memory:d1020000-d103ffff(prefetchable)
09:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:137a]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 18
Region 0: Memory at d1100000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Address: 00000000 Data: 0000
Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
ClockPM- Suprise- LLActRep- BwNot-
LnkCtl: ASPM L1 Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
Vector table: BAR=0 offset=00000000
PBA: BAR=0 offset=00000000
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Kernel driver in use: ath5k
Kernel modules: ath5k

0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Subsystem: Hewlett-Packard Company Device [103c:30fc]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 29
Region 0: I/O ports at 2000 [size=256]
Region 2: Memory at d1010000 (64-bit, prefetchable) [size=4K]
Region 4: Memory at d1000000 (64-bit, prefetchable) [size=64K]
Expansion ROM at d1020000 [disabled] [size=128K]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
Address: 00000000fee0300c Data: 4199
Capabilities: [70] Express (v2) Endpoint, MSI 01
DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 4096 bytes
DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
ClockPM+ Suprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [ac] MSI-X: Enable- Mask- TabSize=2
Vector table: BAR=4 offset=00000000
PBA: BAR=4 offset=00000800
Capabilities: [cc] Vital Product Data <?>
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-01
Kernel driver in use: r8169
Kernel modules: r8169

ubuntu@ubuntu:~$ sudo apt-get install linux-backports-modules-headers-lucid-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
linux-headers-lbm-2.6.32-28-generic
The following NEW packages will be installed:
linux-backports-modules-headers-lucid-generic
linux-headers-lbm-2.6.32-28-generic
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/228kB of archives.
After this operation, 1,356kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package linux-headers-lbm-2.6.32-28-generic.
(Reading database ... 165127 files and directories currently installed.)
Unpacking linux-headers-lbm-2.6.32-28-generic (from .../linux-headers-lbm-2.6.32-28-generic_2.6.32-28.27_i386.deb) ...
Selecting previously deselected package linux-backports-modules-headers-lucid-generic.
Unpacking linux-backports-modules-headers-lucid-generic (from .../linux-backports-modules-headers-lucid-generic_2.6.32.28.32_i386.deb) ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Setting up linux-headers-lbm-2.6.32-28-generic (2.6.32-28.27) ...
Setting up linux-backports-modules-headers-lucid-generic (2.6.32.28.32) ...
ubuntu@ubuntu:~$ sudo apt-get install linux-backports-modules-wireless-lucid-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic
The following NEW packages will be installed:
linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic
linux-backports-modules-wireless-lucid-generic
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/2,824kB of archives.
After this operation, 8,372kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic.
(Reading database ... 165248 files and directories currently installed.)
Unpacking linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic (from .../linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic_2.6.32-28.27_i386.deb) ...
Selecting previously deselected package linux-backports-modules-wireless-lucid-generic.
Unpacking linux-backports-modules-wireless-lucid-generic (from .../linux-backports-modules-wireless-lucid-generic_2.6.32.28.32_i386.deb) ...
Setting up linux-backports-modules-compat-wireless-2.6.34-2.6.32-28-generic (2.6.32-28.27) ...
update-initramfs is disabled since running on read-only media

Setting up linux-backports-modules-wireless-lucid-generic (2.6.32.28.32) ...
ubuntu@ubuntu:~$ sudo modprobe -rv ath5k
rmmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/ath5k.ko
rmmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/mac80211.ko
rmmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/ath.ko
rmmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/cfg80211.ko
ubuntu@ubuntu:~$ sudo modprobe acer-wmi
FATAL: Error inserting acer_wmi (/lib/modules/2.6.32-28-generic/kernel/drivers/platform/x86/acer-wmi.ko): No such device
ubuntu@ubuntu:~$ sudo modprobe -v ath5k
insmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/cfg80211.ko
insmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/ath.ko
insmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/mac80211.ko
insmod /lib/modules/2.6.32-28-generic/updates/compat-wireless-2.6.34/ath5k.ko
ubuntu@ubuntu:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Failed to read scan data : Network is down

ubuntu@ubuntu:~$ rfkill list
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
ubuntu@ubuntu:~$ block all
ubuntu@ubuntu:~$ rfkill list
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes
ubuntu@ubuntu:~$ rfkill unblock all
ubuntu@ubuntu:~$ rfkill list
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
ubuntu@ubuntu:~$

Last edited by Toadbrooks; 06-16-2011 at 08:24 PM. Reason: Turn off smilies
 
Old 06-17-2011, 07:49 AM   #25
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
You tried, but it didn't help you. Sorry.
It looks like ath5k is badly broken for ububtu 10.04

A lot of reading suggests that installing a 2.6.33 kernel helps.
My updated lucid is at 2.6.32-32-generic, so is not quite there yet.

Instructions for installing 2.6.33 are here
The install guide seems to have a typo:
Quote:
4.Install the files in the same order (else it won`t work!)
Install the files with sudo dpkg -i filename.deb

Note that looks like a 32-bit kernel, (maybe you should go 32-bit, or find where to get the 64-bit kernel? The repository being referenced is here: http://kernel.ubuntu.com/~kernel-ppa....6.33.5-lucid/ ).

Worth a try, you can always go back to your old kernel at the grub prompt if something else breaks.
 
1 members found this post helpful.
Old 06-17-2011, 11:47 AM   #26
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
Quote:
Originally Posted by tredegar View Post
You tried, but it didn't help you. Sorry.
It looks like ath5k is badly broken for ububtu 10.04
Nothing to be sorry about. I *really* appreciate the help. One of the hardest things to figure out is when to stop beating your head against a brick wall. I've got an expert opinion now that the brick wall has been reached.

Solution: I'm going to buy an Intel WiFi Link 5100 Mini PCI-E 512AN card. Then I will yank that Atheros POS out of my laptop and terminate it with extreme prejudice. THEN I'm going to write a document about my experiences and post it at every website I searched trying to find a solution, in hopes of saving someone else the same headaches.

Regarding termination procedures, do you have a recommendation? I personally favor using my magnum loaded .45 calibre M1911. There's something magical about hitting a POS with a 265 grain FMJ slug travelling at 1450 FPS. But I do have a 12 gauge, if you think it would be more appropriate.
 
Old 06-17-2011, 12:07 PM   #27
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Then I will yank that Atheros POS out of my laptop and terminate it with extreme prejudice.
I'd just try an updated kernel first, seriously.
Or you could try booting from a live CD of 10.10 or even 11.04 to see if it works there.

Most of my laptops have intel wireless - and I have never had any problems with them.
 
1 members found this post helpful.
Old 06-17-2011, 06:35 PM   #28
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
Quote:
Originally Posted by tredegar View Post
I'd just try an updated kernel first, seriously.
Or you could try booting from a live CD of 10.10 or even 11.04 to see if it works there.

Most of my laptops have intel wireless - and I have never had any problems with them.
I appreciate the suggestion, but I don't have the skill to carry out kernel debugging and I don't want to continue to send the logs to you to tell me what is right or wrong. I have copied several threads of similar problems with Meercat and Narwhal, plus I really don't want to "upgrade" to Unity, nor do I want to use anything not LTS. I know that abandoning Atheros is to some extent abandoning those who have this same problem, but I shouldn't be committing anyone but me to such an extended process. Besides, Atheros apparently SUCKS big time, and I think the world (at least the Linux world) needs to know not to trust them or to buy anything with Atheros in it.

Finally, the Intel wifi card I ordered cost me just $13, or less than 10 quid. As you noted Intel seems to work without issue. That's a small price to pay NOT to have to play with experimental kernels and OS versions that I don't want to use anyway.

Thanks again for all your advice and help.
 
Old 06-18-2011, 07:37 AM   #29
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
If you are determined to stick with 10.04 (and we each have our reasons ) then I agree: go for the intel chipset. $13 is a cheap cure for a severe PITA.

Good luck, and please remember to let us know how you get on.
 
Old 06-23-2011, 07:33 AM   #30
Toadbrooks
Member
 
Registered: Jul 2008
Distribution: Linux Mint 16
Posts: 74

Rep: Reputation: 7
OK, got a nice new Intel 5100 PCI-E card, put it in my case, and powered up. Those sorry SOBs at HP included code in the BIOS to lock the PC up if you swap out the wifi card. Not the end of the world, but $13 wasted and I *HATE* HP.

If anyone has RECENT experience getting a PCMCIA card to work with Lynx, I'd appreciate knowing specifically what card and what your experience was.
 
  


Reply

Tags
download, ubuntu, wicd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wicd could not launch vitalstrike82 Slackware 7 04-30-2009 11:49 AM
WICD and WPA2 Supplicant Problems on Ubuntu 8.10 SaraiKhan Linux - Wireless Networking 2 12-07-2008 07:12 PM
WiCD Apt-keys sadarax Linux - Networking 0 04-29-2008 07:40 PM
Slackware + Wicd sparker Slackware 28 03-12-2008 06:13 PM
trouble with wicd unisol Debian 1 08-20-2007 05:22 PM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration