LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Getting Wicd on Ubuntu (http://www.linuxquestions.org/questions/linux-newbie-8/getting-wicd-on-ubuntu-744434/)

Rockspud5693 08-01-2009 08:21 PM

Getting Wicd on Ubuntu
 
HELPPP!!!

Please assume the most basic of Linux knowledge!!!!: I'm trying to get wicd on Ubuntu 9.04, but I can't find anywhere to download it from. Lots of the forums mention sudo blah blah.... but I don't know where to type the stuff!!

One of the forums posted a comprehensive step-by-step how-to, but it mentioned something about installing a wicd key, where would I find this?

Also what was mentioned was gutsey, hardy, jaunty etc. I guessed that these must be the names of different Ubuntu distributions, how do I find out which one mine is?

Johnnie J 08-03-2009 04:51 AM

I took this quote right from their website:
"Wicd is an open source wired and wireless network manager for Linux which aims to provide a simple interface to connect to networks with a wide variety of settings."
http://wicd.sourceforge.net/

linuxlover.chaitanya 08-03-2009 04:54 AM

Simple enough answer to install wicd on Jaunty.

Go to System > Administration > Synaptic Package Manager.

It will ask for your password. Give it. Click on the search button to open up a text box. Type wicd there to search for it.
It will find it for you.
Click on and mark it for install. Click Apply for install it.
Thats it. Wicd is installed on your Jaunty.

Rockspud5693 08-04-2009 10:18 AM

I search for it in the quick search box and it doesn't come up. Then I search for it in the pop-out search window, and it finds it. However it does not allow me to install it! I can't find the WICD thing anywhere to download (via the Vista side of the partition)!

I tried updating and installing it through the Terminal window (yes I am aware of the Microsoft terminology! lol) but it does not like my wireless internet (hence why I wanted WICD). It does not seem that WICD is included on my version of Ubuntu.

So is there anywhere I can get WICD on it's own?

tredegar 08-04-2009 05:08 PM

Quote:

Lots of the forums mention sudo blah blah.... but I don't know where to type the stuff!!
In a terminal (which you will find on one of your (system/utilities) menus)
Quote:

I guessed that these must be the names of different Ubuntu distributions, how do I find out which one mine is?
You presumably installed it, didn't you look?

Otherwise cat /etc/apt/sources.list (in a terminal) and look for references to hardy jaunty etc. (and please tell us what you found).

If you are still having trouble, connect yourself with an ethernet cable (OK, maybe you have to MOVE hardware around, just do it, it's good exercise).

Connect it up, boot, you will almost certainly be connected.
Then you can get the downloads you need to get your wireless working.

For wicd Johnnie J gave you the right link in post #2

Rockspud5693 08-06-2009 02:55 PM

I may have to! But it's sooooo much effort!! I would just love there to be a solution that does not involve moving my computer to be in reach of the ethernet cable!

Toadbrooks 06-13-2011 09:24 AM

Download wicd
 
Unfortunately, I followed instructions I found elsewhere which said I had to uninstall the network-manager. Having done this, I now have no network connection at all, wired or wireless.

I'm running Lucid Lynx, and have the Atheros AR5001 wireless, which I have been completely unable to get to work. Anybody ahve an idea if wicd will do it, and if so, how can I download it to another computer, put on a flash drive, and get working on my crippled machine?

Thanks!

snowpine 06-13-2011 09:39 AM

If your Atheros does not work with network manager, it will not work with wicd either. It is a driver/module issue.

I did a quick Google search for you and this was the first hit, hope it helps resolve the issue: http://ubuntuforums.org/showthread.php?p=9287770

tredegar 06-13-2011 01:57 PM

Quote:

Unfortunately, I followed instructions I found elsewhere which said I had to uninstall the network-manager. Having done this, I now have no network connection at all, wired or wireless.
If you have an ethernet cable plugged into a DHCP-capable router (ie practically any router) when you boot, you'll usually get connected automatically.

If you'd like NM back you can probably just do
sudo apt-get install network-manager
as all the needed files should still be in apt's cache, and it will not need a net connection.

snowpine's link for getting your wireless working looks a good one.

Good luck.

Toadbrooks 06-14-2011 07:44 AM

I appreciate the responses. That's one thing I am not getting on other sites.

Unfortunately, having removed network manager, I no longer have the option of plugging in the cat 5 and using wired. Losing NM cost me the wired network. What I was trying to do was get the wireless working for when I take my laptop on the road.

I appreciate the link. I've been following similar ones on other sites and have done the backports and the modprobe without success. Madwifi doesn't seem to be a solution. The upgraded driver from the Madwifi project is the ath5k driver that is loaded now in my machine.

There is an ath9k driver that I thought I might try, although I don't see how that is likely to solve the problem. My card is the AR5001 and if the 5k driver won't work, why should the 9k driver work? But I do appreciate the opinion that wicd won't work if network-manager doesn't, since neither address the probable driver issue. I'm afraid I have no choice but to try, assuming I can get some kind of network manager reloaded so I again have my wired connection.

I am surprised this isn't a more common problem and I was hoping someone else had seen and solved it. HP laptops like mine (DV7-1451nr) are powerful and relatively inexpensive.

Thanks again,
Toad

hitmen 06-14-2011 07:49 AM

report

lspci

iwconfig

ping -c 127.0.0.1

Is your ethernet working?

Toadbrooks 06-14-2011 08:05 AM

I did manage to get network-manager back, using the installation CD and synaptic package manager. Still no wireless, but at least I'm back where I started.

Toadbrooks 06-14-2011 08:12 AM

Hitmen,

Network manager is back up, so I have wired. The GUI did not reinstall, but Synaptic is back to functional, so I can go get it. Having no other options, I'm still going to try wicd, to remove it from consideration if nothing else. Meanwhile, I unfortunately have to go to work. Appreciate your note and hope to return this evening and read something new I can try.

Ping responds as expected. (64 bytes from 127.0.0.1: icmp ...)

tom@Owl:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:23:5a:b7:b0:4d
inet addr:192.168.100.97 Bcast:192.168.255.255 Mask:255.255.0.0
inet6 addr: fe80::223:5aff:feb7:b04d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6481 errors:0 dropped:0 overruns:0 frame:0
TX packets:3911 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5672731 (5.6 MB) TX bytes:577116 (577.1 KB)
Interrupt:28 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:960 (960.0 B) TX bytes:960 (960.0 B)

wlan0 Link encap:Ethernet HWaddr 00:26:5e:2d:20:6c
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

tom@Owl:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID: off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr: off Fragment thr: off
Power Managementff

tom@Owl:~$ sudo lshw -C network
[sudo] password for tom:
*-network
description: Wireless interface
product: AR5001 Wireless Network Adapter
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:09:00.0
logical name: wlan0
version: 01
serial: 00:26:5e:2d:20:6c
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
resources: irq:18 memory:d1100000-d110ffff
*-network
description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:0a:00.0
logical name: eth0
version: 02
serial: 00:23:5a:b7:b0:4d
size: 100MB/s
capacity: 100MB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.100.97 latency=0 link=yes multicast=yes port=MII speed=100MB/s
resources: irq:28 ioport:2000(size=256) memory:d1010000-d1010fff(prefetchable) memory:d1000000-d100ffff(prefetchable) memory:d1020000-d103ffff(prefetchable)

Here's the networking section from lspci -nnvv:

09:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
Subsystem: Hewlett-Packard Company Device [103c:137a]
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 18
Region 0: Memory at d1100000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Address: 00000000 Data: 0000
Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
ClockPM- Suprise- LLActRep- BwNot-
LnkCtl: ASPM L1 Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
Vector table: BAR=0 offset=00000000
PBA: BAR=0 offset=00000000
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Kernel modules: ath5k

0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Subsystem: Hewlett-Packard Company Device [103c:30fc]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 28
Region 0: I/O ports at 2000 [size=256]
Region 2: Memory at d1010000 (64-bit, prefetchable) [size=4K]
Region 4: Memory at d1000000 (64-bit, prefetchable) [size=64K]
Expansion ROM at d1020000 [disabled] [size=128K]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
Address: 00000000fee0100c Data: 4199
Capabilities: [70] Express (v2) Endpoint, MSI 01
DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 4096 bytes
DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
ClockPM+ Suprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [ac] MSI-X: Enable- Mask- TabSize=2
Vector table: BAR=4 offset=00000000
PBA: BAR=4 offset=00000800
Capabilities: [cc] Vital Product Data <?>
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [140] Virtual Channel <?>
Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-01
Kernel driver in use: r8169
Kernel modules: r8169

hitmen 06-14-2011 08:33 AM

previously could you start wicd?
What was the problem you faced with wicd?
I dunno about network manager

After installing wicd, I uninstalled network manger

sudo apt-get remove network-manager
sudo /etc/init.d/wicd restart

I restarted my comp and it worked.

Toadbrooks 06-14-2011 08:57 AM

I haven't tried wicd yet. This evening, thats my next step, i.e. get wicd then remove nm, then see what happens. At least it will remove it from consideration.

Assuming the problem is the driver ... I've been reading about this and the only options appear to be getting another driver or using the wrapper that enables PC driver use. I can't find an indicator that there is a better driver than ath5k, which is one of the results of the madwifi project, except perhaps ath9k. Likewise I read that using the ndis wrapper means you have to redo it every time you upgrade your system. That just doesn't seem reasonable.

So, the remaining option I have read about is getting another wifi card, from a vendor that supports linux. Question: Do you have a recommendation? (Anybody reading this thread have a suggested card?) I'm rapidly reaching the point where spending $20 on a new card to solve this forever is looking best.


All times are GMT -5. The time now is 03:23 PM.