LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2008, 10:57 AM   #1
darkside720
LQ Newbie
 
Registered: Feb 2008
Posts: 11

Rep: Reputation: 0
Angry Getting when running make to build simulator


Hi I am trying to run make to build the simulator and am seeing this error while building the target...

error is :
/usr/bin/ld: cannot find -lelf

Log spit out when executing make:

echo "INSTALL_DIR=`cds_root pliwiz`" > macros
make -f /smsc/chp/tweety/a/src/rves_5.0/lnx86/nc/Makefile_pliwiz.nc
make[1]: Entering directory `/smsc/chp/tweety/a/src/rves_5.0/lnx86/nc'
g++ -rdynamic `[ \`ncbits\` = 32 -a \`uname -m\` = x86_64 ] && echo -m32 -W, -m elf_i386 || echo` -mt -fPIC -o /smsc/chp/tweety/a/src/rves_5.0/lnx86/nc/ncelabC \
\
/eda/ius_6.1/tools/inca/lib/`[ \`ncbits\` = 64 ] && echo 64bit/ || echo`ncelab.o \
\
main.o \
\
/smsc/chp/tweety/a/src/rves_5.0/lnx86/nc/veriuser.o ../../../damem_LDV34/obj-lnx86/libpli.a ../../../fileio3.2/obj-lnx86/libfileio.a ../../../value1.7/obj-lnx86/libvalue.a ../../../TrFmt_PLI/obj-lnx86/libTrFmt.a /eda/debussy_2007.07/share/PLI/nc54/LINUX/pli.a \
\
-L/eda/ius_6.1/tools/inca/lib/`[ \`ncbits\` = 64 ] && echo 64bit/ || echo` -lvoids \
-L/eda/ius_6.1/tools/inca/../lib/`[ \`ncbits\` = 64 ] && echo 64bit/ || echo` -L/usr/lib`[ \`ncbits\` = 64 ] && echo 64bit/ || echo` -lnsl -ldl -L/lib -lm `[ \`ncbits\` = 32 -a \`uname -m\` = x86_64 ] && echo || echo -lelf -lstdc++` `[ \`ncbits\` = 32 ] && echo -L/eda/ius_6.1/tools/lib -lrh72compat || echo`
make[1]: Leaving directory `/smsc/chp/tweety/a/src/rves_5.0/lnx86/nc'
/usr/bin/ld: cannot find -lelf
collect2: ld returned 1 exit status
make[1]: *** [/smsc/chp/tweety/a/src/rves_5.0/lnx86/nc/ncelabC] Error 1
make: *** [all] Error 2
 
Old 02-27-2008, 09:30 PM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Welcome to LQ!

This probably means you have to install libelf-dev package. You have chosen not to reveal what distro you are using, so cannot be sure how it is called in your repos.
 
Old 02-28-2008, 09:00 AM   #3
darkside720
LQ Newbie
 
Registered: Feb 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Talking Make error when running build

Thanks for the response. Sorry, kinda new to this whole thing, but I have RH4 and checked to see if the rpm libelf-dev was installed and it came back with no response. I'm assuming that this is not installed...
 
Old 02-28-2008, 09:35 AM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Hmh, RH is certainly the last distro I'd use myself ... de gustibus non est disputandum.

There certainly is a method how to get, upgrade and install software in RHEL4 (I assume you do not run RH-4?!). I'd recommend you start reading documentation now.
Useful links:
www.redhat.com/docs/manuals/
www.google.com/linux
www.rpmseek.com
 
Old 02-28-2008, 09:46 AM   #5
darkside720
LQ Newbie
 
Registered: Feb 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Yeah, I am running Redhat 4 the WS version... I'll check the links out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
C++ (compile vs. make vs. build) wwnexc Programming 11 10-10-2011 02:38 PM
[root@oprations Module]# make make -C /lib/modules/2.6.18-1.2798.fc6/build SUBDIRS=/r korotania Fedora 7 06-22-2007 04:12 PM
Need Help on How to make/build a Server spide21 Programming 5 03-09-2006 12:40 PM
'make' fails while trying to build jonnycarlos Linux - Software 0 04-29-2004 10:14 PM
running applications from one Linux build in another Linux build bcottam Linux - Distributions 2 04-13-2004 01:08 AM


All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration