LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-13-2005, 06:47 PM   #1
servnov
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2
Posts: 276

Rep: Reputation: 30
getting USB attached printer going


I just got a new printer for another computer of mine. Its an HP and I found all the drivers included in CUPS when i did setup via localhost:631. I have setup printers before with CUPS but only parallel port ones. CUPS shows USB ports to select from, but the printer just sits there, although CUPS says 'idle, accepting jobs'.

How can I get it working, it seems I am so close, and I know CUPS has the driver for it, since I found it during setup?

I have also tried 'lpr fubar.txt' and couldnt find the job in the print queue with lpq nor did anyting print
 
Old 07-13-2005, 08:19 PM   #2
OrganicOrange84
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian-Etch
Posts: 30

Rep: Reputation: 15
Hmmm.... not that I would know particulary, but might it just might be looking in the wrong place? I don't know, but you could try all the following ports, er device names.

/dev/lp0
/dev/lp1
/dev/usblp0
/dev/usblp1
dev/usb/lp0
/dev/usb/lp1

I had the problem too, with the printer telling me it was idle and accepting jobs, yet it would just sit there. I played with all these names for the device and for me the /dev/usb/lp0 worked. I don't know but MAYBE it will work. I hope so. That's in my minimal experience anyway.
 
Old 07-20-2005, 04:31 PM   #3
servnov
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2
Posts: 276

Original Poster
Rep: Reputation: 30
Thanks for the response. How did you get them to work? In CUPS i get something like this:

Parrallel port
Serial 0
Serial 1
Serial 2
USB 0
USB 1
USB 2

I think for serial and USB it goes up to 15 and I also have ipp and a couple other options. If I choose anything except USB 0 (like USB 1, etc) it gives an error telling me no device there. And nothing gives errors or complains with USB 0, it just doesn't print just sitting there (begging me to give up and install it on win32 haha :-P)

I tried chmod 755 /dev/usb/lp0 but no difference. I figure if its showing up in CUPS permissions isn't the problem anyway.

Last edited by servnov; 07-20-2005 at 04:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer(attached to windows machine) configuration RohanShrivastav Suse/Novell 1 06-07-2005 08:09 PM
print from smb to windows attached printer axelmang Linux - Networking 3 09-21-2004 06:31 AM
linux locks up when usb mouse attached to usb port during startup. BGuy891653 Linux - Hardware 0 02-08-2004 05:26 PM
Printing on PC (Windows ) attached printer from a linux application on same Network shankar_hn Linux - Newbie 0 10-24-2003 04:32 AM
No Sound when USB WebCam attached! Caglistro Linux - Newbie 2 07-30-2001 01:55 PM


All times are GMT -5. The time now is 02:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration