LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-27-2003, 05:24 PM   #1
Gäfvert
LQ Newbie
 
Registered: Oct 2003
Location: Sweden
Posts: 6

Rep: Reputation: 0
Getting the internet to work. [Newbie]


Red Hat 9.0

Ok, the thing is that i dont know anything about Red Hat since im used to XP (running dual boot with GRUB).

So can anyone help me set up the xDSL connection?
I have tried to run that internet guide in the menu and typed in the password and username i recived by my ISP.
But arent there more settings you have to do before it works like, proxyserver port, DNS, domains, gateway?
The book i got with the connection shows how to do it in windows but i cant find any of those in any grafical meny in red hat, do i have to do it by commands in the terminal?

And also dosent my eth0 activate when i try to activate it unless i have run that guide to internet stuff in the meny. And now it wont activate at all. What is wrong ? do i have to intall drivers? it works from time to time.

HELP ME PLEASE!
DONT BE SHY TO RESPOND, YOU KNOW MORE THAN I DO.

Last edited by Gäfvert; 10-27-2003 at 06:05 PM.
 
Old 10-27-2003, 06:05 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Some things we will need to know before helping:

1. How are you connecting from your DSL modem? Ethernet or USB?

2. What type of connection do you have? DHCP or Static assigned IP from your ISP?
 
Old 10-27-2003, 06:08 PM   #3
Gäfvert
LQ Newbie
 
Registered: Oct 2003
Location: Sweden
Posts: 6

Original Poster
Rep: Reputation: 0
1. i connect over a ethernet card
2. DHCP

note: the card wont work at all now, but in xp its fine
 
Old 10-27-2003, 06:08 PM   #4
WannaLearnLinux
Member
 
Registered: May 2003
Location: California
Distribution: Slax
Posts: 262

Rep: Reputation: 31
sorry I'm newbie also,but

when u type in console as root "ifconfig",does it shows the "eth0" and those IPs or just "Lo" (loopback) ?

If there is not eth0 then u don't have a driver installed for eth0.

I had same problem so I'm trying to help u as possible.If I'm wrong, then someone else will help u better.
 
Old 10-27-2003, 11:56 PM   #5
namespace
LQ Newbie
 
Registered: Oct 2003
Location: China
Distribution: LFS
Posts: 21

Rep: Reputation: 15
Look at this http://www.linuxfromscratch.org/hint.../OLD/pppoe.txt
 
Old 10-28-2003, 02:44 AM   #6
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
I dont know if Redhat 9.0 has this feature (i think it still does) but have you tried configuring your NIC card? Type this in root:

/usr/sbin/netconfig

After filling in the fields that it requests, then try "ifconfig" to see if your eth0 interface is up. If it is still not up, state the error message and we'll try to figure it out. By the way, what is the manufacture of the NIC card? Redhat 9.0 does support a variety of NICs but yours may not be supported in the kernel.

-twantrd
 
Old 10-28-2003, 09:07 AM   #7
Gäfvert
LQ Newbie
 
Registered: Oct 2003
Location: Sweden
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the adress namespace ill try that.

when i type /sbin/ifconfig as root in the terminal i get the following

lo Link encap: Local Loopback
inet addr: 127.0.0.1 Mask : 255.0.0.0
UP LOOPBACK RUNNING MTU: 16436 Metric: 1
RX Packets: 621 errors:0 dropped:0 overruns:0 frame:0
TX packets: 621 errors:0 dropped:0 overruns:0 carriers:0
collisions:0 txqueuelen:0
RX bytes: 41912 (40.9 kb) TX bytes 41912 (40.9 kb)

My NIC is a Micronet SP2500R series 10/100 Fast ethernet adapter.
 
Old 10-28-2003, 12:50 PM   #8
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
Hi gafvert,

Well, wannalearnlinux is correct. You need a driver for that NIC. By looking at the manufacturer I have no idea which module you need to load. Do a google search to find out which module you can use to load for that NIC. Best of luck.

-twantrd
 
Old 10-28-2003, 01:19 PM   #9
Gäfvert
LQ Newbie
 
Registered: Oct 2003
Location: Sweden
Posts: 6

Original Poster
Rep: Reputation: 0
Here is some information i found on the 3.5" i got with the NIC.

Linux
=====

Installing Driver:
(1.) Kernel Had Supported Driver:
Check the directory " /lib/modules/¡K./net " if you could find "rtl8139.o"
Your kernel had supported RTL8139 series. You could easy use "linuxconf"
to setup your card. If you don't like linuxconf, you also could use
"modprobe rtl8139" and "ifconfig up eth0" to load module.
If your driver load properly, your "/etc/conf.modules" should include
line of "alias eth0 rtl8139".

(2.) Kernel Don't Support Driver:
If your kernel doesn't support RTL8139 series, you should compiler driver
by yourself. Please contact http://www.scyld.com/network/rtl8139.html
to get source code. The compiler command is located on the end of source
code. Maybe like "gcc -DMODULE -Wall -Wstrict-prototypes -O6 -c rtl8139.c".
If you couldn't compiler success, maybe you should refer to error message
and copy library or head file to Linux.

Adjust Speed:
(1.) Adjusting speed:
Driver is designed with the gold that no options should be needed in most
environment. However not all cards and networks can be automatically configured,
thus allow operational parameters to be modify when they are loaded
as module. Typically the following variables may be set:
insmod rtl8139 options=0x40
Hex Decimal Meaning
0x10 16 ¡K..Force Full-Duplex operation (must be used with 0x20 or 0x40)
0x20 32 ¡K..Force 100mbps-only operation
0x40 64 ¡K..Force 10mbps-only

If loading as a module and configured /etc/conf.modules

alias eth0 rtl8139
options options=0x40

Look weird like that but I believe that works.

That's what I got out of the documentation. It seems like the
options are supported in the module. If not, you'll need to
download ftp://ftp.scyld.com/pub/diag/rtl8139-diag.c

Compiling syntax is at the end.

Run: "rtl8139-diag -F 10baseT-HD"

That will force it to 10Mbps at half-duplex. If you want full-duplex change it to 10baseT-FD.
You'll need a switch for full-duplex.

Once you establish that it works, you can write the setting to
the EEPROM with "rtl8139-diag -w".

Other information:
You could get some helpful information on these URLs.

http://www.scyld.com/

http://www.deja.com/usenet

http://www.realtek.com.tw/cn/html


I dunno how to do all this so can anyone plz help by explaning it step by step.
Also i like to know what a module is and what the word compile means, sorry about my noobieness ^_^

Last edited by Gäfvert; 10-28-2003 at 05:18 PM.
 
Old 01-10-2004, 10:48 AM   #10
silverbear
LQ Newbie
 
Registered: Jan 2004
Posts: 25

Rep: Reputation: 15
*Laugh* I think you might have solved my issue without being able to solve yours... Simply enough. That is saying that your redhat isn't supporting RTL8139 as an ethernet card (According to scyld.com it's based on a useless driver with changes made that are pointless) Basically all you need to do is copy the .c file to floppy or a mounted windows directory and run the gcc command all the way to the .c and that should "Compile" the new driver and make it a "Module" Compiling is just making a source code a running (Sorry people) Executable in this case a module which is basically a driver, but we're not running windows or we wouldn't be getting anything from this site.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie wants the internet to work on Redhat 9.0... Fang_Oracle Linux - Networking 2 10-18-2005 11:47 AM
Newbie needs help on his Internet connection! Fatch_R Linux - Newbie 7 02-14-2005 02:08 PM
Internet Connection - Newbie! l22arg Linux - Newbie 2 05-17-2004 11:10 AM
Newbie needs networking / internet help!! Stoffer Linux - General 12 06-10-2003 03:32 PM
Internet sharing newbie slipsy Linux - Networking 1 04-18-2003 06:49 PM


All times are GMT -5. The time now is 04:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration