LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-14-2010, 12:07 PM   #1
oalette
LQ Newbie
 
Registered: Nov 2010
Posts: 11

Rep: Reputation: 0
Getting TeamViewer to start up 30/60 seconds after login?


Hello, my name is Oalette and this is my first post, I'm a Linux noobie and I need your help!

Okay, what I need help with is configuring TeamViewer to start up 30 to 60 seconds after login.

At the moment, TV starts up straight away at login, but seeing as the wireless internet isn't connected straight away, TV's trying to connect without a connection, which is a problem when the wireless does connect as it will get stuck with 'Activating TeamViewer'.

Obviously, this is a straight forward task, just exit and then re-open TV. But seeing as I want to run a headless server, carrying my monitor and mouse to the server every time I want to activate TV isn't ideal.

The way I did set up TeamViewer to start up on login, was by dragging the icon into System>Preferences>Start-up Applications, so if the solution is to create a script of some sort, a step-by-step guide would be greatly appreciated

Thanks for any help that comes my way ,

Oalette


EDIT: P.s OS is Ubuntu 10.04 btw

Last edited by oalette; 11-14-2010 at 12:10 PM.
 
Old 11-14-2010, 12:38 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Remove the entry from System>Preferences>Start-up Applications. Create a script called ~/.xinitrc - this script is automatically run when you start an X windows session. Add to it:

Code:
#!/bin/bash
(/bin/sleep 60; /usr/bin/someprogram) &
Save it and chmod +x ~/.xinitrc

Log out and log back in. After 60 seconds, '/usr/bin/someprogram' will run.
 
Old 11-14-2010, 01:28 PM   #3
oalette
LQ Newbie
 
Registered: Nov 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by macemoneta View Post
Remove the entry from System>Preferences>Start-up Applications. Create a script called ~/.xinitrc - this script is automatically run when you start an X windows session. Add to it:

Code:
#!/bin/bash
(/bin/sleep 60; /usr/bin/someprogram) &
Save it and chmod +x ~/.xinitrc

Log out and log back in. After 60 seconds, '/usr/bin/someprogram' will run.
i did that, removed the teamviewer from the list of startup apps, made the text file and removed '/someprogram' for /teamviewer, saved it as ~/.xinitrc in my home directory and put chmod +x ~/.xinitrc into the terminal and restarted my computer and it doesn't come up.

Although it didn't come up, the screen did go black and pop back up just like when teamview is initially started, but nothing comes up after that :/
 
Old 01-12-2011, 08:36 AM   #4
mrkee
LQ Newbie
 
Registered: Jan 2011
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by oalette View Post
Hello, my name is Oalette and this is my first post, I'm a Linux noobie and I need your help!

Okay, what I need help with is configuring TeamViewer to start up 30 to 60 seconds after login.

At the moment, TV starts up straight away at login, but seeing as the wireless internet isn't connected straight away, TV's trying to connect without a connection, which is a problem when the wireless does connect as it will get stuck with 'Activating TeamViewer'.

Obviously, this is a straight forward task, just exit and then re-open TV. But seeing as I want to run a headless server, carrying my monitor and mouse to the server every time I want to activate TV isn't ideal.

The way I did set up TeamViewer to start up on login, was by dragging the icon into System>Preferences>Start-up Applications, so if the solution is to create a script of some sort, a step-by-step guide would be greatly appreciated

Thanks for any help that comes my way ,

Oalette


EDIT: P.s OS is Ubuntu 10.04 btw
Hi,

had a same problem and managed to fix it...

I am using ubuntu 10.10, but should work on 10.04.

keep /usr/bin/teamviewer in StartUP Applications and edit /usr/bin/teamviewer it is wrapper script for wine.
Add sleep 30 on top of teamviewer script. (first tried with 15 sec but still gets stuck, with 30 sec it works)

it should look like this
Code:
#!/bin/sh
sleep 30

userid=$(id -u)
tv_ver="6"

if [ $userid = 0 ]
then
        echo TeamViewer must not be executed as root!
        exit 1
fi

export TV_BINDIR=/opt/teamviewer/teamviewer/$tv_ver/bin
exec "$TV_BINDIR"/wrapper "c:\Program Files\TeamViewer\Version$tv_ver\TeamViewer.exe" "$@"

true
 
Old 01-12-2011, 08:37 AM   #5
mrkee
LQ Newbie
 
Registered: Jan 2011
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by oalette View Post
Hello, my name is Oalette and this is my first post, I'm a Linux noobie and I need your help!

Okay, what I need help with is configuring TeamViewer to start up 30 to 60 seconds after login.

At the moment, TV starts up straight away at login, but seeing as the wireless internet isn't connected straight away, TV's trying to connect without a connection, which is a problem when the wireless does connect as it will get stuck with 'Activating TeamViewer'.

Obviously, this is a straight forward task, just exit and then re-open TV. But seeing as I want to run a headless server, carrying my monitor and mouse to the server every time I want to activate TV isn't ideal.

The way I did set up TeamViewer to start up on login, was by dragging the icon into System>Preferences>Start-up Applications, so if the solution is to create a script of some sort, a step-by-step guide would be greatly appreciated

Thanks for any help that comes my way ,

Oalette


EDIT: P.s OS is Ubuntu 10.04 btw
Hi,

had a same problem and managed to fix it...

I am using ubuntu 10.10, but should work on 10.04.

keep /usr/bin/teamviewer in StartUP Applications and edit /usr/bin/teamviewer it is wrapper script for wine.
Add sleep 30 on top of teamviewer script. (first tried with 15 sec but still gets stuck, with 30 sec it works)

it should look like this
Code:
#!/bin/sh
sleep 30

userid=$(id -u)
tv_ver="6"

if [ $userid = 0 ]
then
        echo TeamViewer must not be executed as root!
        exit 1
fi

export TV_BINDIR=/opt/teamviewer/teamviewer/$tv_ver/bin
exec "$TV_BINDIR"/wrapper "c:\Program Files\TeamViewer\Version$tv_ver\TeamViewer.exe" "$@"

true
hope it helps.
 
Old 01-19-2011, 07:58 PM   #6
atal379
LQ Newbie
 
Registered: Jan 2011
Posts: 1

Rep: Reputation: 0
I'm having the same issue. I tried to edit the /usr/bin/teamviewer script but I guess it is "Read Only" and it won't let me type anything into it. How did you edit it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can i start program for 5 seconds? DoME69 Programming 2 03-16-2010 04:16 AM
LCD out of range for 10 seconds on login malcolmBl Linux - Hardware 1 03-23-2007 08:51 AM
Password prompt takes 20 seconds to display after login afgs_uk Linux - General 6 12-07-2006 10:13 PM
KSCD: track doesn't play at start; skips the first (two) seconds JBailey742 Linux - Software 0 09-11-2006 04:19 PM
KDE kicking me out to login screen every couple seconds.. slug420 Linux - General 2 01-06-2005 09:51 AM


All times are GMT -5. The time now is 03:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration