LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2004, 02:21 PM   #1
timeslice
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Rep: Reputation: 0
getting stuck with Suse


hello
Im new to linux but decided to give it a go and brought Suse,everything seemed to install ok then it started to reboot and it gets as far as "Starting hotplugging services (ieee1394 net pci usb" and then comes to a complete stop??

Any help would be appreciated
 
Old 03-31-2004, 03:10 PM   #2
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
Which version of SuSE is this? [won't help me, but may help others]

Is there a close bracket on the end of "Starting hotplugging services (ieee1394 net pci usb"? If not then somethings up with Linux and your USB hardware.

Was there an option in the install to turn USB off, or configure it?

If you bought SuSE, you may be eligible for their support.
 
Old 03-31-2004, 03:38 PM   #3
timeslice
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Hi jmorse

It's Version 9.0
There was no closed brackets and no option about usb when installing it
 
Old 03-31-2004, 04:07 PM   #4
dizzy_vee
LQ Newbie
 
Registered: Mar 2004
Distribution: SuSE 9, Mandrake 10
Posts: 19

Rep: Reputation: 0
can you paste the resuts of lsmod and dmesg? If you don't know what that means, just open a shell window and type:

lsmod

Copy the results and paste them, and do the same with dmesg:

dmesg

I had the same problem when I first booted SuSE 9 on my desktop. Wasn't sure what it was but when I turned off acpi during boot, it worked fine.

To do that, when you get to the GRUB boot prompt (where you choose to load linux when you turn on your machine), type the following in the little box at the bottom:

acpi=off


Cheers,
Dizzy V
 
Old 03-31-2004, 04:43 PM   #5
LoungeLizard
Member
 
Registered: Apr 2003
Location: Tampa, Florida
Distribution: Mint 17.2 ,OpenSuse, Kali and Pepermint OS 6
Posts: 276

Rep: Reputation: 30
here is what I did to get past that when you get to where you can put in boot options type

acpi=force
 
Old 03-31-2004, 05:18 PM   #6
timeslice
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Managed to sort it out,
Disconected a secondary cd writer and it booted first time
Thanks for you help!
 
Old 04-01-2004, 07:00 AM   #7
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
That is fairly odd. Probably anoying if you wanted to use that drive.

It was probably getting confused somewhere, unless you use hotplug PCI, Firewire etc, try turning them off and see if the problem returns.
 
Old 05-07-2004, 03:30 AM   #8
skr
Member
 
Registered: Apr 2004
Location: London
Distribution: Whatever takes my fancy this week
Posts: 40

Rep: Reputation: 15
I am having the same problem, acpi=force makes no difference but acpi=off appears to work.

Questions:

Can I tell what I have switched off as my USB sockets work ?

Can I set boot up to automatically include acpi=off as the PC boots up I tend not to catch it in time to enter the prompt ?


Many thanks:
a confused
 
Old 05-07-2004, 07:14 AM   #9
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
I don't understand your first questions:
>Can I tell what I have switched off as my USB sockets work ?

To add acpi=off to the boot options without having to type it in,
add 'acpi=off' to the end of your 'kernel' statement in grub.conf [/boot/grub/menu.lst]

or if you use lilo add 'append acpi=off' to the section for your kernel in lilo.conf [/etc/lilo.conf] and run 'lilo'


[Written in haste and on the hoof, no charge for spelling mistakes.]
 
Old 05-07-2004, 02:36 PM   #10
skr
Member
 
Registered: Apr 2004
Location: London
Distribution: Whatever takes my fancy this week
Posts: 40

Rep: Reputation: 15
Thanks for that I'll try it.

My first question was really trying to understand what was in error and what I was turning 'OFF'.

I assumes (propably wrongly) that the error message 'ieee1394 net pci usb' related to USB support and that was what I was turning off. However USB Ports seem unaffected.

Thanks again
 
Old 05-07-2004, 02:46 PM   #11
jmorse
Member
 
Registered: Mar 2004
Location: United Kingdom
Distribution: LFS
Posts: 74

Rep: Reputation: 15
ACPI is the interface to all your motherboards power managment features. This may range from slowing the processor down to reduce power consumption, to the button on the front to turn the computer off, or shutdown, or suspend to disk.

What you are turning off is the linux kernel's support for acpi, seeing as most motherboard manufacturers appear to have taken the standard as a guideline, as opposed to a standard, it isn't guaranteed to work under linux. [Or at least that's what I've found.]

ACPI can tell the usb chip on your motherboard to shut itself off, to save power, or when your computer is in standby.

Your hotplug error is probably a result of ACPI getting in the way of the usb hotplug code, or even PCI, net or firewire!

Simple solution, turn of ACPI [as you have found.]

Try upgrading to a more recent kernel [unless you are already using 2.6], 2.6 probably has better support for ACPI, and may solve your problem.
 
Old 05-09-2004, 01:07 PM   #12
skr
Member
 
Registered: Apr 2004
Location: London
Distribution: Whatever takes my fancy this week
Posts: 40

Rep: Reputation: 15
Thank you for that full explanation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 9.1 Online Update Gets Stuck at 96% soopafresh Linux - Newbie 3 08-09-2004 07:55 PM
Ati 9200 / Suse 8.2 / I'm stuck Kdiver58 Linux - Hardware 1 02-24-2004 11:38 AM
Help!! Suse Won't Boot, Stuck In Winxp!!!! shane25119 Linux - General 3 02-21-2004 03:10 PM
I'm stuck between Slackware - Suse the panther Linux - Distributions 12 08-07-2003 08:19 AM
SuSE 8.2: stuck in TWM thom Linux - Distributions 1 06-01-2003 06:42 PM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration