LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-06-2012, 11:25 AM   #1
fwellers
Member
 
Registered: Dec 2011
Posts: 32

Rep: Reputation: Disabled
getting openldap slapd to listen on port 636 ( ssl ) ?


Hello,
I am building a new ldap registry. In Oracle red-hat Linux using openldap and openssl.

When I run the command line:
/usr/local/libexec/slapd -f /usr/local/etc/openldap/slapd.conf -l LOCAL4 -d -1

slapd runs, but only listens on port 389.

I configured TLS in the slapd.conf.

What am I missing to be for slapd to listen on 636 ? I can't find anywhere that tells which port to listen on, and I can't find any command line args for the startup to tell it which port.


Thank you in advance
 
Old 01-06-2012, 01:45 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Hello,

I have noticed that you have marked your thread as solved; Have you figured out your issue? If so, could you kindly share your results with the rest of us? Thanks!

Cheers,

Josh
 
Old 01-06-2012, 01:54 PM   #3
fwellers
Member
 
Registered: Dec 2011
Posts: 32

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
Hello,

I have noticed that you have marked your thread as solved; Have you figured out your issue? If so, could you kindly share your results with the rest of us? Thanks!

Cheers,

Josh
Very sorry, I meant to, and have been called away.
The solution was in how slap is started from the command line.
The command line that works is :
nohup /usr/local/libexec/slapd -f /usr/local/etc/openldap/slapd.conf -l LOCAL4 -d -1 -h "ldap:/// ldaps:///" &

The bolded part is the addition ( the -h ) tells slap to start on the standard ldap and then the standard ldaps ports.

Thanks,
floyd
 
Old 01-06-2012, 01:58 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Ok cool, thanks for sharing that with other fellow users of LQ.

Cheers,

Josh
 
Old 01-06-2012, 02:00 PM   #5
fwellers
Member
 
Registered: Dec 2011
Posts: 32

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by corp769 View Post
Ok cool, thanks for sharing that with other fellow users of LQ.

Cheers,

Josh
My pleasure. I get enough help myself from this great place. :-)))
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ldap cannot carry slapd.conf changes or did not use /etc/openldap/slapd.conf joel_saul Linux - Server 6 08-21-2010 05:53 AM
OpenLDAP (no slapd.conf) britchaz Linux - Networking 1 05-05-2009 04:29 PM
LXer: OpenLDAP Quick Tips: Using syslog or syslog-ng with slapd for OpenLDAP logging LXer Syndicated Linux News 0 11-14-2008 09:41 PM
ProFTP + LDAP + SSL (LDAPServer 1.2.3.4:636) one71 Linux - Server 2 06-02-2008 05:08 AM
tomcat don't listen on port 8443 (ssl) Kanaflloric Linux - Software 2 05-03-2007 06:41 AM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration