LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-09-2005, 12:41 PM   #1
fell
LQ Newbie
 
Registered: May 2005
Location: Sonoma County, CA
Distribution: Slackware 10.1
Posts: 12

Rep: Reputation: 0
Getting on the internet with Slackware 10.1


I searched around a bit, but unfortunately I'm so new to all this that any 'helpful' information is a bit beyond my understanding.

I've tried to setup my basic network settings by using 'pkgtool', going to setup and running the 'netconf'. I'm using Cox cable for my internet. It runs from the modem (of course) through a Linksys router.

Anyway...I'm not sure what to use as my host name and domain. I'm used to windows..just plug in and bam. Works. Or if need be, cmd with ipconfig /release and /renew, etc.

I've also tried checking out 'ifconfig' and all it shows is my loopback being active. I did ifconfig eth0 and it shows my ethernet card...but in KDE using Mozilla, I'm still not getting a connection to the internet.

What's the missing link?

Sorry for the major n00b question. =/
 
Old 05-09-2005, 01:00 PM   #2
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
Being a newbie(not a bad thing at all, we all are on some level), I assume you did an 'everything' install?? I hope so, as it will make your life easier... If you did, it should have installed a dhcp client, and the eth0 should automatically be configured. Of course, there are many reasons why it may not be, but let's start with the simple stuff...


AS ROOT:
try "ifconfig eth0 up" to activate the eth0 NIC. Then try one of 2 DHCP clients that may have been installed. "dhcpcd eth0" should work. If not, try "dhclient eth0"

If this is a new install, you may want to run through the installation again. But it's not necessary. Did you do the basic network configuration during the install?? Setting hostname for both standard hostname, and using the same name when it asks for a DHCP hostname works well, and then you can always view that information in the DHCP table in your Linksys router.

If you have no luck with this stuff, let us know. Also, please give the NIC make/model/revision and what version of Slackware? I assume 10.1??

Good Luck!!
 
Old 05-09-2005, 01:09 PM   #3
fell
LQ Newbie
 
Registered: May 2005
Location: Sonoma County, CA
Distribution: Slackware 10.1
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by halo14
Being a newbie(not a bad thing at all, we all are on some level), I assume you did an 'everything' install?? I hope so, as it will make your life easier... If you did, it should have installed a dhcp client, and the eth0 should automatically be configured. Of course, there are many reasons why it may not be, but let's start with the simple stuff...


AS ROOT:
try "ifconfig eth0 up" to activate the eth0 NIC. Then try one of 2 DHCP clients that may have been installed. "dhcpcd eth0" should work. If not, try "dhclient eth0"

If this is a new install, you may want to run through the installation again. But it's not necessary. Did you do the basic network configuration during the install?? Setting hostname for both standard hostname, and using the same name when it asks for a DHCP hostname works well, and then you can always view that information in the DHCP table in your Linksys router.

If you have no luck with this stuff, let us know. Also, please give the NIC make/model/revision and what version of Slackware? I assume 10.1??

Good Luck!!
Dear lord, you are the man. Hehe. I did the first two commands...the ifconfig eth0 up and dhcpcd eth0. Worked like a charm. Thanks so much!

Would you mind explaining this in further detail to me? Why wasn't it automatically setup/detected once I went through the basic network configuration? It did detect my NIC since it displayed the information when I typed in ifconfig eth0...but why was my loopback active only?

Just curious. Oh, and this was after a fresh install. Thanks again!
 
Old 05-09-2005, 01:20 PM   #4
fell
LQ Newbie
 
Registered: May 2005
Location: Sonoma County, CA
Distribution: Slackware 10.1
Posts: 12

Original Poster
Rep: Reputation: 0
Also..I'm noticing I'm not getting any sound. Man...this feels SO weird not being able to manipulate my OS. I see why a lot of Windows users don't switch over or take the time to check things out. Makes you feel like a total retard, even if you're a Microsoft NA. Bleh!

UPDATE: Did some research and got my sound working with the ALSACONF and ALSAMIXER. Turned out, everything was configured, but the master (as well as everything else) was turned off.

Last edited by fell; 05-09-2005 at 01:48 PM.
 
Old 05-09-2005, 03:07 PM   #5
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
there ya go.. I was going to suggest alsaconf and alsamixer...

As for it not starting on bootup, perhaps try the netconfig again?

As root, run 'pkgtool' and towards the bottom you'll see "Setup", select that, and then select 'netconfig' and set up your stuff appropriately, when it asks about a DHCP hostname, even though it's not required, I always find it a good idea to go ahead and use the same name you used for the standard hostname...

If you decide you'd like to set other IP stuff, check out /etc/rc.d/rc.inet1.conf

good luck man!
 
Old 05-09-2005, 03:57 PM   #6
fell
LQ Newbie
 
Registered: May 2005
Location: Sonoma County, CA
Distribution: Slackware 10.1
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by halo14
there ya go.. I was going to suggest alsaconf and alsamixer...

As for it not starting on bootup, perhaps try the netconfig again?

As root, run 'pkgtool' and towards the bottom you'll see "Setup", select that, and then select 'netconfig' and set up your stuff appropriately, when it asks about a DHCP hostname, even though it's not required, I always find it a good idea to go ahead and use the same name you used for the standard hostname...

If you decide you'd like to set other IP stuff, check out /etc/rc.d/rc.inet1.conf

good luck man!
Thanks again for the reply.

I'm building a machine from spare parts to put a second installation of Slackware onto. Going to try and get it to be the server of sorts..and have the two talk to one another. After that, I figure I'll dive into the apache web server. I have a couple domains I'd love to transfer over (just hobby related stuff)...see if I can't run it.

In the meantime, I'm still familiarizing myself with the file structure, command line commands (I started in DOS back in the day when Windows 3.11 was prevelant) and over all use. Trying to figure out how to add users. I can do it in KDE easily, but as for the shell...still working on it.

This place has been an invaluable resource. I've only had my laptop running Slackware for a few hours, and already I've learned so much.
 
Old 05-09-2005, 04:01 PM   #7
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
that's awesome, keep at it.. you'll learn a lot.. Glad to see you choose Slackware as your first ditro...

you can use 'adduser' from the console to add users...
 
Old 06-01-2005, 11:03 PM   #8
baseballfan
LQ Newbie
 
Registered: May 2005
Location: USA Northern Kentucky
Distribution: Tried Ubuntu, Damn Small Linux, Knoppix
Posts: 10

Rep: Reputation: 0
Very Helpful

I couldnt get the internet to work and found out I had to run dhcpcd...thanks for all of the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SlackWare Internet BlackVoid Linux - Newbie 9 10-28-2005 07:02 PM
No Internet In Slackware duffmckagan Slackware 22 06-19-2005 01:22 PM
no internet in slackware 9.1.. tehnick Linux - Networking 1 05-10-2004 06:58 PM
Slackware - CAn't Go On INternet RealmX Slackware 1 12-31-2003 01:50 PM
No internet on slackware 9 jr6676 Slackware 9 08-05-2003 09:31 PM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration