LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2003, 11:11 AM   #1
InEeDhElPlInUx
Member
 
Registered: Sep 2003
Posts: 107

Rep: Reputation: 15
Getting MP3's off NTFS Drive


Alright so I have my 60 gig cut in half xp on one then redhat on the other. I have my 80 gig as NTFS. It has all my music...software...etc. I would be nice to have that when I boot up linux. Now how do I get it so I can find that shared drive. I have it shared in windows and I can get on the the other shared drive on my network when I click on Network Servers. Do I need Samba or something along those lines? I think I've already installed it...not sure though. Still learning
 
Old 10-12-2003, 11:47 AM   #2
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
Re: Getting MP3's off NTFS Drive

Quote:
Originally posted by InEeDhElPlInUx
Alright so I have my 60 gig cut in half xp on one then redhat on the other. I have my 80 gig as NTFS. It has all my music...software...etc. I would be nice to have that when I boot up linux. Now how do I get it so I can find that shared drive. I have it shared in windows and I can get on the the other shared drive on my network when I click on Network Servers. Do I need Samba or something along those lines? I think I've already installed it...not sure though. Still learning
That 80gb disk with the music, is that on a network server ? or is it a fysicall disk inside your machine ?
 
Old 10-12-2003, 12:02 PM   #3
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
If the 80GB disk you want to access is on the same computer simply mount it.

1. Create a mountpoint. This is a directory where you will be able to access the partition once it's mounted. The /mnt directory is where you usually mount things, so create a directory called "windows" (or something) there.

2. Check what the partition name is. If the disk is mounted as slave on the primary IDE controller it should be called /dev/hdb. You could run /sbin/fdisk /dev/hdb and then, in fdisk, type p to list the partitions and then q to exit fdisk. It should be listed as ntfs.

3. Mount the disk. As root, do mount -t ntfs /dev/hdb1 /mnt/windows, where /dev/hdb1 is the NTFS partition you wish to mount and /mnt/windows is the mountpoint that you created.

If no error messages are displayed you should be able to go to /mnt/windows and list the files and dirs and access them as usual, but the NTFS module is by default limited to read-only operations.

hw
 
Old 10-12-2003, 01:58 PM   #4
InEeDhElPlInUx
Member
 
Registered: Sep 2003
Posts: 107

Original Poster
Rep: Reputation: 15
alright so I did that and everyone was good until it said my kernel doesnt support it. I tried upgrading my kernel but Redhat wont boot with it because of my FX5600. I says that the kernel doesnt support my nvidia driver. Any suggestions?
 
Old 10-12-2003, 02:05 PM   #5
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
go back to your old redhat kernel. Then take a look at this thread - the search function is your friend:
http://www.linuxquestions.org/questi...hreadid=103088
it gives you a link where you can download an rpm that will install ntfs support for redhat.
 
Old 10-12-2003, 02:36 PM   #6
InEeDhElPlInUx
Member
 
Registered: Sep 2003
Posts: 107

Original Poster
Rep: Reputation: 15
Thanks a bunch but I still dont know how to give myself...not root permission to read the folder. It's alright when I'm logged on as root but as soon as I log on as myself I says I dont have permission into the folder

Last edited by InEeDhElPlInUx; 10-12-2003 at 02:45 PM.
 
Old 10-12-2003, 02:53 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
do you have an entry in the fstab? Then add umask=0 as one of the options. E.g.

/dev/hda1 /mnt/winxp ntfs auto,ro,umask=0 0 0

if you're mounting manually:
mount -t ntfs -o umask=0 /dev/hda1 /mnt/winxp

of course, change the mount point to what you have.
 
Old 10-12-2003, 03:01 PM   #8
InEeDhElPlInUx
Member
 
Registered: Sep 2003
Posts: 107

Original Poster
Rep: Reputation: 15
how would I add an entry into the fstab...if I did that it would mean I would have to manually mount it everytime right?
 
Old 10-12-2003, 03:09 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
the full path of the fstab file is
/etc/fstab
you have to be root to be able to edit it. When you look at it, you'll see various entries for what partition gets mounted where with what options. You can add an entry for your xp partition. Something like
/dev/hda1 /mnt/winxp ntfs auto,ro,umask=0 0 0

you can change the mount point to your liking. After this, it will get mounted at boot time and will stay mounted until you unmount it manually.
Take a look at
man fstab
and
man mount
for more details about what you can do. Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving files from NTFS drive to a EXT3 drive?? webshark Slackware 10 05-28-2006 03:02 PM
NTFS (winxp) drive is accessible only by root, why NTFS (winxp) drive not accessible Samppa72 Linux - Software 1 07-26-2004 03:13 PM
slackware 9.1 mounting problems (cd drive, cd writer drive, win partition (ntfs)) mr.gizm0 Slackware 8 05-11-2004 06:23 PM
mp3's on mounted windows drive rkemp Linux - General 6 12-03-2003 09:30 AM
Cannot Copy Files From Network FAT32/NTFS Drive to My Local Linux Drive michaelh Linux - Networking 3 10-29-2002 10:27 AM


All times are GMT -5. The time now is 10:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration