LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2003, 03:39 PM   #1
sammyd56
Member
 
Registered: Sep 2003
Posts: 36

Rep: Reputation: 15
Question Getting Internet Working!?!? HELP PLS


Hello there good sirs,

DISTRO: Mandrake 9.1

I am trying to get my internet connection working with Linux, but it is proving to be more difficult than I expected.

I connect to the internet using a router, which is connected to a NIC (properly connected and installed) via ethernet.

I used drakconnect (the network setup wizard) to try and set up my connection. I selected that I would like to connect by LAN through my ethernet adapter, and inputted my ip address and subnet mask correctly.

Then I clicked on next and it comes up with:

HOSTNAME: ?????
ZEROCONF: ?????
DNS: *Inputted correctly*
GATEWAY: *Inputted correctly*

What do I put under hostname and zeroconf? I tried leaving them blank - doesn't work No internet.

Any help greatly appreciated,

Sam
 
Old 09-23-2003, 03:43 PM   #2
sammyd56
Member
 
Registered: Sep 2003
Posts: 36

Original Poster
Rep: Reputation: 15
Just had a thought, my router has WEP encryption enabled. That might be the problem. Can you enter a WEP Key in Linux? If so, how?

Thanks,

Sam
 
Old 09-23-2003, 04:07 PM   #3
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Your connection to the router via ethernet and NIC will not be encrypted with WEP as far as I know. WEP is for the clients conneting to that wireless access point via wireless connections.

I suggest that you look at your network setup/config scripts in "/etc/sysconfig". In here you will find a files named something like ifcfg-eth0. Find the right one for you NIC and set up your IP, and Subnet there. Restart the network and your set;
 
Old 09-23-2003, 04:33 PM   #4
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
What type of router?

Type cat /etc/sysconfig/network

HOSTNAME=spongebob
NETWORKING=yes
GATEWAY=192.168.0.1
GATEWAYDEV=eth0

HOSTNAME should match what you get when you type hostname at the command prompt.. NETWORKING=yes is required. GATEWAY=192.168.0.1 <- This is the internal IP of the router.
GATEWAYDEV=eth0 <- The router is on eth0.

There could be other things in the file like DHCP and so on. When you finish fixing that file do what micxz suggested and then restart your network:
service network restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PLS Help- trouble w/ internet connection Jack_Tripper Red Hat 3 10-03-2005 10:04 PM
Pls help me!! I can't connect to internet!! falcon3000 Linux - Networking 2 09-21-2005 06:27 AM
xmms not playing .pls from internet fatblueduck Linux - Software 2 04-21-2005 10:57 PM
my samba suddenly is not working pls help sibu_rajappan Linux - Networking 0 06-07-2004 05:31 AM
pls pls pls help me ! i'm tired with httpd config on fedora apache 2.0.48 AngelOfTheDamn Fedora 0 01-24-2004 06:12 PM


All times are GMT -5. The time now is 03:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration