LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-08-2004, 08:42 PM   #1
Momboking
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Rep: Reputation: 0
Getting Grub to dual boot with Morphix running Lilo


Ok, here is the deal:

Lets start with the OSs':

Win XP on NTFS partition---> installed on hda0,0

Morphix (hybred) running Phlak---> installed on partition hda0,4 with lilo installed on the / partition. When this drive is mounted it mounts as"/mnt/hda5. I'm not sure why its not da0,4, which is simular to the Red Hat string inside the grub.conf file.

Red Hat 9---> installed on hda0,5 with Grub bootloader

When I boot up I get the option to boot to "DOS" or "rh9". Both options work fine.

My problem is with Morphix running Lilo. I found the vmlinuz-2.4.21-xfs, config-2.4.21, boot-menu.b, and boot.0300 in /mnt/hda5/boot.

I need to see an example of the proper config in my grub.conf file to make Morphix(phlak) boot.

P.S. the mnt/hda5/boot/etc/lilo.conf is emty
 
Old 03-08-2004, 08:48 PM   #2
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try
Code:
title Morphix
rootnoverify (hd0,4)
chainloader +1
 
Old 03-08-2004, 09:09 PM   #3
Momboking
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Original Poster
Rep: Reputation: 0
I just tryed this and it did not work
 
Old 03-08-2004, 09:17 PM   #4
Demonbane
Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
then you probably don't have lilo installed in hda5, since lilo.conf is empty
can you do a "/sbin/fdisk -l" ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install grub, lilo running.. slack10.1 rkrishna Slackware 16 06-22-2005 05:59 AM
lilo vs grub, dual-booting binkgle Ubuntu 6 05-16-2005 01:39 AM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 01:44 PM
How to load linux in dual boot sys(grub not running)? karfei00 Linux - General 6 06-01-2004 04:41 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 05:00 PM


All times are GMT -5. The time now is 03:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration