LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-24-2004, 03:21 PM   #1
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Rep: Reputation: 30
Getting Ethernet working... Slackware box, uber-newb.


Well, in dmesg, it states

Code:
00:0a.0: 3Com PCI 3c905 Boomerange 100baseTx at 0xb800.   Vers LK1.1.18-ac 00:60:08:a1:39:61, IRQ 5
and then a paragraph of stats for it... but 2 lines down, it says
Code:
eth0: Dropping NETIF_F_SG since no checksum feature.
I also have another card in there at 0xb400, mostly the same card, same model number, at eth1, and it says the same no checksum...

I'm trying to set this up with DHCP comcast internet, and having no luck... can anyone help?

Tell me what you need, I'll slap it on.

Last edited by Diademed; 07-24-2004 at 05:43 PM.
 
Old 07-24-2004, 05:16 PM   #2
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi Diademed,
Are you using kernel 2.6. I did some google with your error message and is plenty of posts for 2.6 with this card. If you have 2.6, try boot with 2.4. Post us your results.

Have a funny week end!
 
Old 07-24-2004, 05:43 PM   #3
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
I imagine it is 2.6

It's the kernel off the Slack10 disk--, so I imagine it would be the latest...all right, I'll try, thanks
 
Old 07-24-2004, 06:24 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,158

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Slackware 10 ships with both 2.4 and 2.6 kernels -- do "uname -r" at the command line and see what it says.
 
Old 07-25-2004, 01:56 AM   #5
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
Sorry, it's 6.4.26.
 
Old 07-25-2004, 02:39 PM   #6
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
EDIT: It stopped working. Disregard this post. /EDIT

I got it working!!!

For those of you in the same situation try this....
Quote:
The first thing I'd want to do is get my network going (if it isn't already). The netconfig utility that ran during setup, could not probe for my network adapter. However, I know that it uses the sundance module. How did I know that? Well, when I first bought those NICs, I typed D-Link 530TXS Linux (the "S" is significant in the model number) into a search engine (Google) and found the tidbit I needed in mailing list archives and the like.

Now, during setup we configured our network with the exception of the driver module for the network adapter. That means, all we have to do is load the module, and start the network. Slackware's startup scripts look for a script file named rc.netdevice in the /etc/rc.d directory. This is where the system init scripts are located on Slackware system. (It uses the BSD style init script mechanism)

It is very easy to create this file from the command line. As root, type:

echo "/sbin/modprobe sundance" > /etc/rc.d/rc.netdevice

This will redirect the output of the echo command into the specified text file that will get created. The quotes are important, because there is a space in the string we are echoing. Use the correct module name for your network adapter, of course.

Now, set the file executable:

chmod 755 /etc/rc.d/rc.netdevice

That's it, on the next reboot your network should initialize.

Alternatively, to load a network adapter module, you could uncomment the appropriate module loading line (or add one) in the /etc/rc.d/rc.modules init script.

Now, I don't feel like rebooting at the moment, so I'm going to just type a few simple commands to start the network.



I'm loading the module, then using the ifconfig utility to specify the interface, IP address of the machine, and subnet mask, and then using the route command to specify my router as the gateway.

You probably will want to attempt to start the XFree86 GUI now. By default, Slackware is set up to use the VESA Framebuffer driver for your display hardware. The /etc/X11/XF86Config file is a copy of the file XF86Config-vesa in the same directory.

So if you type startx you may have a usable GUI if the settings are compatible with your display hardware. That will do in a pinch, but you will want to properly configure XFree86 and use the accelerated driver for your video card (which hopefully exists, otherwise you've got some generic options)
All I did was switch his Sundance module for the 3c59x module that is compatible with my card, rebooted, and ping'd www.google.com, and now on tty1, the ping command is running... still... I can't figure out how to shut it off.....


Last edited by Diademed; 07-27-2004 at 05:17 PM.
 
Old 07-25-2004, 05:12 PM   #7
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,158

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Control+C sends SIGINT to the ping program, shutting it down (this works for most other programs). Good that you got it working .
 
Old 07-25-2004, 11:09 PM   #8
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
Thanks--I tried everything I could think of... Break, ctrl+alt+break, ctrl+break, esc, ctrl+esc... etc...

Nothing worked. Of course it would be something simple like that. Good to know!
 
Old 07-27-2004, 05:16 PM   #9
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
I take everything back. It stopped working. Back to square one. Any thoughts on why it started, then stopped....?
 
Old 07-27-2004, 05:49 PM   #10
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,158

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Did it stop working after a reboot? If so, your driver module probably wasn't initialized correctly on boot. Since the sundance module worked for you, what does "modprobe sundance" give you now? After you modprobe does ifconfig show eth0?
 
Old 07-27-2004, 10:57 PM   #11
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi Diademed,
All you need to load the proper driver for your ethernet is to enter
Code:
alias eth0 3c59x
in the file "/etc/modules.conf". After you do this, you have to enter
Code:
depmod -a
to activate this configuration change. Your network configurations on slackware must be in a file named "/etc/ rc.d/rc.inet1.conf", at least in slackware 9.1 which I have installed.
The rc.netdevice must be conceived for any special driver, may be wireless, as the normal ethernet cards are properly recognized by the kernel and may be treated at "/etc/modules.conf" or at /etc/rc.d/rc.modules.
 
Old 07-28-2004, 12:55 PM   #12
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
I use the 3c59x module, not the sundance module, but I sort of thought that the modprobe was a temporary fix.

Anyway, thanks, you guys, I hope this is a permanent fix!

One thing.... my modules.conf file said something to the effect of "GENERATED BY ALSACONF DON'T EDIT", But I ignored that and made my changes anyway. I do not expect any drastic consequences, but should I ?

Thanks again!
 
Old 07-28-2004, 01:07 PM   #13
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
nope, modprobe is vital tool for loading drivers and modules.

Quote:
Sorry, it's 6.4.26
kernel 6.4.26 wow...
was Doc right ? do time machines have flux capacitors and time circuits ?
i take it linux survived all this software patent crap. is windows still around ?
what are Nvidia GeForce12's like ?
does kernel 6.4.X support quantum CPU's ?
 
Old 09-16-2004, 11:34 PM   #14
Diademed
Member
 
Registered: Jul 2004
Distribution: Slackware 10.2
Posts: 159

Original Poster
Rep: Reputation: 30
I musn't say.... might cause a rift in the space-time continuum, you know...

Now be nice or I'll go back farther and marry your mother.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to write to hardrive from windows computer - uber newb violettheconqueror Linux - Hardware 4 09-23-2005 07:54 PM
4 Uber-newb ?'s kendan Linux - Newbie 6 09-13-2005 01:11 AM
Uber Newb Question Here natenate Linux - Newbie 2 09-25-2004 10:44 AM
Is anzone willing to help an uber newb config suse? marpil Linux - Newbie 1 03-28-2004 05:25 PM
Newb Ethernet problem. Please Help. lumpfish Linux - Networking 2 08-02-2003 09:14 PM


All times are GMT -5. The time now is 07:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration