LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2016, 03:33 PM   #16
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled

I placed the ttf fonts in /usr/share/fonts/ttf

Ran ttmkfdir -o fonts.scale ; mkfontdir no errors

Then ran xset +fp /usr/share/fonts/ttf

[prod.dwreports (root) <ttf>] xset +fp /usr/share/fonts/ttf
xset: bad font path element (#1), possible causes are:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Incorrect font server address or syntax

I'm sorry to keep at it. But, I'm out of options. If not possible I'll just have the reports developer to use the fonts already available. The issue is that we're migrating the reports from 10g to 11g and there are hundreds of reports and all of them use the arial fonts.

Thanks for all your help!

Ana
 
Old 02-04-2016, 03:34 PM   #17
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
By the way, I checked the permissions on all of the directories and fonts in /usr/share/fonts and they all have the same.

Thanks

Ana
 
Old 02-05-2016, 11:13 AM   #18
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,613

Rep: Reputation: 433Reputation: 433Reputation: 433Reputation: 433Reputation: 433
Quote:
Directory does not exist or has wrong permissions
Directory missing fonts.dir
Ana, as we pointed out initially (above) that "font" directory is somewhere /usr/share/fonts or $HOME/.fonts, yet, as I understood after your explanation, your OS is not a common GNU/Linux distro, it is an Oracle-mizteza, something I cannot agree or disagree with reasons.
Your error reports simply tells us that your xset did not find the folder. I don't know, it might turn out right if you try save it at $HOME/ttf. Just play with it.

Good luck.
 
Old 02-05-2016, 11:17 AM   #19
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
OK, thanks! There is also a problem with the DISPLAY variable. When I start ssh, or putty, the DISPLAY is set at localhost:10.0 on the server. When I try to enter any xset command it complains about the DISPLAY localhost:10.0 is not found (either as oracle or root). So, I change it to localhost=:0 and that works.

Thanks for all your help. I'll try again. We're on test right now, but we're going live on Wednesday 2/10. We'll be using the available fonts at that time, but it will be nice if we could get the arial fonts available, as it will mean the reports developer will not have to change hundreds of reports.

Thanks again!

Ana
 
Old 02-07-2016, 06:32 PM   #20
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,613

Rep: Reputation: 433Reputation: 433Reputation: 433Reputation: 433Reputation: 433
Quote:
but it will be nice if we could get the arial fonts available, as it will mean the reports developer will not have to change hundreds of reports.
n If you don't give up you shall solve it. Good luck.
 
Old 02-08-2016, 08:47 AM   #21
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
I'm still trying. Thanks for your help.

Ana
 
Old 02-08-2016, 03:25 PM   #22
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
I was wondering if the problem is with the fonts directory path. I entered xset -q and the fonts path points to my windows xming fonts directory, not to the server's.

[prod.dwreports (achoto) <~>] xset -q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000002
XKB indicators:
00: Caps Lock: off 01: Num Lock: on 02: Scroll Lock: off
03: Shift Lock: off 04: Group 2: off 05: Mouse Keys: off
auto repeat delay: 500 repeat rate: 31
auto repeating keys: 00ffffffdffffbbf
fadfffdfffdfe5ef
ffffffffffffffff
ffffffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 600 cycle: 600
Colors:
default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
built-ins,C:\Program Files (x86)\Xming/fonts/misc/,C:\Program Files (x86)\Xming/fonts/TTF/,C:\Program Files (x86)\Xming/fonts/75dpi/
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
Server does not have the DPMS Extension


Tnanks!

Ana
 
Old 02-10-2016, 02:39 PM   #23
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
I wasn't successful setting up the arial fonts. But, now we can't open Oracle reports using a certain URL where the reports name is included. Not sure if whatever I've done to make the arial fonts available is the culprit. Is there a way to just go back to whatever we had previously. Meaning go back to the default fonts setting. I've tried xset -fp <my arial ttf fonts> dir but that doesn't delete the fonts from the fonts path.

The display variable is giving me grief. I've used ssh and putty. But it doesn't seem to work.

When I enter xset -q I see that the fonts path for the arial fonts are still there.

Font Path:
/usr/share/X11/fonts/arial-fonts,/usr/share/X11/fonts/arial-fonts/,/etc/arial_fonts,/etc/arial_fonts,catalogue:/etc/X11/fontpath.d,built-ins

In other server I have only /etc/X11/fontpath.d,built-ins

Thanks!

Ana
 
Old 02-10-2016, 04:52 PM   #24
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
Never mind. I found out how to reset the Font Path. The issue with the reports wasn't with the fonts anyway.

Thanks!

Ana
 
Old 02-11-2016, 01:30 PM   #25
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,613

Rep: Reputation: 433Reputation: 433Reputation: 433Reputation: 433Reputation: 433
Ana, have you solved the problem? Is it doing now as you wanted to?
If xorg has problem with the desired font path you can make a link to it from the xorg path.
Are you running xset locally?
 
Old 02-11-2016, 01:48 PM   #26
achoto
LQ Newbie
 
Registered: Feb 2016
Location: Silver Spring, Maryland
Posts: 17

Original Poster
Rep: Reputation: Disabled
No, I tried several times but I failed. I restored the original path font, because we were getting some other issues with the reports server and I wasn't sure what I had been doing was the culprit. So, I left it alone. I noticed that there were some soft links to some fonts but as I said, I didn't want to keep at it. We're in the testing phase and we were supposed to go live last night but, we couldn't because of other issues. If I want to keep on trying, how do I go about making the link from the xorg path?
I'm login on to the server via ssh and I have been running xset as root, either using sudo xset .... or sudo su - and then running xset ....
What happens is that the display variable changes if I sudo su -. It also doesn't like the localhost:11.0 or localhost:10.0 (it keeps on changing also depending where I'm login to the server from)
One thing I notice is that if I logon as myself or sudo and type xset -q the fonts path points to the server. But if I logon as oracle, the font path points to the xming fonts in my computer.

I don't know what to do anymore, and as I said, going into production if we solve all the issues we're having I don't want to touch it anymore.

Thanks!

Ana
 
Old 02-12-2016, 11:57 AM   #27
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,613

Rep: Reputation: 433Reputation: 433Reputation: 433Reputation: 433Reputation: 433
Your oracle uses local fonts. Copy the fonts into your local host in a place where oracle or report reader knows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Arial fonts.tgz rody Slackware 17 01-22-2011 01:56 PM
TTF to Linux fonts Shioni Linux - Software 6 01-18-2007 10:15 PM
Fonts - parameters in -misc-arial.... kaise_sose Linux - Newbie 0 09-15-2004 12:50 PM
Any way to convert ttf fonts to linux console fonts? Glockage Linux - Software 7 12-30-2002 07:41 AM
How to add ttf fonts Bogdan Linux - Newbie 2 03-31-2002 03:17 AM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration