LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-25-2006, 01:10 AM   #1
lexx11
LQ Newbie
 
Registered: Jan 2006
Posts: 11

Rep: Reputation: 0
getting back to GUI from command line


What is the command to get back to KDE from bash?
I've been stumped on this for a while (first time playing around with CLI).

Thanks

Last edited by lexx11; 03-25-2006 at 01:29 AM.
 
Old 03-25-2006, 01:22 AM   #2
kevkim55
Member
 
Registered: Dec 2005
Location: Edmonton
Distribution: BLFS, Gentoo
Posts: 353

Rep: Reputation: 32
If you switched to the virtual console by pressing Alt+Ctrl+F<1-6> you should know how to get back to GUI - Alt+Ctrl+F7 !
 
Old 03-25-2006, 01:28 AM   #3
lexx11
LQ Newbie
 
Registered: Jan 2006
Posts: 11

Original Poster
Rep: Reputation: 0
still having problems

I'm not in virtual console... I somehow changed it so that it boots up to CLI and I don't know how to enter GUI mode.

I typed "startx" but it says:

execute failed for /etc/X11/X (error 2)
giving up.
xinit: No such file or directory (error 2): unable to connect to xserver
xinit: No such process (error 3): Server error


Please help!

Update:

I read somewhere else to go to /etc/inittab to change id:3:initdefault to a "5" instead of "3". I tried switching to su, but I still get permission denied when I type /etc/inittab.

What should I do from here?

Thanks

Thanks!

Last edited by lexx11; 03-25-2006 at 01:49 AM.
 
Old 03-25-2006, 01:46 AM   #4
inam75
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Rep: Reputation: 0
init 5 to switch to GUI

If you switched to the virtual console by pressing Alt+Ctrl+F<1-6> you should know how to get back to GUI - Alt+Ctrl+F7 !

Secondly, you can type run level command "init 5" to switch to GUI interface from CLI.
Just type
init 5
dont enclose it in double qoutes.

Lastly if u want to make it default (run GUI at startup) you can make changes in inittab (inittab cantains run level settings) file.
cd /etc
vi inittab
Find the line containing word 'default', set default to 5. Save the changes and exit from the vi editor.
next time when you restart your system, it will bootup in GUI mode.
 
Old 03-25-2006, 01:50 AM   #5
lexx11
LQ Newbie
 
Registered: Jan 2006
Posts: 11

Original Poster
Rep: Reputation: 0
This isn't working at all. I did "vi inittab" like you said, and I figured out how to change the 3 to a 5, then save and exit.

I restart, and I am back in Bash. If I look at inittab, it says "id:5:initdefault", which is what I think I want. Why is it not booting up into GUI?

Also, typing "init 5" doesn't do anything.

Thanks

Last edited by lexx11; 03-25-2006 at 02:20 AM.
 
Old 03-25-2006, 12:08 PM   #6
bmarx
Member
 
Registered: Dec 2004
Distribution: Slackware, Arch, FreeBSD
Posts: 202

Rep: Reputation: 34
which distro are you using? i use slack, and runlevel 5 is configured to be the same as runlevel 3, which boots into text mode - although startx from the command line boots to my default window manager with no problem. And I point out that I have never tried booting to runlevel 5...

I boot to runlevel 4 to get to my login gui screen, but figuring out your inittab sounds like it would fix the problem...
 
Old 03-25-2006, 03:20 PM   #7
johndoe0028
Member
 
Registered: Jun 2005
Location: CA, USA
Distribution: Gentoo
Posts: 165

Rep: Reputation: 30
If you're trying startx, do you have a .xinitrc file in your home?

If not, make one and put this line in it:

exec startkde

Then, startx will start X, then KDE.



Hope this helps.

-[EDIT]-

Oops, thanks

Last edited by johndoe0028; 03-25-2006 at 09:01 PM.
 
Old 03-25-2006, 03:43 PM   #8
sumguy231
Member
 
Registered: Apr 2004
Location: North America
Distribution: Kubuntu 7.04 - Feisty Fawn
Posts: 296

Rep: Reputation: 30
^Typos can cause problems, so it should be noted that the above should read '.xinitrc'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get back into command line interface bonniehandi Linux - Newbie 1 11-19-2005 12:07 AM
Going back to the command line? Mathiasdm Debian 5 02-10-2005 02:55 PM
Command line runs back on itself SharpyWarpy Linux - General 2 11-25-2003 06:56 PM
gui vs. command line sdfjk Linux - Newbie 1 10-05-2002 03:59 PM
Command Line vs GUI Poorman Linux - General 27 07-11-2002 12:40 PM


All times are GMT -5. The time now is 09:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration