LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Getting a text console runlevel in Kubuntu 10.04 (Changing runlevel won't work) (http://www.linuxquestions.org/questions/linux-newbie-8/getting-a-text-console-runlevel-in-kubuntu-10-04-changing-runlevel-wont-work-830399/)

gregorian 09-04-2010 11:53 PM

Getting a text console runlevel in Kubuntu 10.04 (Changing runlevel won't work)
 
As you might already know, runlevels 2 -5 are identical in Ubuntu. /etc/init/rc-sysinit.conf is used instead of /etc/inittab for changing the runlevel. But there's no point doing that since the runlevels are identical. The default runlevel is 2, so I tried to find some service I could disable in /etc/rc2.d. I didn't find anything I could work with.

Thank you for your help.

DevilFreeBSD 09-05-2010 04:10 AM

Disable compiz fusion. Chmod -x /usr/bin/compiz. (Undo later +x)

If you have a black screen, Ctrl_alt_F2 gets you console login. Now try to configure X (the gui) simple command. X configure. Test that. (After command, it will tell you how) No workie means that Xorg ain't working. That means you need a distro with balls. Try linux mint. They have drivers. Or find out if you can install xfree86.

If they ask who sent you say FSF or RMS.

bsat 09-05-2010 08:06 AM

Press "esc" while booting to go to the grub menu
Press "e" on the line which displays the "os" you want to boot

Another menu will be displayed, take the cursor to the line that starts with the "kernel"
Press "e"
add the sting "text" at the end of the line and "enter"
press b

This should take you to the text mode.

jay73 09-05-2010 09:01 AM

Quote:

As you might already know, runlevels 2 -5 are identical in Ubuntu.
Actually, runlevels are an illusion in ubuntu. They are really faked so as to maintain compatibility with debian. The point is that ubuntu wants to introduce more flexibility by breaking the link between services and runlevels.

Quote:

/etc/init/rc-sysinit.conf is used instead of /etc/inittab for changing the runlevel
But you can still create an inittab manually, or at least, you could do so until fairly recently. I haven't needed to do so for a while so I cannot guarantee it still works that way.

gregorian 09-05-2010 11:50 AM

Thank you all for your help. I added the text option at the end of the kernel in grub.cfg . As most you might have experienced, the computer rarely wakes up from sleep. And when it does, the NetworkManager applet causes some problems. Now I can simply close X and sleep. It might now wake up, but at least the NetworkManager won't cause problems.


All times are GMT -5. The time now is 11:31 PM.