LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-04-2010, 10:53 PM   #1
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Rep: Reputation: 33
Getting a text console runlevel in Kubuntu 10.04 (Changing runlevel won't work)


As you might already know, runlevels 2 -5 are identical in Ubuntu. /etc/init/rc-sysinit.conf is used instead of /etc/inittab for changing the runlevel. But there's no point doing that since the runlevels are identical. The default runlevel is 2, so I tried to find some service I could disable in /etc/rc2.d. I didn't find anything I could work with.

Thank you for your help.
 
Old 09-05-2010, 03:10 AM   #2
DevilFreeBSD
LQ Newbie
 
Registered: Aug 2010
Distribution: kodak digital unix
Posts: 18
Blog Entries: 12

Rep: Reputation: 3
Disable compiz fusion. Chmod -x /usr/bin/compiz. (Undo later +x)

If you have a black screen, Ctrl_alt_F2 gets you console login. Now try to configure X (the gui) simple command. X configure. Test that. (After command, it will tell you how) No workie means that Xorg ain't working. That means you need a distro with balls. Try linux mint. They have drivers. Or find out if you can install xfree86.

If they ask who sent you say FSF or RMS.
 
0 members found this post helpful.
Old 09-05-2010, 07:06 AM   #3
bsat
Member
 
Registered: Feb 2009
Posts: 347

Rep: Reputation: 72
Press "esc" while booting to go to the grub menu
Press "e" on the line which displays the "os" you want to boot

Another menu will be displayed, take the cursor to the line that starts with the "kernel"
Press "e"
add the sting "text" at the end of the line and "enter"
press b

This should take you to the text mode.
 
Old 09-05-2010, 08:01 AM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Quote:
As you might already know, runlevels 2 -5 are identical in Ubuntu.
Actually, runlevels are an illusion in ubuntu. They are really faked so as to maintain compatibility with debian. The point is that ubuntu wants to introduce more flexibility by breaking the link between services and runlevels.

Quote:
/etc/init/rc-sysinit.conf is used instead of /etc/inittab for changing the runlevel
But you can still create an inittab manually, or at least, you could do so until fairly recently. I haven't needed to do so for a while so I cannot guarantee it still works that way.

Last edited by jay73; 09-05-2010 at 08:03 AM.
 
1 members found this post helpful.
Old 09-05-2010, 10:50 AM   #5
gregorian
Member
 
Registered: Apr 2006
Location: India
Posts: 473

Original Poster
Rep: Reputation: 33
Thank you all for your help. I added the text option at the end of the kernel in grub.cfg . As most you might have experienced, the computer rarely wakes up from sleep. And when it does, the NetworkManager applet causes some problems. Now I can simply close X and sleep. It might now wake up, but at least the NetworkManager won't cause problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
runlevel 1 doesn't work [kubuntu] froginvasion Ubuntu 4 03-20-2009 12:18 PM
Weird: Changing runlevel from 3 to 4 makes sound not work Melkor Slackware 35 05-19-2008 03:30 PM
New Install of PCLinuxOS boots into runlevel 3. Should be runlevel 5 MonctonJohn Linux - General 4 02-01-2008 04:38 PM
Soun Mixer absent in Runlevel 3 but present in Runlevel 5 debloxie Suse/Novell 1 01-18-2006 09:15 AM
Set text (runlevel 3) console character width davee Linux - Newbie 2 11-16-2003 03:33 PM


All times are GMT -5. The time now is 07:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration