LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2008, 06:40 PM   #1
geoffupton
LQ Newbie
 
Registered: Mar 2008
Location: Stafford UK
Distribution: debain lenny and debian etch (not on the same system!)
Posts: 13

Rep: Reputation: 0
Question getting a KDEInit could not launch '/usr/bin/epiphany' error


hi, wonder if anyone can work our why this error is appearing and how to fix it

KDEInit could not launch '/usr/bin/epiphany'

it seems to happen when i click links in emails (email prog is icedove) and links in kopte. This is annoying as I've got iceweasel as default browser and don't even have epiphany installed (I know this because i uninstalled it!!) i've set it as the default web program in the Gnome control panel preferred applications thing, but it still does it! As far as i can see there aren't any other web browsers installed!

Any idea's how to kill or fix this????

Btw I;m running Debian Etch
 
Old 03-23-2008, 06:59 PM   #2
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
Trick it...?

Hi,

Don't have much experience with debian, but how about making a symlink to your browser from /usr/bin/epiphany?

This would probably make it load iceweasel in stead?

It's more of a hack than a solution, but at least it won't take long to try...
 
Old 03-24-2008, 04:40 AM   #3
geoffupton
LQ Newbie
 
Registered: Mar 2008
Location: Stafford UK
Distribution: debain lenny and debian etch (not on the same system!)
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Retrievil_Knievil View Post
Hi,

Don't have much experience with debian, but how about making a symlink to your browser from /usr/bin/epiphany?

This would probably make it load iceweasel in stead?

It's more of a hack than a solution, but at least it won't take long to try...
thaanks for the quick reply Retrievil, im not sure how to make a symlink as I'm quite a newbie to the cool world of Linux/Debian (about 2 weeks!!!) I've had a look in /usr/bin/ and the epiphany directory isn't there.

Ah well, thanks for having a go Retrievil
 
Old 03-25-2008, 07:08 AM   #4
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
Try opening a root shell/terminal session, and do the following:

ln -s /usr/bin/iceweasel /usr/bin/epiphany

This should create a symlink to the iceweasel binary from the epiphany-name, which should trick it into starting iceweasel instead.
 
Old 03-25-2008, 03:52 PM   #5
geoffupton
LQ Newbie
 
Registered: Mar 2008
Location: Stafford UK
Distribution: debain lenny and debian etch (not on the same system!)
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Retrievil_Knievil View Post
Try opening a root shell/terminal session, and do the following:

ln -s /usr/bin/iceweasel /usr/bin/epiphany

This should create a symlink to the iceweasel binary from the epiphany-name, which should trick it into starting iceweasel instead.
Man that is so excellent, thanks, it works perfectly... i must remember this one! LOL
 
Old 04-14-2008, 08:31 AM   #6
Retrievil_Knievil
Member
 
Registered: Mar 2004
Location: Stavanger, Norway
Distribution: Gentoo, Slackware/SLAX, Knoppix, CentOS, IPCop & DSL
Posts: 138

Rep: Reputation: 21
Thumbs up Cool

Excellent.... Always good to be able to cheat the system a little....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDEInit could not launch '/usr/bin/openkmenu'. Richie55 Mandriva 2 10-14-2007 07:54 AM
Kmail KDEInit could not launch '/usr/bin/firefox' issue wth DCOP registration mdv2007 Emmanuel_uk Mandriva 0 11-05-2006 04:40 PM
KDEInit could not launch '/usr/bin/vmware' aztrix Linux - Software 3 07-15-2005 01:17 PM
KDEinit error message: /usr/bin/autorun kpsornes SUSE / openSUSE 0 05-13-2005 03:54 AM
KDEInit could not launch '/usr/bin/autorun' in Manrake 9.0 orca Linux - Distributions 2 03-22-2003 03:22 PM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration