LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-24-2009, 12:33 PM   #1
4dummies
LQ Newbie
 
Registered: May 2009
Location: Central coast of California.
Distribution: Xubuntu
Posts: 10

Rep: Reputation: 1
gentoo using xorg 1.5, now cannot find my ATI Rage XL video adapter


I've been running gentoo on this box since 2002. The video is integrated on the motherboard, and describes itself as ATI Rage XL.

I've been trying for about a week to get it working with the latest xorg server from gentoo, and I'm about to give up.

I've gotten it to load the fglrx driver, but it reports that no suitable device was found, and I have to run that machine by logging in from another machine via SSH.

Can anybody verify for me that a new xorg can be made to work with Rage XL? I'd like to move to Fedora Core or Ubuntu if I have to move at all --
I use FC at work, and Ubuntu on my laptop, so I'd be comfortable either way, but I'd like to know it's going to work.

Even better, can anyone give me hints on getting it to work on gentoo?
I'm using the latest ~86 ati-drivers, and latest stable xorg-server.

++ kevin
 
Old 05-24-2009, 02:56 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,689

Rep: Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687
the new ATI driver from ati HAS some VERY serious problems with xorg 1.5 and the "newer" kernels
use a OLD driver . Or wait for ati to build a "good" Linux driver
 
Old 05-24-2009, 03:36 PM   #3
4dummies
LQ Newbie
 
Registered: May 2009
Location: Central coast of California.
Distribution: Xubuntu
Posts: 10

Original Poster
Rep: Reputation: 1
Thanks, I was afraid of that.

No can do with gentoo.... One dare not get too far behind, and I had poor luck even blocking the xorg upgrade for a month. One thing led to another and I had to upgrade the kernel and drivers, but then that didn't work either.

I'll probably go to Ubuntu, using a slightly old release.

Drat.
 
Old 05-26-2009, 02:56 PM   #4
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40
4dummies,

You need the x11-drivers/xf86-video-ati for your card, or one of the other packages that x11-drivers/xf86-video-ati was broken into. Maybe x11-drivers/xf86-video-r128 ?
 
  


Reply

Tags
aticonfig, gentoo, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me get 2 ATI Rage XL Video Cards Going xmrkite Linux - Hardware 2 05-25-2009 11:37 AM
Xorg impossibly slow on Debian Etch (PowerPC) with ATI Rage 128 Pro video card Lannix Linux - Hardware 7 04-20-2007 01:41 AM
How do you use video in on ATI rage fury pro (128) to record from a video cam? ka9qlq Linux - Hardware 0 01-06-2005 07:48 PM
ATI 3D Rage Pro Video Card kystandardbred Linux - Hardware 4 02-14-2003 04:22 PM
ATI Rage Fury Pro - TV (S-Video) Out MasterC Linux - Hardware 3 06-30-2002 12:29 PM


All times are GMT -5. The time now is 01:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration