LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-26-2009, 02:08 AM   #1
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Rep: Reputation: 0
Unhappy Gentoo - Kernel Panic - Help :(


Hello to all,

Firstly, I have been using Linux now, both Fedora and Ubuntu, for around 2 months so not a complete newbie.

I have decided to compile Gentoo onto the laptopo instead, I have done all the compiling using Ubuntu Live CD and everything is ready and waiting.

I have also built my Kernel. HOWEVER, when I boot the laptop goes into a Kernel Panic - Not Syncing: No Init Found.

Here is a copy of my grub.conf which I made myself.

default=0
timeout=10
title Gentoo
root (hd0,0)
kernel /boot/vmlinuz root=/dev/sda1

What could be wrong?

Thanks,
Gentoo-Gav
 
Old 04-26-2009, 03:05 AM   #2
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
here is some other information in case it helps.

This is my ls -l output (not sure if it will help)

ubuntu boot # ls -l
total 4780
lrwxrwxrwx 1 root root 1 2009-04-25 06:30 boot -> .
-rw-r--r-- 1 root root 69789 2009-04-25 17:32 config-2.6.29-gentoo-r1
drwxr-xr-x 2 root root 4096 2009-04-25 18:43 grub
-rw-r--r-- 1 root root 1687044 2009-04-25 17:32 System.map-2.6.29-gentoo-r1
lrwxrwxrwx 1 root root 24 2009-04-25 18:46 vmlinuz -> vmlinuz-2.6.29-gentoo-r1
-rw-r--r-- 1 root root 3114240 2009-04-25 17:32 vmlinuz-2.6.29-gentoo-r1

And my mount

ubuntu boot # mount
rootfs on / type rootfs (rw)
none on /sys type sysfs (rw,nosuid,nodev,noexec)
none on /proc type proc (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,mode=755)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
/dev/scd0 on /cdrom type iso9660 (ro,noatime)
/dev/loop0 on /rofs type squashfs (ro,noatime)
tmpfs on /cow type tmpfs (rw,noatime,mode=755)
aufs on / type aufs (rw,noatime,si=a1fabae8a6182e24,xino=/cow/.aufs.xino,br:/cow=rw:/rofs=rr)
aufs on /dev/.static/dev type aufs (rw,noatime,si=a1fabae8a6182e24,xino=/cow/.aufs.xino,br:/cow=rw:/rofs=rr)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=755)
varrun on /var/run type tmpfs (rw,nosuid,mode=755)
varlock on /var/lock type tmpfs (rw,nosuid,nodev,noexec)
tmpfs on /lib/modules/2.6.27-7-generic/volatile type tmpfs (rw,mode=755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,gid=5,mode=620)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user_id=999,group_id=999)
/dev/sda1 on / type ext3 (rw,errors=continue,data=ordered)
/dev/mapper/stealth1-usr on /usr type ext3 (rw,errors=continue,data=ordered)
/dev/mapper/stealth1-var on /var type ext3 (rw,errors=continue,data=ordered)
/dev/mapper/stealth1-tmp on /tmp type ext3 (rw,errors=continue,data=ordered)
/dev/mapper/stealth1-portage on /usr/portage type ext3 (rw,errors=continue,data=ordered)
none on /proc type proc (rw,nosuid,nodev,noexec)
 
Old 04-26-2009, 03:09 AM   #3
kool_kid
Member
 
Registered: Sep 2004
Location: Dubai, UAE
Distribution: RHL
Posts: 350

Rep: Reputation: 30
add enforcing=0 to kernel line, like this and see if it works.

Quote:
kernel /boot/vmlinuz root=/dev/sda1 enforcing=0
 
Old 04-26-2009, 05:22 AM   #4
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
unfortunately this did not work.

The same results were experienced
 
Old 04-26-2009, 05:36 AM   #5
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
My guess is for some reason initrd was not installed or is just not found.... but the Not Syncing error is terribly generic so it's hard to hazard guesses here. If you can mount the hard drive with another distro you maybe able to check if init is correctly installed... unfortantly I do not know gentoo however, I think other distributions have an initrd declaration in grub... not sure if it's required or not but it could be that, that appears to be missing...
 
Old 04-26-2009, 08:06 AM   #6
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,206

Rep: Reputation: 230Reputation: 230Reputation: 230
Gentoo-Gav:

With 3GB of RAM I believe you do not need an initrd to boot your gentoo. The error you posted implies that grub doesn't see your gentoo system kernel. Do these:

--first try reinstall Gentoo into its partition (reformat this partition if possible; avoid overwriting old system files) allowing it to modify automatically the grub entries while installing. Find out if Gentoo runs on reboot.

--if above solution doesn't work then you have to recompile your linux kernel for gentoo and closely study your grub/menu.lst entries if the gentoo kernel is accurately pointed to at boot time.

hope this helps.

Goodluck.
 
Old 04-26-2009, 08:41 AM   #7
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Did you use genkernel to build the kernel ?

Did you build a custom kernel or did you minimize the kernel options ?
If you built a custom kernel, did you enable an initrd / Initial Ram system support ?
 
Old 04-26-2009, 09:11 AM   #8
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Hello,

Thanks for the help so far....

The Kernel was manually built by me and a friend.

In response to re-partitioning, I have been following the guides of a friend, how to I do this "without" losing everything I have built and compiled so far (it has taken 2 days lol).

If it helps I have a Samsung R710 laptop.

Gav
 
Old 04-26-2009, 09:23 AM   #9
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Did you enable an initrd / Initial Ram system support in your kernel config ?
 
Old 04-26-2009, 09:34 AM   #10
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Im not sure, my friend did it over ssh.

Is there anyway to tell?
 
Old 04-26-2009, 09:46 AM   #11
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
# grep -i initrd /usr/src/linux/.config
CONFIG_BLK_DEV_INITRD=y
# grep -i dev_ram /usr/src/linux/.config
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_COUNT=16
CONFIG_BLK_DEV_RAM_SIZE=8192
 
Old 04-26-2009, 09:47 AM   #12
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
we may be making progress..

ubuntu / # grep -i initrd /usr/src/linux/.config
# CONFIG_BLK_DEV_INITRD is not set
 
Old 04-26-2009, 09:48 AM   #13
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
also....

ubuntu / # grep -i dev_ram /usr/src/linux/.config
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_COUNT=16
CONFIG_BLK_DEV_RAM_SIZE=16384
 
Old 04-26-2009, 09:58 AM   #14
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
OK. So the kernel is not build with initramfs.
That is fine.

Is EXT3 support built into the kernel or is it modular ?
Code:
grep -i ext3 /usr/src/linux/.config
 
Old 04-26-2009, 10:37 AM   #15
Gentoo-Gav
LQ Newbie
 
Registered: Apr 2009
Location: United Kingdom
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
see below (thanks for sticking with this)

ubuntu grub # grep -i ext3 /usr/src/linux/.config
CONFIG_EXT3_FS=y
CONFIG_EXT3_FS_XATTR=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT3_FS_SECURITY=y
ubuntu grub #
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel not loading - Kernel Panic in Grub - 2.6.23-gentoo-r6 rahulthewall3000 Linux - Kernel 2 02-11-2008 02:33 PM
Receiving Kernel Panic - Gentoo justanothersteve Linux - General 6 07-27-2006 11:23 AM
Gentoo Kernel panic - not syncing... patrickclay Linux - Distributions 2 03-10-2005 01:53 PM
Kernel Panic in Gentoo palmem Linux - General 1 11-06-2004 01:16 PM
Grub w/ Gentoo 2.6.3 - Kernel Panic smehi Linux - Newbie 3 03-21-2004 11:39 PM


All times are GMT -5. The time now is 11:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration