LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-13-2009, 02:53 PM   #46
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40

vibinlakshman,

The easy things to explain first

Code:
1242112631: ::: completed emerge (10 of 83) x11-apps/xmodmap-1.0.3 to /
Your emerge did not complete, you still have another 73 packages to go before you can run
Code:
Xorg -configure
As i92guboj explained, thats because a patch failed. Thats a temporary problem with Gentoo. It may be fixed by now.
Run
Code:
emerge --sync
to get an updated portage tree, Then try
Code:
emerge xorg-x11
again. The packages that are already built will not be rebuilt.

Thats the easy bit.

Your emerge --info shows
Code:
Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-11-generic i686)
This means you have selected the bare default/linux/x86/2008.0 profile. Further, your USE flags have many options missing that will allow a smooth install of a GUI.
You have several choices here. (Gentoo is all about choice) I will describe two. You can update your USE flags with a tool like ufed or profuse, which you can emerge or you can change your profile to
Code:
default/linux/x86/2008.0/desktop
which provides a better set of USE flags for a desktop system.

Whatever you choose, you will need to run
Code:
emerge xorg-x11 -uDNav
after you have changed your USE flags to make them take effect.
Thats --update --deep --newuse --ask --verbose
Only things that need to change will be rebuilt.
If you don't fix your USE now, shortly you will run into errors with one package needing an earlier package to be build with different options.

Everything else looks good.
 
Old 05-13-2009, 09:18 PM   #47
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
Thanks neddyseagoon , i just emerged profuse , seems pretty easy like synaptic manager ..
But how do u change it to desktop environment , i couldnt find anything which help me to edit profile
Or plz guide me how to edit /etc/make.conf to have desktop environment , i forgot where i have done this environment steps , is it in kernel configuration or not ?
Any way i'll be grateful !!!!
 
Old 05-13-2009, 09:24 PM   #48
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Understand this for once: you are never ever going to get a desktop environment until X is installed and running.

As for the profile, use this command to list the available ones:

Code:
eselect profile list
Search the desktop one in the list and and note down the number on the left column. Then do this to select it:

Code:
eselect profile set <number>
 
Old 05-13-2009, 09:25 PM   #49
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,900

Rep: Reputation: 261Reputation: 261Reputation: 261
how to change profile is in chapter 6 of the gentoo handbook How come they don't put eselect profile list and eselect profile set commands in the installion handbook? It's alot easier changing profiles this way then by book.

Last edited by colorpurple21859; 05-13-2009 at 09:35 PM.
 
Old 05-13-2009, 09:35 PM   #50
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
[QUOTE=i92guboj;3539979]Understand this for once: you are never ever going to get a desktop environment until X is installed and running.

As for the profile, use this command to list the available ones:

Code:
eselect profile list
Search the desktop one in the list and and note down the number on the left column. Then do this to select it:

Code:
eselect profile set <number>
[/QUOTE
Thank u i92guboj .. I thought u forgot me .. That was pretty easy to have environment in desktop ..
 
Old 05-14-2009, 11:25 AM   #51
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
Can anyone help me to identify which chipset i'm using , i'll just post the content what i've done , couldnt identify , is this of nvidia or other type
From my point of view i find everything as Intel , but i set VIDEO_CARD="nvidia vesa" , should i change this USE flag to intel? If so , plz provide the correct format of this type


vibin-laptop / # lspci | egrep "AGP|PCI Express|VGA|Display"
pcilib: Cannot open /proc/bus/pci
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)


vibin-laptop / # lspci -vvv | egrep "AGP|PCI Express|VGA|Display"
pcilib: Cannot open /proc/bus/pci
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
BridgeCtl: Parity- SERR- NoISA+ VGA- MAbort- >Reset- FastB2B-
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
BridgeCtl: Parity- SERR- NoISA+ VGA- MAbort- >Reset- FastB2B-
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
BridgeCtl: Parity- SERR- NoISA+ VGA- MAbort- >Reset- FastB2B-
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+ PostWrite+
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-

Last edited by vibinlakshman; 05-14-2009 at 11:29 AM.
 
Old 05-14-2009, 11:31 AM   #52
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Both your graphics chip and the chipset that governs your motherboard are from Intel according to that output.
 
Old 05-14-2009, 01:19 PM   #53
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,900

Rep: Reputation: 261Reputation: 261Reputation: 261
looks like you have an intel i945 graphics card. set your make.conf to VIDEO_CARD="intel" and when you do your /etc/X11/xorg.config in the video card section driver="intel" I have an intel i810 video card and thats what i had to do. you might still have to install your intel drivers. You can look in usr/portage/x11-drivers/to find the actual name of the intel driver and there might be a i945 driver listed also but not sure.

Last edited by colorpurple21859; 05-14-2009 at 05:37 PM.
 
Old 05-14-2009, 09:13 PM   #54
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
Wink

Quote:
Originally Posted by i92guboj View Post
Both your graphics chip and the chipset that governs your motherboard are from Intel according to that output.
i've change my VIDEO_DRIVER accordingly , so what to do next ??

vibin-laptop ~ # cat /var/log/Xorg.0.log |grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Unable to locate/open config file
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load module "glx" (module does not exist, 0)
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "intel" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)

this is what i've done after startx in gentoo terminal
 
Old 05-14-2009, 09:27 PM   #55
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
If you have changed your /etc/make.conf file with the new VIDEO_CARD entry ... you will have to
Code:
# emerge xorg-server -uDNav
# emerge xorg-x11 -uDNav

Last edited by dxqcanada; 05-14-2009 at 09:30 PM.
 
Old 05-14-2009, 10:20 PM   #56
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
Wink

Quote:
Originally Posted by dxqcanada View Post
If you have changed your /etc/make.conf file with the new VIDEO_CARD entry ... you will have to
Code:
# emerge xorg-server -uDNav
# emerge xorg-x11 -uDNav
Before that i've done emerge -uva xf86-video-intel and plz verify the err i got

* Checking for direct rendering capabilities ...
*
* ERROR: x11-drivers/xf86-video-intel-2.6.3-r1 failed.
* Call stack:
* ebuild.sh, line 48: Called src_unpack
* environment, line 3022: Called x-modular_src_unpack
* environment, line 3835: Called x-modular_dri_check
* environment, line 3681: Called die
* The specific snippet of code:
* die "You must build x11-base/xorg-server with USE=-minimal.";
* The die message:
* You must build x11-base/xorg-server with USE=-minimal.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-2.6.3-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-2.6.3-r1/temp/environment'.
*

>>> Failed to emerge x11-drivers/xf86-video-intel-2.6.3-r1, Log file:

>>> '/var/tmp/portage/x11-drivers/xf86-video-intel-2.6.3-r1/temp/build.log'

* Messages for package x11-drivers/xf86-video-intel-2.6.3-r1:

*
* ERROR: x11-drivers/xf86-video-intel-2.6.3-r1 failed.
* Call stack:
* ebuild.sh, line 48: Called src_unpack
* environment, line 3022: Called x-modular_src_unpack
* environment, line 3835: Called x-modular_dri_check
* environment, line 3681: Called die
* The specific snippet of code:
* die "You must build x11-base/xorg-server with USE=-minimal.";
* The die message:
* You must build x11-base/xorg-server with USE=-minimal.
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-2.6.3-r1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-2.6.3-r1/temp/environment'.
*

* GNU info directory index is up-to-date.

I think this intel driver is making the problem!!!!
 
Old 05-14-2009, 10:32 PM   #57
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Try
Code:
# emerge -av xorg-server xf86-video-intel
 
Old 05-14-2009, 10:34 PM   #58
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
... post the output of that.
Then let it run.
 
Old 05-14-2009, 11:06 PM   #59
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
Wink

Quote:
Originally Posted by dxqcanada View Post
... post the output of that.
Then let it run.
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] x11-apps/bdftopcf-1.0.0 USE="-debug" 0 kB
[ebuild N ] media-fonts/font-adobe-75dpi-1.0.0 USE="X nls" 0 kB
[ebuild R ] x11-base/xorg-server-1.5.3-r5 USE="hal ipv6 nptl sdl xorg -3dfx -debug -dmx -kdrive -minimal* -tslib" INPUT_DEVICES="evdev keyboard mouse synaptics -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -tek4957 -tslib -ur98 -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="intel* -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -imstt -mach64 -mga -neomagic (-newport) -nv -nvidia* -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa* -via -virtualbox -vmware -voodoo -xgi" 0 kB
[ebuild N ] x11-drivers/xf86-video-intel-2.6.3-r1 USE="dri -debug" 0 kB

Total: 4 packages (3 new, 1 reinstall), Size of downloads: 0 kB
 
Old 05-14-2009, 11:25 PM   #60
vibinlakshman
Member
 
Registered: Dec 2008
Location: Kerala, India
Distribution: Ubuntu 11.10
Posts: 334

Original Poster
Rep: Reputation: 33
Now Xorg had installed , but how to get it worked !!!

vibin-laptop / # Xorg -configure
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

vibin-laptop / # X -config /root/xorg.conf.new
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Installation Plzzzzzz Help!! kornoholio Linux - Laptop and Netbook 1 12-18-2006 04:10 AM
Help Me!!!!!! plzzzzzz dogslayer Linux - Software 9 03-02-2006 08:04 PM
Help Me!!!!!! plzzzzzz dogslayer Linux - Software 2 02-22-2006 12:34 PM
Need Help Plzzzzzz Jonasl Linux - Software 1 11-06-2003 11:07 AM


All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration