LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-21-2007, 04:53 PM   #1
gruelius
Member
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 30

Rep: Reputation: 15
Gentoo: Emerging and order of install


Hi all

I decided to format and start again with KDE due to some wierd errors i was getting. I setup the system and emerged xorg-x11 and then emerged kde-meta with the flags that they needed. I got a prompt from emerge kde-meta saying "x11-libs/qt-3 use flag opengl needed" or something like that, so i added opengl to make.conf and no matter how hard i try to re emerge xorg-x11 with newuse on or off it wont do it!

Which order should i install things? Drivers then X then KDE? im just trying to get it to work as best as possible!

Julius
 
Old 02-21-2007, 05:03 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
http://www.gentoo.org/doc/en/kde-config.xml would be a good place to start. Read through the docs to see your options.
 
Old 02-21-2007, 05:31 PM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Try the following
Code:
#echo "x11-libs/qt-3 opengl" >> /etc/portage/package.use
After that try emerging KDE.
 
Old 02-21-2007, 05:33 PM   #4
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
Quote:
Originally Posted by gruelius
Hi all
I got a prompt from emerge kde-meta saying "x11-libs/qt-3 use flag opengl needed" or something like that, so i added opengl to make.conf and no matter how hard i try to re emerge xorg-x11 with newuse on or off it wont do it!
QT is not part of Xorg.
 
Old 02-21-2007, 05:54 PM   #5
gruelius
Member
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 30

Original Poster
Rep: Reputation: 15
Hey,
Makes sense with it not being a part of Xorg but kde, would explain my issue as i did not emerge --newuse kde-meta haha.

since ive added opengl to make.conf should i emerge --newuse world or emerge --newuse kde-meta?
 
Old 02-21-2007, 06:03 PM   #6
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
'world' seems to be the right target, other packages are probably affected too. 'emerge -aNDv world'
 
Old 02-21-2007, 06:10 PM   #7
gruelius
Member
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 30

Original Poster
Rep: Reputation: 15
can someone comment on the best order to install packages? Im setting up my mothers computer which is a P3 600mhz so i cant really afford to recompile everything all the time. I was hoping to just type something like: emerge xorg-x11 && emerge xfce(whatever its called) && emerge *whatever else*, and just leave it sitting fora few days. Which flags do i need or should i just look at doc's and gentoo portage info.

From that KDE page you sent me, it didnt list anything about opengl however i guess if i looked at the package tree i would have found something.

Anyways its fun learning :P ill try these commands at home tonight
Julius
 
Old 02-22-2007, 05:20 PM   #8
gruelius
Member
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 30

Original Poster
Rep: Reputation: 15
I think i figured it out.
I must have synced emerge inbetween instilations because the error i got was an incorrect/no version of some kdelib file was installed, so i emerged kde-libs && emerge kde-meta and ran off to work.

Hopefully it will all work out for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error emerging gnome in fresh gentoo install PhantmShado Linux - Software 0 02-24-2006 10:30 PM
Gentoo freezes when emerging Strom_Boli Linux - Newbie 1 10-18-2004 11:52 PM
Emerging ppc kernel in gentoo MACSRULE Linux - Newbie 3 09-12-2004 01:48 AM
gentoo: conflict when emerging kde Moebius Linux - Software 1 06-04-2004 02:47 AM
Gentoo - Emerging Xfree86 arrruken Linux - Software 5 02-29-2004 07:08 AM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration