LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-18-2003, 12:47 AM   #1
Harpune
Member
 
Registered: Sep 2002
Location: Seattle, WA
Distribution: Ubuntu
Posts: 101

Rep: Reputation: 15
Gentoo config issues


Ok, so I am brand new to Gentoo linux, I just switched over from Redhat 8.0. So far I am loving it, but I still have a lot of things that, even after a lot of research, I can't seem to get resolved. I don't know if this is kosher or not, but this email is going to be a conglomoration of about 5 or 6 issues i've been having with this new distro.

1. How do I start certain services, such as telnetd and samba directly from xinetd and is that the ideal way to do it?

I have looked into some configurations for samba, starting from inetd, etc... but I have seen nothing in specific about xinetd with samba. As far as telnet goes when I try to start it from the command line (in.telnetd) I get the error:

in.telnetd: getpeername: socket operation on non-socket

And when I put the following in my /etc/xinetd.d/telnet:

service telnet

{
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
only_from = 0.0.0.0/24
}

all I get when I attempt to connect is:

Trying 127.0.0.1...
Connected to Localhost.
Escape Character is '^]'.
Connection closed by foreign host.

Should I be starting this from Gentoo's init? or is xinetd the best option?

2. How can I configure Gentoo for DHCP without having to type 'dhcpcd eth0' everytime I boot?

I think I may have missed a configuration step at install time and I can't figure out how to fix my error.

3. Blackdown JRE and mozilla aren't playing well with each other. I have a symlink to my java plugin in my mozilla plugins dir, but it isn't showing up or becoming useful in mozilla.

I emerged blackdown after mozilla and it automatically put the symlink in mozilla's plugin directory but I still can't seem to see the plugin under mozilla.

4. I don't konw if anyone else is having this problem, but Linux seems to be locking up on me randomly, and far to often to be acceptable. I have XFree 4.3.0, could that be the cause of this?

If there is anything you can do to help me in one of these ares, I would sure appreciate it.

Thanks
 
Old 04-18-2003, 01:18 AM   #2
mjgeiger
LQ Newbie
 
Registered: Mar 2002
Location: Stoughton, MA
Distribution: Gentoo 1.4rc?, it's all good.....
Posts: 19

Rep: Reputation: 0
Here you go with a little bit of help:

1) !!!-USE SSHD INSTEAD-!!! it is secure, telnet is not. If you have to use telnet, make sure you have emerged netkit-telnetd in net-misc. You can start it in /etc/init.d by issueing the command

/etc/init.d/telnetd start

You can make it start at boot, by issueing the command

rc-update add telnetd default

This will put it in your default runtime.

2) Edit /etc/conf.d/net and in there you will find a line:

#iface_eth0="dhcp"

Just uncomment this, and add eth0 to your boot

rc-update add net.eth0 default

3) Try this on for size, http://forums.gentoo.org/viewtopic.php?t=22759 it is the same idea with Sun.

4) I actually run X-Free 4.2.1 and am happy with it no problems with TNT2 card under Fluxbox. Just make sure your drivers are correct (xf86config and /etc/X11/XF86Config).

later,
matt

p.s. for more Gentoo related questions, try the gentoo forum at http://forums.gentoo.org LQ is great with the general quesitons
 
Old 04-18-2003, 07:07 PM   #3
Harpune
Member
 
Registered: Sep 2002
Location: Seattle, WA
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 15
Thanks for you help, I will remember to check there first next time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail - Config for IP Block's & Config Issues Thom_Redhat Linux - Software 1 04-07-2006 02:29 PM
pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6 ghrellin Linux - Software 2 12-22-2004 07:37 PM
gentoo: about config the Kernel akira117 Linux - Distributions 1 09-09-2004 05:29 AM
gentoo file manager install issues (not Gentoo) windeath Fedora 2 03-01-2004 08:17 PM
Gentoo issues zigmund555 Linux - Distributions 2 02-21-2004 10:05 AM


All times are GMT -5. The time now is 05:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration