LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2010, 03:32 AM   #1
frida kiriakos
LQ Newbie
 
Registered: Apr 2010
Posts: 2

Rep: Reputation: 0
gconf, gnome problem


Hello everyone,

i am having these problems for almost 3 days, i am trying to add a keyboard layout using gconftool-2, when i execute the commands i dont have any problem, the commands are:
#gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s /desktop/gnome/peripherals/keyboard/kbd/layouts -t list --list-type string '[us,ara]'

#gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s /desktop/gnome/peripherals/keyboard/kbd/options -t list --list-type string '[altwin altwin:super_win,grp_led grp_led:scroll,grp grp:alt_shift_toggle,terminate terminate:ctrl_alt_bksp]'

but the layout its not working, when i want to change between layouts.
if i try to run:

#gconftool-2 --get /desktop/gnome/peripherals/keyboard/kbd/layouts

i get this error message: Failed to get value for `/desktop/gnome/peripherals/keyboard/kbd/layouts': Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

i tried many things and looked over the internet i didnt find any answers

if i run "gnome-terminal" command i get these error messages: ** (gnome-terminal:3095): WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

Failed to get the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Falling back to non-factory mode.
Failed to summon the GConf demon; exiting. Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

could use help
Thanks
 
Old 04-01-2010, 07:38 PM   #2
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
I've never tried 'gconftool2' command line editing... have you tried to diagnose this in the graphical editor 'gconf-editor'? It's cheating I know but still... :P
 
Old 04-02-2010, 01:30 PM   #3
frida kiriakos
LQ Newbie
 
Registered: Apr 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Tuttle View Post
I've never tried 'gconftool2' command line editing... have you tried to diagnose this in the graphical editor 'gconf-editor'? It's cheating I know but still... :P

well i did try to use it but i get the same errors:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Last edited by frida kiriakos; 04-02-2010 at 01:31 PM.
 
Old 04-03-2010, 09:26 PM   #4
Tuttle
Senior Member
 
Registered: Jul 2003
Location: Wellington, NZ
Distribution: mainly slackware
Posts: 1,289

Rep: Reputation: 52
Have you tried emptying out your /tmp?
Sometimes there is stale stuff there...
I always mount my /tmp directory as a 'tmpfs' with this entry in my /etc/fstab:
Code:
tmpfs            /tmp             tmpfs       defaults         0   0
That way is is wiped on every reboot, plus all temporary files get held in RAM or swap space!

PS. you can also move your ~/.gconf directory to see if there are errors there somewhere, it'll be regenerated on next login... or simply make a test user for troubleshooting

Last edited by Tuttle; 04-03-2010 at 09:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Arch, Gnome, GDM and GConf TheStarLion Arch 4 03-13-2010 01:10 PM
gconf, orbit, gnome tramni1980 Slackware 3 10-13-2006 10:19 AM
Compiling gnome myself, got a problem with gconf! Linux.tar.gz Slackware 10 02-03-2006 10:13 PM
gconf is just for gnome?? marlor Slackware 1 08-01-2004 11:26 PM
Gnome - Gconf problems rebdi Linux - Software 3 12-18-2003 06:59 PM


All times are GMT -5. The time now is 04:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration