LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2006, 11:41 PM   #1
jared78
Member
 
Registered: Mar 2005
Distribution: Red Hat 9.0
Posts: 94

Rep: Reputation: 15
Thumbs up gcc upgraded but not showing


I use RH9.0 and have upgraded my gcc from the given gcc along with it more than an year back.
I am trying to install an rpm,and it gave a "Failed Dependencies because of gcc.

[root@localhost root]# rpm -ivh gnofract4d-python22-3.0-1.i386.rpm
error: Failed dependencies:
gcc >= 2.95 is needed by gnofract4d-3.0-1

Let me know what I can do to help this rpm recognise my latest gcc

thanks in advance,
Jared
 
Old 07-04-2006, 11:47 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
RH9 shipped with gcc 3.2 so the version of gcc shouldn't be a problem. What does rpm -q gcc show?

If you compiled a new gcc (or anything) from source or installed it via any means other than RPM, then the RPM database won't know about it.
 
Old 07-05-2006, 02:19 AM   #3
jared78
Member
 
Registered: Mar 2005
Distribution: Red Hat 9.0
Posts: 94

Original Poster
Rep: Reputation: 15
Thanks btmiller.

Here is the query.

[root@localhost root]# rpm -q gcc
package gcc is not installed

I am baffled.Does this mean I dont have gcc at all?

thanks,
Jared
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Tools: GCC 3.4.6, Final GCC 3 Release LXer Syndicated Linux News 0 05-30-2006 03:21 AM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare SUSE / openSUSE 3 11-29-2004 03:13 PM
Kernel compiling: gcc-3.3 is 586, should be gcc-3.3 386 Erik Plaggenmar Linux - Software 0 10-01-2004 12:38 PM
Upgraded GCC; now many programs don't work Zoombie Linux - Software 13 02-24-2004 07:08 AM
export CC=/usr/bin/gcc-3.2 - switch gcc version? ferreter Linux - Software 1 08-20-2003 01:07 AM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration