LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2009, 07:31 AM   #16
johnsfine
LQ Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,286

Rep: Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181

Hopefully, knudfl will notice your post and reply soon or someone else knows how to correct yum in an unregistered install of Red Hat so it will use Centos repositories (and can guess what you did wrong in following instructions from post 2 of that other thread).

I don't know how to switch Red Hat to use Centos repositories.

When the support expired on a Red Hat system where I work, the person managing that system thought the only way to be able to install packages from Centos was to overwrite the whole install of Red Hat with a newer version of Centos, and that is what we did. If I were in your position now, that is the only way I would know for solving the problem. But knudfl seems to know a less drastic solution.
 
Old 07-27-2009, 05:20 AM   #17
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
Thanks for the idea. I will try that only way left for me..........

after some more searches on the net.

Regards Redhat5
 
Old 07-27-2009, 08:41 AM   #18
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Well, I haven't tried the CentOS repo's on RH yet.
I may do that in a couple of days.

On the other hand, there hasn't been any complaints
so far, the referred post has been readable for four
months :
http://www.linuxquestions.org/questi...ghlight=centos
# 2 + # 3.
.....
 
Old 07-27-2009, 06:22 PM   #19
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
ok, thanks !

I will reply as soon as i do that. may be within few minutes.

Before this post, i have tried it once, but it did not work. I will try once again.
 
Old 07-27-2009, 06:34 PM   #20
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
I did the same as directed by you in the Reffered post.

First, i copied the files from the post after proper editing to the folder
/etc/yum.repos.d

Second i visited the website for rpm fusion configration files to be installed.

When i installed them after download i.e SOFTWARE INSTALLER installed them, it gave the following error

Unable to start to due to a configuration error

File contains no section headers.
file: file://///etc/yum.repos.d/CentOS-Media.repo, line: 1
'/root/Desktop/CentOS-Media.repo'

What to do now?
 
Old 07-28-2009, 03:07 PM   #21
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
I installed Redhat EL 5.3 today and found,
that the 'CentOS-Base.repo' must be edited.
Ref. post # 4 here
http://www.linuxquestions.org/questi...r-rhel-644632/
> > mirror.centos.org/centos/5.3/os/i386

And please delete the 'CentOS-Media.repo'.
The 'epel.repo' seems OK.

The edited 'CentOS-Base.repo' is attached.
.....
Good luck !
.....
P.S. : The even newer CentOS-Base.repo , attachment, please look here
http://www.linuxquestions.org/questi...9/#post3751993
= version 5.4
.....

Last edited by knudfl; 11-12-2009 at 04:18 PM.
 
Old 07-29-2009, 06:17 AM   #22
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
what i didi today is enable the epel in rhel5 and then

enable the rpm fusion free and non free

and then

yum update yum

it returned

[root@localhost ~]# yum update yum
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Update Process
Setting up repositories
rpmfusion-nonfree-updates 100% |=========================| 2.8 kB 00:00
rpmfusion-free-updates-te 100% |=========================| 2.8 kB 00:00
rpmfusion-nonfree-updates 100% |=========================| 2.8 kB 00:00
rpmfusion-free-updates 100% |=========================| 2.8 kB 00:00
Reading repository metadata in from local files
68149941f0aeedb3db75a8c22 100% |=========================| 5.9 kB 00:00
################################################## 20/20
cee878845a4b4bc0267fd58c0 100% |=========================| 26 kB 00:01
################################################## 85/85
417974a221689cab0d0d15f18 100% |=========================| 198 B 00:00
86a348b6c38d1134adff8462c 100% |=========================| 1.2 kB 00:00
################################################## 1/1
primary.xml.gz 100% |=========================| 250 kB 00:11
################################################## 369/369
primary.xml.gz 100% |=========================| 878 kB 00:33
################################################## 2508/2508
primary.xml.gz 100% |=========================| 100 kB 00:03
################################################## 312/312
primary.xml.gz 100% |=========================| 157 B 00:00
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yum to pack into transaction set.
yum-3.2.19-18.el5.centos. 100% |=========================| 38 kB 00:03
---> Package yum.noarch 0:3.2.19-18.el5.centos set to be updated
--> Running transaction check
--> Processing Dependency: yum-fastestmirror for package: yum
--> Processing Dependency: yum = 3.0.1-5.el5 for package: yum-updatesd
--> Processing Conflict: yum conflicts yum-rhn-plugin < 0.5.2-1.el5
--> Processing Dependency: yum-metadata-parser >= 1.1.0 for package: yum
--> Processing Dependency: python-iniparse for package: yum
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yum-metadata-parser to pack into transaction set.
yum-metadata-parser-1.1.2 100% |=========================| 4.5 kB 00:00
---> Package yum-metadata-parser.i386 0:1.1.2-2.el5 set to be updated
---> Downloading header for yum-updatesd to pack into transaction set.
yum-updatesd-0.9-2.el5.no 100% |=========================| 4.5 kB 00:00
---> Package yum-updatesd.noarch 1:0.9-2.el5 set to be updated
---> Downloading header for yum-fastestmirror to pack into transaction set.
yum-fastestmirror-1.1.16- 100% |=========================| 9.1 kB 00:01
---> Package yum-fastestmirror.noarch 0:1.1.16-13.el5.centos set to be updated
---> Downloading header for python-iniparse to pack into transaction set.
python-iniparse-0.2.3-4.e 100% |=========================| 5.4 kB 00:00
---> Package python-iniparse.noarch 0:0.2.3-4.el5 set to be updated
--> Running transaction check
--> Processing Conflict: yum conflicts yum-rhn-plugin < 0.5.2-1.el5
--> Processing Dependency: gamin-python for package: yum-updatesd
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gamin-python to pack into transaction set.
gamin-python-0.1.7-8.el5. 100% |=========================| 14 kB 00:01
---> Package gamin-python.i386 0:0.1.7-8.el5 set to be updated
--> Running transaction check
--> Processing Conflict: yum conflicts yum-rhn-plugin < 0.5.2-1.el5
--> Finished Dependency Resolution
Error: yum conflicts with yum-rhn-plugin < 0.5.2-1.el5


What does this mean?


Am i ready with the coentos repos?


Also,

Can you please tell me, what status of yum does this convey?


[root@localhost ~]# yum install firefox
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for firefox to pack into transaction set.
firefox-3.0.12-1.el5.cent 100% |=========================| 74 kB 00:05
---> Package firefox.i386 0:3.0.12-1.el5.centos set to be updated
--> Running transaction check
--> Processing Dependency: xulrunner >= 1.9.0.12-1 for package: firefox
--> Processing Dependency: libxul.so for package: firefox
--> Processing Dependency: libxpcom.so for package: yelp
--> Processing Dependency: gecko-libs = 1.8.0.9 for package: yelp
--> Processing Dependency: libxpcom_core.so for package: yelp
--> Processing Dependency: libxpcom.so for package: firefox
--> Processing Dependency: libgtkembedmoz.so for package: yelp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for yelp to pack into transaction set.
yelp-2.16.0-22.el5.i386.r 100% |=========================| 29 kB 00:01
---> Package yelp.i386 0:2.16.0-22.el5 set to be updated
---> Downloading header for xulrunner to pack into transaction set.
http://mirror.centos.org/centos/5.3/....el5.i386.rpm: [Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Trying other mirror.
Error: failure: RPMS/xulrunner-1.9.0.12-1.el5.i386.rpm from updates: [Errno 256] No more mirrors to try.

Last edited by redhat5; 07-29-2009 at 06:29 AM.
 
Old 07-29-2009, 09:26 AM   #23
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
The "xulrunner-1.9.0.12-1.el5.i386.rpm link "
works fine now
http://mirror.centos.org/centos/5.3/...1.el5.i386.rpm
" Temporary failure .... " your error line says.

About your original question ( gcc ) :
Why not install it from the install DVD
( cd set > > disc 2 ) ? ?

And why have all these troubles. It would be
much easier just to install CentOS 5.3, which
is the recommended solution.

I just got the Redhat 5.3 on a 14 days trial .....
(( and did not activate the install number ))
.... only for the experiment. And have no problems
with a conflict concerning the installed
yum-rhn-plugin ( 0.5.3.30.el5 ).
.....
# yum install firefox
I got 'xulrunner-devel-1.9.0.12-1.el5' ,
xulrunner-1.9.0.12-1.el5, firefox-3.0.12-1.el5 .
.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding commands to the &PATH???? JibberingJ Slackware 4 04-14-2009 08:39 PM
Many commands don't work; PATH issue? BostonMark Linux - General 3 08-15-2007 11:34 AM
Set the path for shell commands??? acidblue Fedora 2 12-24-2005 12:23 AM
Executing commands without using the full path.. LinuxBAH *BSD 2 12-02-2003 08:16 PM
Need help with path commands rdaves@earthlink.net Linux - General 7 06-27-2001 06:21 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration