LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2005, 08:30 AM   #1
JimboJet
LQ Newbie
 
Registered: May 2005
Distribution: Mandrake 10.1
Posts: 2

Rep: Reputation: 0
gcc 3.4.1 vs glib 1.2.10


I'm trying to get GTK+1.2.10 installed under Mandrake 10.1. I'm having some fun trying to get glib 1.2.10 up and running first (I think it's a pre-requisite for gtk+). I've got gcc 3.4.1 as the compiler, and I'm getting a number of errors (see below), that according to a quick bit of googling, appear to be caused by the later version of gcc.

Being a complete n00b, how would I get an earlier version of gcc, and how do I get glib to be compiled by it? There's talk of patches as well for gcc 3.4.x, but that just confuses me. Any ideas?

So much to learn, so much time.
TIA

---
Glib error message, in part:
gstrfuncs.c: In function `g_printf_string_upper_bound':
gstrfuncs.c:870: error: syntax error before string constant
gstrfuncs.c:1037: error: syntax error before string constant
gstrfuncs.c:1080: error: syntax error before string constant
gstrfuncs.c:1111: error: syntax error before string constant
 
Old 05-25-2005, 12:20 PM   #2
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 30
Patching isnt that difficult, in your case there's an example online at the LFS website that fixes this very problem.

See here http://www.linuxfromscratch.org/blfs...eral/glib.html

HTH

Mad.
 
Old 05-25-2005, 07:12 PM   #3
JimboJet
LQ Newbie
 
Registered: May 2005
Distribution: Mandrake 10.1
Posts: 2

Original Poster
Rep: Reputation: 0
Thumbs up

Many thanks. Got there in the end...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM


All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration