LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-23-2004, 09:58 PM   #16
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30

OK Ben here is the break down...

In wondows the conventional naming for hard disk is (as you know):
C: (firs disk, first partiotion)
D: (would be next partition , or disk depending in your setup)

In Linux they are called different:

hda (First HD)
hda1 (first HD, first partiotion)
hda2 (first HD, second partition)

hdb (second HD)
hdb1 (second HD, first partition)

now... lets say you have windows in you 1st_disk-1st_partition (hda1), it can be found in the device '/dev/hda1'

you need to mount such partition. here I am as a noob as you are, I can not help with the whole commands you need.

RedHat should have installed support for FAT32 and NTFS more likely. So try finding help about: "How to mount NTFS in linux?"

Search help typing 'man mount' and 'info mount'. Or perhaps some guru arround the forums can give us a short answer.
 
Old 04-24-2004, 03:10 PM   #17
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Original Poster
Rep: Reputation: 30
Quho(SP?)... the command to mount the "C" drive is: mount /dev/hda2 where hda2 is the drive you want to mount.

Ok, besides that, there's been some progress. I unmounted the "C" drive that I mounted logged on as root, so then I logged back in as superman, and I mounted it there. and bingo. The mounted "C" drive appears on my desktop.

So that's good. now I have my "C" drive there. But everythings not fine. I cannot access the contents in "C" because I "don't have the right permission". So I go back to root to try to give myself the permissions for the 100th time, and it gives the error: "Cannot change the permissions because its a read only drive".

Now why does "C" drive being read only have to do with me changing the permissions of it? And how do I get beyond this error message?
 
Old 04-25-2004, 03:34 AM   #18
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
How to change the permision .. I dont know yet
But here is the way i made it work for me (since you got me in this path :P )

I modified the file /etc/fstab as follows:
______
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb5 none swap sw 0 0
/dev/hdb1 / ext3 defaults,errors=remount-ro 0
1

# Here is my 'C:\' and my 'G:\' (my first HD has two partitions.

/dev/hda1 /winc vfat users,noauto
/dev/hda5 /wing vfat users,noauto
__________

I manually made the mount points (they are just a folder where they get mounted)
I used 'mkdir /winc' as root
the users option allowes any user to mount and umount the filesystems
now notice the noauto part is very important. If you dont, the disk is
automaticaly mounted by root at boot time. THIS is why you won't be able to access
to them after you log as a regular user, because they are been used by someone else (root)

Luck,

[edit]

My HD uses vfat (FAT36) be sure you set the right filesystem for your disks (NTFS I think you are using)

Find more with: ~$ man fstab

Last edited by Qucho; 04-25-2004 at 03:38 AM.
 
Old 04-25-2004, 03:11 PM   #19
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Original Poster
Rep: Reputation: 30
ok, I did what Qucho suggested, and now my /etc/fstab looks like this (for my ntfs partition:

Code:
/dev/hda2 /winc ntfs users,noauto 1 0
now when I log on as superman, I cannot access /winc becuase of permissions, but I can access /c. The only hook is that nothing shows up in the folder...Its all a blank screen. I know the last time I toyed around with the 1 and 0 things changed a bit, but i don't know what they mean. Is there something I have to change with that, or is there anything I can do now?
 
Old 04-25-2004, 05:15 PM   #20
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
In my machine I dont have the '0 1' you have at the end of the line, I dont know what they are for nither.

After adding that in ftab all I did was reboot. Then I loggoed as regular user and type;

~$ mount /winc

then i can access to all my files in my windows partition.

- - - - - -IF you mount it as root you wont be able to access to it.- - - - -
 
Old 04-25-2004, 05:33 PM   #21
darin3200
LQ Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
Quote:
Originally posted by ben_build#2.1.0
ok, I did what Qucho suggested, and now my /etc/fstab looks like this (for my ntfs partition:

Code:
/dev/hda2 /winc ntfs users,noauto 1 0
now when I log on as superman, I cannot access /winc becuase of permissions, but I can access /c. The only hook is that nothing shows up in the folder...Its all a blank screen. I know the last time I toyed around with the 1 and 0 things changed a bit, but i don't know what they mean. Is there something I have to change with that, or is there anything I can do now?
Try changing your /etc/fstab to just 0 0 on the end. And from what I've always seen it is user, not users, for the /etc/fstab options. For more info on your /etc/fstab check out the wiki entry

The reason you don't see anything in /c is because there is nothing there, you have mounted /dev/hda2 on /winc, that's were you want to look. Also, if you created the file /winc as root you can mount the drive but not view it. Try the command
Code:
chmod 777 /winc
as root from your / directory.

Last edited by darin3200; 04-25-2004 at 05:35 PM.
 
Old 04-26-2004, 12:35 PM   #22
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Original Poster
Rep: Reputation: 30
ok, I have questions about the chmod command.

I read this answers article

http://www.linuxquestions.org/questi...ticle&artid=20

and this is what I get out of it:

if I type in the command:

<code>
chmod 5 /c
</code

then that will give me read/execute permissions on everybody.

now can I execute programs from C or would it be better to do

<code>
chmod 4 /c
</code>

which will give everyone read only permissions to /C.

which one will be better?
 
Old 04-26-2004, 01:59 PM   #23
Muzzy
Member
 
Registered: Mar 2004
Location: Denmark
Distribution: Gentoo, Slackware
Posts: 333

Rep: Reputation: 30
Change your fstab entry to:

/dev/hda2 /winc ntfs users,noauto,umask=022 1 0

This should fix the permissions problems.

Regards,
Mark.
 
Old 04-26-2004, 02:01 PM   #24
Muzzy
Member
 
Registered: Mar 2004
Location: Denmark
Distribution: Gentoo, Slackware
Posts: 333

Rep: Reputation: 30
Actually, skip the 'noauto' as well then it's even simpler, you don't even need to mount it.
 
Old 04-26-2004, 02:48 PM   #25
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Original Poster
Rep: Reputation: 30
ok muzzy, I'll try that before I mess with CHMOD.
 
Old 04-26-2004, 04:48 PM   #26
darin3200
LQ Guru
 
Registered: Dec 2002
Distribution: Gentoo!
Posts: 1,153

Rep: Reputation: 45
Quote:
Originally posted by ben_build#2.1.0
ok, I have questions about the chmod command.

I read this answers article

http://www.linuxquestions.org/questi...ticle&artid=20

and this is what I get out of it:

if I type in the command:

<code>
chmod 5 /c
</code

then that will give me read/execute permissions on everybody.

now can I execute programs from C or would it be better to do

<code>
chmod 4 /c
</code>

which will give everyone read only permissions to /C.

which one will be better?

Chmod 755 filename will give root read/write/execute permission and everyone else read/execute. That's probably what you want.
 
Old 04-26-2004, 05:31 PM   #27
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Original Poster
Rep: Reputation: 30
gerp. I wish we could delete our own posts...ignore this post



Last edited by ben_build#2.1.0; 04-26-2004 at 05:34 PM.
 
Old 05-03-2004, 06:24 PM   #28
ben_build#2.1.0
Member
 
Registered: Apr 2004
Distribution: Fedora Core 3
Posts: 240

Original Poster
Rep: Reputation: 30
heh. check out the success stories subforum.

I solved the problem ....... darn typos.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
file permissions OK, but command permissions? stabu Linux - General 2 10-05-2005 12:00 PM
permission ... permissions .... permissions alaios Linux - General 1 05-31-2005 04:16 AM
Permissions jymmi Linux - Newbie 3 04-14-2005 11:43 PM
Permissions help reddog64 Linux - Newbie 1 04-22-2004 05:23 PM
getting a directory's permissions and creating a new one with the same permissions newbie1000101 Programming 1 04-10-2004 12:52 PM


All times are GMT -5. The time now is 06:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration