LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-09-2009, 11:59 AM   #1
edortizq
LQ Newbie
 
Registered: Jan 2009
Posts: 7

Rep: Reputation: 0
FVWM can't terminate in SLES 10


I've installed SLES 10 SP2, everything was doing right until I clicked an Xterm icon then the graphics interface was changed to to FVWM and I CAN'T TERMINATE IT! I don't know how!. I can go back to the text interface selecting the exit option from the window manager menu, but when I restart the PC the FVWM is working again.
I WANT TO RESTORE THE SLES 10 DEFAULT GRAPHICS INTERFACE, PLEASE HELP!!!!

I am new with Linux, but i am trying to learn, so what is going on?
 
Old 01-09-2009, 01:47 PM   #2
edortizq
LQ Newbie
 
Registered: Jan 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Unhappy

Please experts your help!!!! anybody????
 
Old 01-09-2009, 03:07 PM   #3
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
How do you login? Text and do startx or graphical login.
Which desktop is your default? kde?
Look in ~/.dmrc and change it to whatever you like.
If you use kdm you can also just select it in the login window under "Session". Same thing for gdm.

Don't shout.
 
Old 01-09-2009, 04:17 PM   #4
edortizq
LQ Newbie
 
Registered: Jan 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for your answer. The login is graphical, but is not the original which comes with SLES; this graphical interface is very poor, like DOS graphs.
I'm very newbie with Linux but my desktop is default wich comes with SLES, I don't what dmrc is and suppose that I don't have kdm or gdm because there are not any "session" button.


Quote:
Originally Posted by makuyl View Post
How do you login? Text and do startx or graphical login.
Which desktop is your default? kde?
Look in ~/.dmrc and change it to whatever you like.
If you use kdm you can also just select it in the login window under "Session". Same thing for gdm.

Don't shout.
 
Old 01-09-2009, 06:00 PM   #5
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
In your home directory type "cat .dmrc" and see what it defaults to. For me it's:
Code:
cat .dmrc
[Desktop]
Session=kde
If yours is different, edit it to either kde or gnome depending on what you used to use.

Edit: Come to think of it, do you have some sort of autologin? I ask while you should see the kdm login screen no matter which desktop you use.
System -> etc/sysconfig Editor -> Desktop -> Display manager -> Erase your name from the autologin window.
Do a ctrl-alt-backspace to restart X, and see if you got kdm back. If yes, you can select kde from the session menu.

You could also try to set DISPLAYMANAGER="kdm" in /etc/sysconfig/displaymanager and DEFAULT_WM="kde" in /etc/sysconfig/windowmanager. Setting the displaymanager should be enough though to be able to select the session.

Last edited by makuyl; 01-10-2009 at 03:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to load sles in redhat platform using sles image created in nfs server AshishNsearch Red Hat 0 03-28-2008 01:12 AM
fvwm & fvwm-crystal? festhead Linux - Desktop 1 09-23-2007 10:49 AM
transparency not correct with fvwm + fvwm-crystal + radeon hedpe Linux - Desktop 0 01-30-2007 08:59 PM
clock not working in fvwm with fvwm-crystal hedpe Linux - Software 0 09-13-2005 09:04 PM
2 fvwm processes with 2 displays, only want one fvwm enzo250gto Linux - Software 0 01-27-2005 05:50 PM


All times are GMT -5. The time now is 02:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration