LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2009, 09:36 AM   #1
umeshsharma
LQ Newbie
 
Registered: Jun 2009
Posts: 6

Rep: Reputation: 0
full RAM is not shown by Dell™ PowerEdge™ 2650 redhat 4 linux system


I have Dell™ PowerEdge™ 2650 server having 4 GB ram and i install Redhat 4 linux on it. But in the bios it shows 4 GB ram which i checked physically but in my OS it shows like.


[root@htss06 ~]# free -m
total used free shared buffers cached
Mem: 248 247 1 0 4 59
-/+ buffers/cache: 182 65
Swap: 511 10 501




It's very strange i am not very good about servers. after googled i found
re-map the missing
ram from where your bios hole is located

but don't know how.

[root@htss06 ~]# getconf LONG_BIT
32
[root@htss06 ~]# uname -a
Linux htss06.htss.com 2.6.9-5.ELsmp #1 SMP Wed Jan 5 19:30:39 EST 2005 i686 i686 i386 GNU/Linux
[root@htss06 ~]#

[root@htss06 ~]# cat /proc/meminfo
MemTotal: 254792 kB
MemFree: 4848 kB
Buffers: 15396 kB
Cached: 131764 kB
SwapCached: 0 kB
Active: 120108 kB
Inactive: 103160 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 254792 kB
LowFree: 4848 kB
SwapTotal: 524280 kB
SwapFree: 524280 kB
Dirty: 192 kB
Writeback: 0 kB
Mapped: 111408 kB
Slab: 19348 kB
Committed_AS: 277988 kB
PageTables: 2568 kB
VmallocTotal: 761848 kB
VmallocUsed: 2184 kB
VmallocChunk: 759512 kB
HugePages_Total: 0
HugePages_Free: 0
Hugepagesize: 2048 kB

Thanks
umesh
 
Old 06-17-2009, 12:27 PM   #2
rayfordj
Member
 
Registered: Feb 2008
Location: Texas
Distribution: Fedora, RHEL, CentOS
Posts: 488

Rep: Reputation: 78
Turn off OS Install Mode in the BIOS. This option limits the amount of physical RAM presented to the OS. IIRC, it was really only ever useful for installing Windows NT so you could apply SP and then access more RAM.

 
Old 06-17-2009, 01:42 PM   #3
johnsfine
LQ Guru
 
Registered: Dec 2007
Distribution: Centos
Posts: 5,286

Rep: Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181Reputation: 1181
Quote:
Originally Posted by umeshsharma View Post
after googled i found
re-map the missing
ram from where your bios hole is located
Having 1/4GB visible of 4GB total is not one of the usual symptoms, so when google or other search finds similar problems (full ram not shown) they aren't actually similar.

Your problem is something else.

Quote:
Originally Posted by rayfordj View Post
Turn off OS Install Mode in the BIOS. This option limits the amount of physical RAM presented to the OS. IIRC, it was really only ever useful for installing Windows NT so you could apply SP and then access more RAM.
Very impressive (assuming it is the right answer).

I know a lot of causes and corrections for missing memory. I hadn't heard of that one before.

After you've fixed whatever problem limits you to 0.25GB, you'll probably be up to about 3.25GB. Then you might want to diagnose and fix one of the more common problems in order to get up to around 3.99GB

BTW, the "GB" I'm using above is what is commonly used for ram, 1024 times 1048576 bytes. Not what is commonly used for disk, 1000 times 1000000 bytes. Some people call the larger one GiB, but that isn't common enough to be less confusing.

Last edited by johnsfine; 06-17-2009 at 01:51 PM.
 
Old 06-18-2009, 01:12 AM   #4
umeshsharma
LQ Newbie
 
Registered: Jun 2009
Posts: 6

Original Poster
Rep: Reputation: 0
No actually have 4.25GB RAM in which it is showing only 256 MB.

Thanks
umesh
 
Old 06-18-2009, 07:56 AM   #5
rayfordj
Member
 
Registered: Feb 2008
Location: Texas
Distribution: Fedora, RHEL, CentOS
Posts: 488

Rep: Reputation: 78
Quote:
Originally Posted by umeshsharma View Post
No actually have 4.25GB RAM in which it is showing only 256 MB.

Thanks
umesh
That is because OS Install Mode is enabled in the system BIOS. Disable OS Install Mode in the PE2650's BIOS to remove the 256MB RAM limit.

System Setup Options
OS Install Mode — Determines the maximum amount of memory available to the operating system. On sets the maximum memory available to the operating system to 256 MB. Off (default) makes all of the system memory available to the operating system. Some operating systems will not install with more than 2 GB of system memory. Turn this option On during operating system installation and Off after installation.

 
Old 06-19-2009, 01:50 AM   #6
umeshsharma
LQ Newbie
 
Registered: Jun 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you very much rayfordj

You r great.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Redhat 9 on Dell poweredge 2650 rack server jmzcons Linux - Newbie 1 05-12-2009 09:37 AM
Dell server PowerEdge 860 - Linux Redhat 9.0 - Shutdown problem areymer Linux - General 1 10-07-2008 03:19 PM
Suse 10.1 - doesn't recognize all RAM on Dell PowerEdge 1300 Sister_Clamp SUSE / openSUSE 2 09-10-2006 06:41 PM
PowerEdge 2650 RedHat ES 2.6.9-5 bleunuit Red Hat 0 06-10-2005 11:02 AM
Dell PowerEdge 2650 k2pattu Linux - Hardware 2 11-21-2003 04:31 AM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration