LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-04-2003, 09:19 AM   #1
robmcw
LQ Newbie
 
Registered: Mar 2003
Location: aberdeen
Distribution: n/a
Posts: 18

Rep: Reputation: 0
ftp problem


I have a pc running linux 2.4.18-14 (I think) it works fine, but
I am having trouble both ftping and attempting to connect
it as a veritas netbackup client. I can telnet no problem
telnet to it. I have checked etc/services and hosts.allow
and ftp is enabled on port 21. I do not know what means
the backup software is using to connect to the machine with
but it also comes back with a "connection refused" message.
any help would be most well received....

Rob.
 
Old 03-04-2003, 10:33 AM   #2
mychl
Member
 
Registered: Jul 2001
Location: Earth
Posts: 164

Rep: Reputation: 30
First, you need to specify what distribution of linux you are using... RedHat, SuSE, Mandrake, etc.....

I think you have RedHat based on your kernel naming convention, so I'll assume that's right.

RedHat installs a firewall by default. To disable the firewall temporatily, type /etc/init.d/iptables stop

Then try to connect to whatever you are trying to connect. I'm thinking it will work.

Once you have shown that iptables is infact what is preventing your connections, you need to find out exactly what ports you want to be open, then look into setting up the iptables rules for what you want.

To start your firewall back up, simply type /etc/init.d/iptables start

HTH
 
Old 03-04-2003, 10:47 AM   #3
robmcw
LQ Newbie
 
Registered: Mar 2003
Location: aberdeen
Distribution: n/a
Posts: 18

Original Poster
Rep: Reputation: 0
Wink ftp access problems

mychl, thanks for your reply, but I had already tried that
stop/starting the firewall option and yes I do have redhat linux.
I think the problems lies with some file like the /etc/hosts.allow
or deny, but they both look fine. I looked at messages and
syslog to see if there was any additional information from them, but alas nothing...

Rob.
 
Old 03-04-2003, 11:13 AM   #4
mychl
Member
 
Registered: Jul 2001
Location: Earth
Posts: 164

Rep: Reputation: 30
No problem.... make sure your services are running correctly...

From your linux machine, try an nmap on 127.0.0.1 to check out what ports have services running..... just to make sure.....
 
Old 03-10-2003, 03:08 AM   #5
robmcw
LQ Newbie
 
Registered: Mar 2003
Location: aberdeen
Distribution: n/a
Posts: 18

Original Poster
Rep: Reputation: 0
Mychl, this is the reply I get when I run the nmap command as
you suggested, I cannot see port 21 being enabled as I thought
this was the port the ftp used....... I take it that the term "interesting" refers to the fact that these services are ones
that are possible ones that hackers would use to access servers ??

Rob.

p.s I can ftp from my linux box, but not to it.


[protek@broth protek]$ nmap 127.0.0.1

Starting nmap V. 3.00 ( www.insecure.org/nmap/ )
Interesting ports on localhost.localdomain (127.0.0.1):
(The 1594 ports scanned but not shown below are in state: closed)
Port State Service
22/tcp open ssh
23/tcp open telnet
25/tcp open smtp
53/tcp open domain
111/tcp open sunrpc
953/tcp open rndc
6000/tcp open X11

Nmap run completed -- 1 IP address (1 host up) scanned in 1 second
[protek@broth protek]$
 
Old 03-10-2003, 09:04 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
The reason you can't ftp to your linux box is you don't have an ftp daemon running. There's nothing to answer requests from FTP clients, so you're getting the "connection refused" message.

I think RH comes with wu-ftpd and I've had good luck using proftpd (some people think it is more secure than wu-ftpd).

BTW, you might want to shut down telnet and just use ssh as it is MUCH more secure.
 
Old 03-11-2003, 04:33 AM   #7
robmcw
LQ Newbie
 
Registered: Mar 2003
Location: aberdeen
Distribution: n/a
Posts: 18

Original Poster
Rep: Reputation: 0
Many Thanks, I thank you for your wise words, could you
enlighten me as to how to stop start these processes ?
I see that there are no # before them in my /etc/services
file so why did they not all start ? can I start/stop them on
the fly (i.e without the need for reboot).
No rush for answers, just when you get a moment.
Thanks.
 
Old 03-11-2003, 09:05 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Since I just nuked my RH install for Slackware, I'm working from memory and that is ALWAYS a bad idea .......

If you are running Gnome, RH has a graphical service tool (under the System menu, I think) that allows you to easily start and stop services and select the ones that load on boot. From the command line you ought to be able to start or stop a service by #> service servicename start (or stop). You really shouldn't have to re-boot the system just to start or stop a service.

The other thing that occurred to me is that RH runs xinetd by default. xinetd is a super-daemon that turns other services on or off as needed. The basic idea is that xinetd listens for calls to services it knows about then starts the service. When the service is no longer needed, xinetd shuts it down. So if wu-ftpd was installed, but running under xinetd, it might not show up via nmap. There should be a directory on your system (/etc/xinetd.d?) that lists all the services xinetd knows about.

The upshot is that you probably need to do a little searching around here on xinetd and setting up an ftp server. I know that since switching to Slack, the search button here has become my best friend.
 
Old 03-11-2003, 08:16 PM   #9
bige
Member
 
Registered: Mar 2003
Location: Kansas
Distribution: debian
Posts: 44

Rep: Reputation: 15
similar problem

Would you guys happen to know why my libranet 2.0 box won't connect to ftp(anonymous and personal) servers, but can serve ftp, and another windows box on the network CAN connect to ftp, AND the ports on the router are unlocked?

JUST wondering....

Thanks in Advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp from LInux to Serv-U ftp server problem csross Linux - General 2 11-07-2005 05:35 PM
FTP problem DataCorrupt Linux - Newbie 1 08-04-2005 12:06 PM
problem with ftp on mandrake 10.1 Official, ftp speeds system wide (anybody noticed?) equinox Mandriva 15 11-10-2004 03:07 PM
FTP Problem - Please help fuelinjection Linux - General 13 12-07-2003 11:46 AM
FTP problem kilogoretrout Linux - General 3 06-22-2003 12:37 AM


All times are GMT -5. The time now is 05:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration