-   Linux - Newbie (
-   -   FTP issue (

mail2vivek1 03-26-2012 05:12 AM

FTP issue
Hello All,

I have configured vsftp server on my machine. and given chrooted access to user 'vivek'.. i am trying to upload one file but getting below error. i am able to browsethe directory, able to download files..also i am able to physically create a file in that directory

eux012{pg337905}# ftp
Connected to
220 (vsFTPd 2.0.5)
Name ( vivek
331 Please specify the password.
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pwd
257 "/"
ftp> put /home/pg337905/
200 PORT command successful. Consider using PASV.
553 Could not create file.

ftp> ls -l
200 PORT command successful. Consider using PASV.
150 Here comes the directory listing.
-rw-r--r-- 1 0 0 0 Mar 26 09:37 abc

config file
#anonymous_enable=YES (this is disabled)
#anon_upload_enable=YES (this is disabled)

linuxlover.chaitanya 03-26-2012 06:43 AM

553 code usually refers to permissions issue. Please check the permissions on the folder.

mail2vivek1 03-26-2012 06:57 AM

Yes I checked the permissions.. as i mentioned before i am able to create files and folders in that directory

linuxlover.chaitanya 03-26-2012 07:45 AM

You mean to say you can create files and folders by physically logging into the system or using FTP console?

uNicks001 03-26-2012 10:01 AM

what are the permissions set to on the folder that you are ftp'ing to?

also in the vsftpd.conf file is this enabled? write_enable=YES

I have also seen similar issues due to file names(underscores, file extension...etc.) and/or length of filenames and file size.

what happens if you set the folder to 777 then ftp a small test file with a simple one word name?

mail2vivek1 03-27-2012 06:00 AM

1 Attachment(s)

Yes, i am able to create file by using physically login in server (not by ftp)

I tried to give 777 permission to home directory, still it did not work :(

Attached is my vsftpd config file.

Please advise, i am so confused by trying lots of thing in this

uNicks001 03-27-2012 08:18 AM

the file seems fine. But I do see this in your file: userlist_enable=YES

this means that you are specifying which users can access the ftp site. do you have a userlist file with login names in it?

if you set it to NO it will disable looking for a userlist. dont forget to restart the vsftpd service.

mail2vivek1 03-27-2012 08:53 AM

i put userlist option for a reason.. i just want to allow few user to access ftp.

All times are GMT -5. The time now is 11:20 PM.