LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2014, 03:03 AM   #1
runningadithya
LQ Newbie
 
Registered: May 2014
Posts: 1

Rep: Reputation: Disabled
ftp error 426, network streaming error,restart of server fixes issue for a day or two


Having an issue with ftp put, 'ftp_put' returns false and files are only transferred incompletely. The error returned is 426 Failure reading network stream. Also got 'Transfer aborted' error when tried to upload files to another server.

Restart of the server is fixing the issue for 2 or 3 days. I tried with a third server too, this time it was uploaded to that server. But still issue persists with the other servers.

Any possible chances for resource locks which automatically fixed while restarting the server. What are the main logs to check for this issue? Also where should I check to know if some resource locking happens? Or something else which will be helpful to solve this issue...

Destination server is using vsftpd and the source is having proftpd sever. Is there any changes needed in the configuration source or detination servers? What could be the reason for failure of these file uploads until restart of the source server and 426 network streaming error?

ftp> put testfile.mp3
local: testfile.mp3 remote: testfile.mp3
ftp: setsockopt (ignored): Permission denied
---> PORT x,x,x,x,54,85
200 PORT command successful. Consider using PASV.
---> STOR testfile.mp3
150 Ok to send data.
426 Failure reading network stream.
279040 bytes sent in 0.01 secs (24289.2 kB/s)


Thanks in advance for the help.

Last edited by runningadithya; 06-05-2014 at 07:49 AM.
 
Old 05-31-2014, 02:33 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,569

Rep: Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696Reputation: 696
Approach it logically. Try some of these.
Have you tried sftp, part of ssh & friends? Does it still crash?
Have you tried a different network interface? Different interrupt on the same interface?
Nothing silly on the disk (e.g. errors) or poorly installed/buggy programs?
Is the server hiding behind NAT which may muck around with port numbers?
Anything in the logs?
Try and eliminate things and verify parts at a time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error in linux when restart network service chuikingman Linux - Server 1 06-20-2011 05:59 AM
What dose error 426 in ftp mean Tekken Linux - Networking 4 06-22-2009 09:56 AM
cifs and 426 Sendfile error: Value too large for defined data type punt Linux - Networking 5 04-10-2008 06:59 AM
FC4 network restart error dretzloff Linux - Networking 2 01-28-2006 12:53 AM
when I restart my network I get an loopback error, Why? mbanbury Linux - Networking 0 05-16-2004 03:33 PM


All times are GMT -5. The time now is 09:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration