LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2001, 11:13 AM   #1
Sathe
Member
 
Registered: Sep 2001
Location: Bryan, Ohio USA (Home of the Etch-A Sketch)
Distribution: RedHat 7.1, 7.2, and 7.3
Posts: 76

Rep: Reputation: 15
Ftp


i'm trying to FTP to my ISP's webspace available for me from my workstation, i am going through a linux box to get connected to the internet. everytime i try to connect i get an invalid port error, i am using LeechFTP, i get the same error using IE (god help me). Am i missing something in my masq or ipforwarding?
 
Old 10-11-2001, 01:06 PM   #2
trusouthrnplaya
Member
 
Registered: Jun 2001
Location: (Cashville) Nashville, TN
Distribution: CentOS 4.0, Slackware 10.2,
Posts: 223

Rep: Reputation: 30
It sounds like to me that u either 1) don't have ur ftp server running or 2) u have that port blocked.....My guess is that ur port is blocked might wanna check ur firewall configuration.
 
Old 10-11-2001, 01:16 PM   #3
Sathe
Member
 
Registered: Sep 2001
Location: Bryan, Ohio USA (Home of the Etch-A Sketch)
Distribution: RedHat 7.1, 7.2, and 7.3
Posts: 76

Original Poster
Rep: Reputation: 15
echo 1 > /proc/sys/net/ipv4/ip_forward
ipchains -F
ipchains -P input ACCEPT
ipchains -P output ACCEPT
ipchains -P forward ACCEPT
ipchains -A forward -i ppp0-j MASQ

this is all i hae set up, no firewalling at all

Last edited by Sathe; 10-11-2001 at 01:56 PM.
 
Old 10-12-2001, 03:42 PM   #4
ejtbrown
Member
 
Registered: Mar 2001
Location: Santa Maria CA USA
Distribution: RedHat 6.0 & RedHat 7.0
Posts: 36

Rep: Reputation: 15
I had this very same problem connecting through my RH 6.0 server. What ended up fixing it was building a new kernel on the machine masqing the internet connection. In the networking section of the kernel configuration, one of the options for IP Masqerading can be turned on to allow the FTP port command to work. I don't remember off the top of my head which one it is, but you can read the Help on each of the options and figure it out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp(through web site access to ftp server) kelper Linux - Software 4 07-03-2015 06:14 PM
ftp server - Pure ftp - logs in OK but no files visible tp11235 Linux - Networking 2 08-30-2005 06:11 AM
FTP Server Up and running... how do I hide ftp users from local login screen? joe1031 Mandriva 2 03-18-2005 05:24 PM
problem with ftp on mandrake 10.1 Official, ftp speeds system wide (anybody noticed?) equinox Mandriva 15 11-10-2004 03:07 PM
how can I restrict ftp users listing files from a pure-ftp server adrianmak Linux - Networking 2 12-31-2002 09:23 AM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration