LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-27-2005, 03:18 PM   #1
ethereal9
LQ Newbie
 
Registered: Jul 2003
Location: Scotland
Distribution: Fedora Core 4
Posts: 26

Rep: Reputation: 15
fstab problem mount partition as user?


hi thanks for reading my thread.

i did have my fedora core 3 running great and i was able to access partitions from windows xp, but i changed my motherboard and installed fedora core 4 now i cant access the mounted partitions.

because i can access the folder /files/applications when there is nothing mounted but can't access it when i mount the partition i believe my problem is that the partitions are mounted as root

i added this to my fstab to mount the partition

/dev/hdb5 /files/applications ext3 defaults 0 0

i am pretty sure i need to change the defaults to something ?

i would like to allow access to anybody.

thanks for any help
mark

once this is fixed i'll move on to my next problem :-)
 
Old 12-27-2005, 03:25 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Change the fstab entry (as root) from;

/dev/hdb5 /files/applications ext3 defaults 0 0

to something like;

/dev/hdb5 /files/applications ext3 exec,users,rw 0 0

Please see both 'man mount' and 'man fstab' for the details and other options.
 
Old 12-27-2005, 03:31 PM   #3
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
Right. I agree, this should help. If it does not, then tell us if the partition is primary or logical. As I said some time ago: FC4 is the main source of problems on LQ.
 
Old 12-27-2005, 03:31 PM   #4
cuiq
Member
 
Registered: Aug 2004
Location: Philly
Distribution: Debian Lenny, FreeBSD
Posts: 577

Rep: Reputation: 30
Try adding "user" or "users" w/o quotes after "defaults". The "user" switch is for when there is only one user setup on your box (I Think). "users" is for mulituse boxes. Anyway give it a try. it should look like this.

/dev/hdb5 /files/applications ext3 defaults,users 0 0


Peace V

Oh! I see this was answered above. Sorry for the late post.

Last edited by cuiq; 12-27-2005 at 03:32 PM.
 
Old 01-01-2006, 10:38 AM   #5
ethereal9
LQ Newbie
 
Registered: Jul 2003
Location: Scotland
Distribution: Fedora Core 4
Posts: 26

Original Poster
Rep: Reputation: 15
Smile problem solved

thanks to everybody for their prompt replies. i edited my fstab using all of the above tips and all of my partitions mounted correctly.

i could use the file browser and access the partitions through /files/(then the folder name)

only problem was that when i clicked on the network icon it showed all 4 folders okay but when you click on them it said that the folders did not exist. i know that they do because i can browse to then at /files/(folder name)

it turns out that there are bugs in fedora core 4 samba sharing

1. if the firwall is running you can't access the linux computer from windows.

i disabled the firewall and i can see the shared folders on the linux computer but when i click on them i get this folder does not exist error.

2. it has been reported that if the smbd service is run normally as part of the boot process then samba is broken.

if i stop the smbd service and then restart manually with - smbd -D that fixes the folder does not exist problem.

i can now access all 3 computers on my network (2 x windows XP and 1 x Fedora core 4)

it makes me slightly mad that i'll have to disable my firewall and then start smbd manually.

thanks again for your help, i'll never upgrade again :-)
 
Old 01-01-2006, 04:54 PM   #6
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Maybe if you start Samba after all of the disks are mounted it will work.

Check to see what ports are required for Windows shares. This should be in the Samba documentation. Then you can open those ports in the firewall and allow the firewall to keep running.

??? Maybe ???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
/home partition will not mount at boot despite fstab settings zach_barrow Slackware 11 03-10-2005 11:24 PM
want user to be able to mount vfat (fstab ?) qwijibow Linux - Software 4 11-13-2003 11:43 AM
mount a partition and swapon on boot(fstab??) edman007 Linux - Newbie 4 10-01-2003 06:53 AM
mount fat32 in fstab in gentoo, user privs yowwww Linux - General 1 08-22-2003 05:36 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration