LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-08-2003, 10:49 AM   #1
clearh20
LQ Newbie
 
Registered: May 2003
Location: Florida
Distribution: RedHat v9, Mandrake v9.1, Windows 2000
Posts: 12

Rep: Reputation: 0
Question FSTAB / Permission Denied Error


This question deals with the last two entries (hda1& hdb1) of the following /etc/fstab file. Everything else works fine. (RedHat v9, all updates)

After I boot, I'm getting a "permission denied" error when trying to access /dev/hda1 & /dev/hdb1 .

**********************************************************
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/hda1 /mnt/windows ntfs defaults 0 0
/dev/hdb1 /mnt/number2 vfat defaults 0 0

*****************************************
The locations /mnt/windows and /mnt/number2 exist, and work fine when mounted manually.

Now, 'root' can access everything just fine. AlI need is read access for any other user, and have it mount itself at boot. I tried changing permissions, but I get the error message "file system is read only". (Which is what I want, partially.)

I've made some half-hearted attempts at changing permissions, but I've read that they change for the time being, and revert back to the original after a reboot. I need the perms to allow everyone read-only access to hda1 and hdb1 and have the perms stay after rebooting.

I'm fairly sure the "defaults" part in the above fstab entries need to be changed, but I can't figure out what the options are, let alone what they should be.

Hope thats clear enough. Thanks for any input.
 
Old 06-08-2003, 11:27 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
pretty common question around here.... set defaults,umask=000 as the options for those entires instead of just defaults.
 
Old 06-08-2003, 11:29 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
incidentally you should be able to appreciate why you can't set file permissions on a fat32 drive under unix as the fat32 filesystem has no conecpt of file ownership and such, so the data is just plain not there in the first place to be changed.
 
Old 06-08-2003, 11:34 AM   #4
contrasutra
Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
try adding "user" before "defaults", that should work.
 
Old 06-08-2003, 01:06 PM   #5
clearh20
LQ Newbie
 
Registered: May 2003
Location: Florida
Distribution: RedHat v9, Mandrake v9.1, Windows 2000
Posts: 12

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks.

I first tried "user,defaults" then "users,defaults", neither worked for me. Don't know why.

However, when I put "umask=000,defaults" in, it worked fine.

Thanks to both of you for your help.

If I've got this umask thing understood correctly, Execute=1, Write=2, Read=4 - so - does "000" mean all access is granted? If so, would "777" be the same thing?


Again, thanks.

Last edited by clearh20; 06-08-2003 at 01:16 PM.
 
Old 06-10-2003, 12:43 AM   #6
laydros
Member
 
Registered: Jun 2003
Location: Raleigh, NC, US
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
well, both are kinda right

if you set a umask, you subtract. if you do a chmod, you add.

so if you want to give a file all permissions, you chmod 777 <file>

when you set a umask, it determines the permissions on files that you create. so a umask=000 is like chmod 777 to a file.

i hope i didnt' mix that up. somebody correct me if im wrong.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cgi-bin error (Permission Denied) Help! Amorgos Programming 8 09-08-2008 10:20 PM
Sound Server (Permission Denied error) rapont Slackware 8 10-29-2007 02:49 AM
Samba error: Permission denied dmkang Linux - Software 6 04-01-2005 08:29 AM
sasldb Permission denied error shino Linux - Networking 0 01-15-2004 03:55 PM
permission denied error endezeichen Linux - General 5 12-20-2003 06:59 PM


All times are GMT -5. The time now is 01:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration