LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-05-2005, 11:21 PM   #1
cryptoX
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian 5.0 on Xfce
Posts: 8

Rep: Reputation: 0
Fstab doesn't listen


I can't get my usb drive to mount from my user account. It says that only root can do that. Before I re-installed, I could use uid=adam in the fstab to allow me to mount, but that isn't working anymore.

ls -l /mnt
drwxr-xr-x 2 adam adam 1536 Jun 5 23:07 usb_drive

cat etc/fstab
/dev/sda1 /mnt/usb_drive vfat noauto,owner 0 0
/dev/sda1 /mnt/usb_drive vfat noauto,uid=adam 0 0

Neither of the ways above work. The only way it works is with
/dev/sda1 /mnt/usb_drive vfat noauto,user(s) 0 0

Shouldn't the uid in the fstab allow me to mount?
 
Old 06-06-2005, 12:05 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,745

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
Unless I am sorely mistaken, you are only allowed one entry in fstab per device. Otherwise, you create a conflict of some kind. Even if thay seem to be one and the same. Your fstab has 2 entries for the same device. Try commenting out 1 of the lines (add the # before the line) and see if that works. If it does not, remove that # and add it to the next line. Then try again.

If both of those fail, try editing fstab. Change owner to user, so that the logged-in user has permission to mount. You could also try changing owner to users, so that members of the users group have permission.
 
Old 06-06-2005, 12:15 AM   #3
cryptoX
LQ Newbie
 
Registered: Jun 2005
Distribution: Debian 5.0 on Xfce
Posts: 8

Original Poster
Rep: Reputation: 0
Sorry for the confusion, but I meant that I had tried without it working
/dev/sda1 /mnt/usb_drive vfat noauto,uid=adam 0 0
then i changed it to
/dev/sda1 /mnt/usb_drive vfat noauto,owner 0 0
and it still didn't work

While changing owner to user or users works, i thought that using uid=adam should have worked.
 
Old 06-06-2005, 12:20 PM   #4
a thing
Member
 
Registered: Jan 2005
Distribution: Fedora Core 4 Test 3/3.92, Fedora Core 3
Posts: 45

Rep: Reputation: 15
"uid=xxx" is not what you want. You want to use the "user" option. And I'm pretty sure uid uses user numbers (found in /etc/passwd) not names.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 06:15 AM
Want to listen but not sure how... lowbrow Linux - Newbie 5 06-03-2005 12:14 PM
newbie vs fstab. fstab wins :( blop Linux - Newbie 3 01-07-2005 05:54 AM
(version 5.1 chapter 08 fstab) vs (man fstab) rgiggs Linux From Scratch 2 06-03-2004 05:55 PM
Listen acid_kewpie!!!!!!!! arunshivanandan General 2 10-08-2003 08:05 AM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration