LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2004, 09:06 AM   #1
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Rep: Reputation: 30
fstab defaults sets wrong permissions


i have a weird problem. the subject says it all. here is my fstab

# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system> <mount point> <type> <options> <dump> <pass>
#
# dump(8) uses the <dump> field to determine which file systems need
# to be dumped. fsck(8) uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# This is a root linux ext2 partition:
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1

# This is a linux ext2 partition:
#/dev/hda2 /mnt/linux ext2 defaults 0 2
/dev/hda7 /home ext3 defaults,user 1 2

# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/cdrom /mnt/cdrom iso9660 defaults,noauto,ro,user 0 0
/dev/fd0 /mnt/floppy auto defaults,noauto,user 0 0
#/dev/fd1 /mnt/floppy auto defaults,noauto,user 0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd /mnt/ls120 auto defaults,noauto,user 0 0

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de /mnt/nfs nfs defaults 0 0

# proc file system:
proc /proc proc defaults 0 0

# Unix98 devpts filesystem:
none /dev/pts devpts gid=5,mode=666 0 0

# Shared memory filesystem:
#none /var/shm shm defaults 0 0
# Basic USB filesystem
usbdevfs /proc/bus/usb usbdevfs defaults,noauto 0 0

# For dos partition use type 'msdos'.
# For win95/98 fat16 or FAT32 partition use type 'vfat'.
/dev/hda1 /mnt/win_c vfat defaults,user,umask=000 0 0
/dev/hda2 /mnt/win_d vfat defaults,user,umask=000 0 0
/dev/hda3 /mnt/win_e vfat defaults,user,umask=000 0 0

# The 'sw' option indicates that the swap partition is to be activated
# with 'swapon -a'.
/dev/hda6 none swap sw 0 0

# Swap file:
#/swap none swap sw 0 0

and here is the result of mount:

[dibble:myBox] dibble: mount
/dev/hda5 on / type ext3 (rw,errors=remount-ro)
/dev/hda7 on /home type ext3 (rw,noexec,nosuid,nodev)
proc on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=666)
/dev/hda1 on /mnt/win_c type vfat (rw,noexec,nosuid,nodev,umask=000)
/dev/hda2 on /mnt/win_d type vfat (rw,noexec,nosuid,nodev,umask=000)
/dev/hda3 on /mnt/win_e type vfat (rw,noexec,nosuid,nodev,umask=000)
usbdevfs on /proc/bus/usb type usbdevfs (rw)

man fstab says defaults should not be setting permissions like this - what has gone wrong - i can't execute in /home at all!
 
Old 02-14-2004, 11:05 AM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,932

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Quote:
/dev/hda7 /home ext3 defaults,user 1 2
Remove user option from your /home fstab entry. See man pages for mount for more info.

user Allow an ordinary user to mount the file
system. This option implies the options
noexec, nosuid, and nodev (unless overridden
by subsequent options, as in the option line
user,exec,dev,suid).
 
Old 02-14-2004, 11:56 AM   #3
dibblethewrecke
Member
 
Registered: Nov 2003
Location: UK
Distribution: Arch Linux
Posts: 210

Original Poster
Rep: Reputation: 30
don't know how i missed that when i read the man and discovered what the defaults "should" have been

whoops

that explains an AWFUL lot about why loads of things don't work for me!

cheers
 
Old 12-11-2004, 03:10 PM   #4
fortezza
Member
 
Registered: Mar 2003
Location: Colorado
Distribution: Fedora Core 4
Posts: 297

Rep: Reputation: 30
Would this explain my inability to mount ISO images that reside on an NFS Share?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
what is wrong with this /etc/fstab entry? d1l2w3 Linux - Hardware 10 02-01-2005 12:15 AM
printer sets margins wrong (sometimes) marie-p Linux - Hardware 0 01-23-2005 01:05 PM
fstab error in line 11, what's wrong? EPa Linux - Networking 4 03-06-2004 11:46 AM
What am I doing wrong in my Fstab? Mounting for Users jimdaworm Slackware 4 11-07-2003 02:46 PM
iptables script sets wrong dynamic IP gundelgauk Linux - Security 5 09-08-2003 08:42 AM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration