LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-27-2003, 10:30 AM   #1
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Rep: Reputation: 15
fstab and windows partitions


I have 2 windows partitions. I have specified this fstab file
Code:
LABEL=/                 /                  ext3    defaults        1 1
LABEL=/boot             /boot              ext3    defaults        1 2
none                    /dev/pts           devpts  gid=5,mode=620  0 0
none                    /proc              proc    defaults        0 0
none                    /dev/shm           tmpfs   defaults        0 0
/dev/hda8               swap               swap    defaults        0 0
/dev/hda1               /mnt/winc          vfat    ro,user         0 0
/dev/hda5               /mnt/wind          vfat rw,user,gid=500,setgid=500,mode=764 0 0
/dev/cdrom              /mnt/cdrom         udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1        udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy        auto    noauto,owner,kudzu 0 0
I ceated the group with gid 500 and I have my user in the group.
If I check the permissions from nautilus I see that /mnt/wind is in tat group and not in the root group. The owner still is root, and I don't want to change that.
How do I change the mode so my user (not root) can read and write all files inside that filesystem?
I want
owner: rwx
group:rw-
other:r--

Any other suggestion about this setup is welcome
 
Old 12-27-2003, 10:57 AM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
change the line to read..........
Code:
/dev/hda5      /mnt/wind      vfat    rw,users,gid=500,setgid=500,mode=764 0 0

Last edited by 320mb; 12-27-2003 at 10:58 AM.
 
Old 12-27-2003, 01:34 PM   #3
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Original Poster
Rep: Reputation: 15
Doesn't do the trick....
Here's what I have:
Code:
[fede@localhost fede]$ cat /etc/fstab
LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda8               swap                    swap    defaults        0 0
/dev/hda1               /mnt/winc               vfat    ro,user         0 0
/dev/hda5               /mnt/wind               vfat    rw,users,gid=500,setgid=500,mode=764 0 0
/dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0
[fede@localhost fede]$ ls -all /mnt/
total 40
drwxr-xr-x    7 root     root         4096 Nov  6 23:14 .
drwxr-xr-x   19 root     root         4096 Dec 27 16:27 ..
drwxr-xr-x    2 root     root         4096 Nov  6 17:11 cdrom
drwxr-xr-x    2 root     root         4096 Nov  6 17:11 cdrom1
drwxr-xr-x    2 root     root         4096 Nov  6 17:11 floppy
drwxr-xr-x   15 root     root         4096 Dec 31  1969 winc
drwxr-xr-x   10 root     windaccess    16384 Dec 31  1969 wind
[fede@localhost fede]$
 
Old 12-28-2003, 05:55 PM   #4
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Quote:
/dev/hda1 /mnt/winc vfat ro,user 0 0
You could try this :

Code:
/dev/hda1      /mnt/winc     vfat    umask=016,gid=500    0 0
I believe this should do what you need it to.

I may be wrong on the numbers so try:

man umask

Let me know if it works, I am not on my Linux box, so I couldn't be absolutely sure about the numbers.
 
Old 12-29-2003, 01:34 AM   #5
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
umask kinda works backwards, (eg: 016 is the same as 761)

Try JayCnrs option.
 
Old 12-29-2003, 05:47 AM   #6
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Original Poster
Rep: Reputation: 15
As soon as I get home, I will.
 
Old 12-29-2003, 06:09 PM   #7
fedetxf
Member
 
Registered: Nov 2003
Location: Argentina
Distribution: RedHat 9
Posts: 54

Original Poster
Rep: Reputation: 15
Well, after 10 reboots, I got it working. In the process I learned it does not make sense to remove the execute permission, doing it makes it impossible to do an ls or a cd and nautilus goes crazy and can list the contents prperly.
Here's the fin al version

/dev/hda5 /mnt/wind vfat rw,user,suid,umask=002,gid=500 0 0
and the result
drwxrwxr-x 10 root windaccess 16384 Dec 31 1969 wind
As my user is in the group, I can r and w it. Other users can read it. nice. Thanks.

EDIT: i just noticed, why does it have that timestamp????? Looks weird.....

Last edited by fedetxf; 12-29-2003 at 06:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard drive partitions not set up in fstab/mtab odyssey84 Linux - Newbie 6 10-18-2005 07:59 AM
/etc/fstab can't mount Windows XP Zeppelin_ii Linux - Software 4 07-21-2005 12:12 PM
fstab extended partitions Chrax Slackware 2 01-03-2005 06:19 PM
why won't my fat32 partitions show up in fstab lailoken Linux - Newbie 8 04-21-2004 01:44 PM
Mounting FreeBSD partitions inside fstab damien Linux - General 1 02-04-2004 09:32 PM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration