LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-19-2009, 09:12 AM   #1
Cyberman
Member
 
Registered: Aug 2005
Distribution: Debian Stable
Posts: 216

Rep: Reputation: 17
fstab and my Vista partition: can't mount at all


I can't remember if things with mounting vista/ntfs partitions has changed, but I cannot seem to get my partition mounted as a read-write partition.

I tried this in fstab:
############### Vista
/dev/sda1 /media/vista ntfs users,exec,auto 0 0

And it made it read-only..

so i tried this:
/dev/sda1 /media/vista ntfs-3g rw,users,exec,auto 0 0

and it wouldn't mount it.

Quote:
$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/sda1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
clicking on the 'Safely Remove Hardware' icon in the Windows
taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/sda1 /media/vista -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/sda1 /media/vista ntfs-3g force 0 0
 
Old 12-19-2009, 01:03 PM   #2
lugoteehalt
Senior Member
 
Registered: Sep 2003
Location: UK
Distribution: Debian
Posts: 1,215
Blog Entries: 2

Rep: Reputation: 49
Quote:
Originally Posted by Cyberman View Post
I can't remember if things with mounting vista/ntfs partitions has changed, but I cannot seem to get my partition mounted as a read-write partition.

I tried this in fstab:
############### Vista
/dev/sda1 /media/vista ntfs users,exec,auto 0 0

And it made it read-only..

so i tried this:
/dev/sda1 /media/vista ntfs-3g rw,users,exec,auto 0 0

and it wouldn't mount it.
Don't really know but there appear to be some errors:

Doesn't 'users' mean 'allow all users to mount the thing', this is inconsistent with 'auto' which, would have thought meant: 'mount the thing automatically on startup'.

Doesn't 'exec' mean 'allow programs to be executed'. You cannot run windows programs inside Linux.

So suggest replace with users, rw and then mount it yourself manually. Dont know if the options uid=yourusername or umask=000 would help.
 
Old 12-19-2009, 01:07 PM   #3
hda7
Member
 
Registered: May 2009
Distribution: Debian wheezy
Posts: 251

Rep: Reputation: 31
If you have a Windows machine, try using that device with windows, and preforming a clean shutdown. If that won't work, or is impractical, try "ntfs-3g /dev/sda1 /media/vista -o force".
 
Old 12-19-2009, 01:16 PM   #4
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
PHP Code:
mount -t ntfs-3g /dev/sda1 /media/vista -o force

Or add the option to the relevant row in the /etc/fstab file:

/
dev/sda1 /media/vista ntfs-3g force 0 0 
what are you trying to accomplish that you are adding additional options to fstab?

PHP Code:
# Entry for /dev/sdb1 :
/dev/sdb1 /mnt/data ntfs-3g relatime 1 2 
was an autogenerated fstab entry created at install with mandriva for an ntfs data partition. I edited from uuid......... to the /dev/sdb1 just because it looked cleaner to me.
 
Old 12-19-2009, 01:27 PM   #5
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 361

Rep: Reputation: 76
If you have ntfs-3g installed, try this:
Code:
/dev/sda1	/media/vista	ntfs-3g	default	0	0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount VISTA Partition cccc Debian 4 08-02-2009 09:38 PM
not mounting Vista partition ...here's my fstab joutlancpa Slackware 2 05-02-2009 08:37 AM
How do I mount the Vista partition on my laptop? jdruin Linux - Newbie 5 01-09-2009 11:48 PM
Fstab Entry To Mount Vista stratcat Linux - Desktop 5 05-15-2007 08:36 PM
mount a partition and swapon on boot(fstab??) edman007 Linux - Newbie 4 10-01-2003 06:53 AM


All times are GMT -5. The time now is 11:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration