LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2010, 11:25 PM   #1
windstory
Member
 
Registered: Nov 2008
Posts: 486

Rep: Reputation: 36
fsck reports problem


My box is kubuntu 10.04, and has a fsck problem.

Quote:
root@maestro:~# fsck -y
fsck from util-linux-ng 2.17.2
e2fsck 1.41.11 (14-Mar-2010)
/dev/sda1 is mounted.

WARNING!!! The filesystem is mounted. If you continue you
cause ***SEVERE*** filesystem damage.

Do you really want to continue (y/n)? yes

/dev/sda1: recovering journal
fsck.ext4: Bad magic number in super-block while trying to r
Warning... fsck.ext4 for device /dev/sda1 exited with signal
root@maestro:~# apt-get -y upgrade
And now "apt-get" command also has a problem.

Quote:
root@maestro:~# apt-get
Traceback (most recent call last):
File "/usr/lib/command-not-found", line 10, in <module>
import CommandNotFound
ImportError: No module named CommandNotFound
Please let me know how to resolve this problem.
 
Old 10-12-2010, 03:39 AM   #2
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 655

Rep: Reputation: 40
I'm not an expert on this, but it may be that by entering "yes" on the fsck command that you have corrupted your system. The command output told you that it might happen, so I don't understand why you chose to answer "yes". If you don't find a way to correct the issue I suggest you recreate your file system and bring back your files from backup (if you have your files backuped up).
 
1 members found this post helpful.
Old 10-12-2010, 03:52 AM   #3
prayag_pjs
Senior Member
 
Registered: Feb 2008
Location: Pune - India
Distribution: Fedora,RedHat,CentOS,Gentoo
Posts: 1,138
Blog Entries: 4

Rep: Reputation: 147Reputation: 147
Hi,

Reboot your system and see the system boots properly.(You are in single user mode where networking doesn't work)

After booting in your system try

# apt-get update
 
1 members found this post helpful.
Old 10-12-2010, 03:52 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,951

Rep: Reputation: Disabled
You might umount /dev/sda1 previous to a renewed attempt to run fsck. If it is a system partition boot from a live disk or your installation DVD. It usually contains a rescue or live mode made for just these purposes.
 
1 members found this post helpful.
Old 10-12-2010, 04:01 AM   #5
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
You should not run fsck on a mounted partition, if you want to do this run this on reboot before mounting devices:

Quote:
shutdown -F -r now
 
2 members found this post helpful.
Old 10-12-2010, 04:07 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,951

Rep: Reputation: Disabled
Indeed, that is the easiest and fastest way. Kudos to divyashree .
 
1 members found this post helpful.
Old 10-13-2010, 02:47 AM   #7
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
At live cd, I found my root partition has strange name "Amoeba".
http://img819.imageshack.us/img819/1...grubrescue.png

I could not resolve this problem, and don't know how to make a question for this partition problem.
Fortunately I have a backup files, so I'll try to reinstall.
 
Old 10-13-2010, 03:26 AM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,951

Rep: Reputation: Disabled
There is one simple chance to avoid reinstalling.

Amoeba is not the name of your partition but the name of the system using this type of partition. So. Do a "fdisk /dev/sda" you'll then be in the active mode of fdisk. Use m for help to see all the commands. Get the list of partition types. Linux should be "83" not "93". Change that. Maybe(!) that will allow then to run fsck successfully. Good luck.
 
Old 10-13-2010, 03:55 AM   #9
kenneho
Member
 
Registered: May 2003
Location: Oslo, Norway
Distribution: Ubuntu, Red Hat Enterprise Linux
Posts: 655

Rep: Reputation: 40
Quote:
Originally Posted by divyashree View Post
You should not run fsck on a mounted partition, if you want to do this run this on reboot before mounting devices:
Excellent! Didn't know about this flag. Thanks for the tip.

- kenneho
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sarg reports problem carabina5 Linux - Software 1 10-22-2009 01:41 AM
Problem with fsck jonlake Linux - Software 19 01-17-2006 08:57 PM
fsck problem RBJohns Linux - General 6 02-24-2005 07:55 PM
automatic fsck on boot. fsck errors. nixel Slackware 1 05-17-2004 08:51 AM
wlan0 reports any problem... rabby Linux - Wireless Networking 0 04-28-2004 01:08 PM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration