LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-29-2012, 04:46 AM   #1
hadimotamedi
Member
 
Registered: Aug 2009
Posts: 228

Rep: Reputation: 30
fsck -fvy ?‏


Dear All
My server got inconsistency from sudden power cut that I fixed it with #fsck -fvy /dev/hda at the maintenance prompt . But after reboot, one of the installed applications is preventing it from booting up (as can be seen in the boot up process list). Can you please let me know how can I remove it from the boot up list to reach the root user prompt and then re-install it again ?
Thank you
 
Old 09-29-2012, 05:59 AM   #2
suttiwit
Member
 
Registered: Aug 2012
Location: Chiang Mai, Thailand
Distribution: Kubuntu 12.10 x86_64
Posts: 192
Blog Entries: 2

Rep: Reputation: 22
Remove it from the root recovery shell the same shell that you used fsck?
 
1 members found this post helpful.
Old 09-29-2012, 06:21 AM   #3
hadimotamedi
Member
 
Registered: Aug 2009
Posts: 228

Original Poster
Rep: Reputation: 30
Thank you for your reply. But I do not see again the system maintenance prompt and just endlessly waiting on coming up this application in the boot up process list. I am sorry to forget to remove it the last time when I was on the system maintenance prompt. So what can I do now ?
 
Old 09-29-2012, 06:46 AM   #4
suttiwit
Member
 
Registered: Aug 2012
Location: Chiang Mai, Thailand
Distribution: Kubuntu 12.10 x86_64
Posts: 192
Blog Entries: 2

Rep: Reputation: 22
What distribution are you using?
 
1 members found this post helpful.
Old 09-29-2012, 07:01 AM   #5
hadimotamedi
Member
 
Registered: Aug 2009
Posts: 228

Original Poster
Rep: Reputation: 30
I am using Linux Redhat.
 
Old 09-29-2012, 11:19 AM   #6
suttiwit
Member
 
Registered: Aug 2012
Location: Chiang Mai, Thailand
Distribution: Kubuntu 12.10 x86_64
Posts: 192
Blog Entries: 2

Rep: Reputation: 22
Never used RedHat, sorry...

Did you mean that you can't go back to maintainance mode because GRUB is not shown every boot time?
 
Old 09-29-2012, 12:07 PM   #7
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,332
Blog Entries: 55

Rep: Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533
Quote:
Originally Posted by hadimotamedi View Post
how can I remove it from the boot up list to reach the root user prompt(..)?
Either 0) boot into a non-multi-user runlevel by appending " 1" or " single" to the end of your GRUB command line on boot, 1) boot into interactive mode by pressing SHIFT+i when asked or 2) boot from a Live CD. Once you're in you can use 'chkconfig --level 12345 [servicename] off' or its systemd equivalent to keep the service from booting. Note that removing and re-installing is a pre-Linux (Windows, mostly) reflex that doesn't help you gain the knowledge to solve things.
 
1 members found this post helpful.
Old 09-29-2012, 01:45 PM   #8
nijinashok00
LQ Newbie
 
Registered: Sep 2012
Posts: 28

Rep: Reputation: Disabled
Enter into your Grub menu by pressing any key while booting. Then enter into the kernel editing mode and enter 1 after the command which shows up so that you can enter into your single user mode which is used for maintenance. Now use the command
chkconfig servicename off
The above command switch off the service from all levels.

If you don't know your service name you can use this command
chkconfig --list
which lists all the services in your system along with its run level details.
Now reboot your system and you are done.
 
1 members found this post helpful.
Old 09-30-2012, 01:05 AM   #9
hadimotamedi
Member
 
Registered: Aug 2009
Posts: 228

Original Poster
Rep: Reputation: 30
At the GRUB screen, I added "single" then "chkconfig omcd off" and reboot. It solved my problem.
Thank you again for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
curl_easy_perform failing when target is behind a NAT‏ HarryBoy Programming 1 11-17-2011 04:39 PM
Audio bitrate Conversion help required.‏ ShaanAli General 10 07-10-2011 09:11 AM
/var/log/messages(dmesg) ?‏ hadimotamedi Linux - Newbie 5 02-23-2010 12:06 AM
Information about bind dlz‏ coffee777 Linux - Server 2 09-18-2009 02:01 AM
alsa programming problem in set frames and buffer size‏‏ wswhp Linux - Kernel 1 12-04-2008 03:39 AM


All times are GMT -5. The time now is 01:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration