LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2005, 09:58 AM   #1
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Rep: Reputation: 15
Unhappy fs vfat not supported by kernel


I am a little flustered on this one. I am trying to get my RH8 box to read a dos formatted floppy. I installed and configured kernel 2.6.9 with support for other file systems enabled. When I go into the ~linux-2.6.9/fs directory, I see a vfat folder. I edited my /etc/fstab file to read the floppy as vfat, but when I try to mount the disk, I get an fs vfat not supported by kernel error. Did I miss something?
 
Old 05-04-2005, 10:15 AM   #2
bdox
Member
 
Registered: Feb 2005
Location: SoL iii
Distribution: Mandriva 2007
Posts: 110

Rep: Reputation: 15
Hi
try auto intead of vfat....
Cheers!
 
Old 05-04-2005, 11:28 AM   #3
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Original Poster
Rep: Reputation: 15
Thanks for the help, but when I changed the /etc/fstab option back to auto, the "mount -t vfat /dev/floppy /mnt/floppy" command still tells me vfat is not supported. I tried substituting vfat with auto in the command but was told to specify the type. I tried fat16 and fat32 for giggles, but get the not supported error. Any other suggestions?
 
Old 05-04-2005, 11:35 AM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
you'll have to recompile your kernel to support those filesystems or try loading modules if they are compiled as modules
 
Old 05-04-2005, 11:59 AM   #5
bdox
Member
 
Registered: Feb 2005
Location: SoL iii
Distribution: Mandriva 2007
Posts: 110

Rep: Reputation: 15
put auto in four fstab and try the command:
mount /dev/floppy
cheers!
 
Old 05-04-2005, 03:27 PM   #6
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Original Poster
Rep: Reputation: 15
I am not sure what you mean by putting auto in four fstab. I tried recompiling the kernel and selected other under file systems. Shouldn't that force the modules to load? What do I look for when I do lsmod? Thanks for the help.
 
Old 05-04-2005, 04:14 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Quote:
Originally posted by abk4523
I am not sure what you mean by putting auto in four fstab.
It probably means fourth column in /etc/fstab, line with floppy description.
Quote:
I tried recompiling the kernel and selected other under file systems. Shouldn't that force the modules to load?
Compiling alone no. Mount attempt - yes.
Quote:
What do I look for when I do lsmod? Thanks for the help.
If the filesystems are compiled as modules, they should be on the lsmod list.
 
Old 05-04-2005, 07:09 PM   #8
bdox
Member
 
Registered: Feb 2005
Location: SoL iii
Distribution: Mandriva 2007
Posts: 110

Rep: Reputation: 15
oops... that was a mistake, sorry...

put auto in your fstab (instead of vfat) and try the command:
mount /dev/floppy

Cheers!
 
Old 05-04-2005, 07:38 PM   #9
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Original Poster
Rep: Reputation: 15
I tried auto in the fourth column of fstab. Mount /dev/floppy tells me it can't find /dev/floppy in fstab. Mount /mnt/floppy tells me I must specify a file system. I will keep looking though...
 
Old 05-04-2005, 07:44 PM   #10
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
Maybe it is ' mount /dev/fd0 '. It needs to match the fstab file.
Post your /ets/fstab file.

Brian1
 
Old 05-04-2005, 07:47 PM   #11
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Original Poster
Rep: Reputation: 15
I took a closer look at my kernel configuration. VFAT support was listed as a loadable module as opposed to built in. I will correct and if that does not work, will post the fstab. Thanks again.
 
Old 05-05-2005, 04:50 AM   #12
bdox
Member
 
Registered: Feb 2005
Location: SoL iii
Distribution: Mandriva 2007
Posts: 110

Rep: Reputation: 15
Brian1, from 'man mount':

(iii) Normally, only the superuser can mount file systems. However,
when fstab contains the user option on a line, then anybody can mount the corresponding system.
Thus, given a line
/dev/cdrom /cd iso9660 ro,user,noauto,unhide
any user can mount the iso9660 file system found on his CDROM using the command
mount /dev/cdrom
or
mount /cd


but any way, of course, is a good idea to post your fstab.
 
Old 05-05-2005, 09:25 AM   #13
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Original Poster
Rep: Reputation: 15
I tried /dev/fd0 with no luck. I was logged on as root, so it should not be a rights issue. Here is the fstab posting. Pretty generic.

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
 
Old 05-05-2005, 01:32 PM   #14
bdox
Member
 
Registered: Feb 2005
Location: SoL iii
Distribution: Mandriva 2007
Posts: 110

Rep: Reputation: 15
ok, give me the output of
mount /mnt/floppy
(make sure you have not changed your fstab since you posted it)

Cheers!
 
Old 05-05-2005, 02:34 PM   #15
abk4523
Member
 
Registered: Jun 2004
Distribution: RH8/Fedora Core 4
Posts: 117

Original Poster
Rep: Reputation: 15
Output of mount /mnt/floppy is : mount: you must specify the filesystem type I have not changed the fstab since posting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vfat (possible kernel) problems microsoft/linux Debian 17 11-15-2004 08:08 PM
VFAT limitation on kernel 2.6 demmylls Linux - General 2 03-11-2004 12:25 PM
Vfat not supported ? thundersnows Slackware 5 09-01-2003 03:50 AM
kernel 2.4.2-2 doesnt support vfat???? vimalkumar_v Linux - Newbie 3 12-31-2002 05:54 AM
Got kernel v2.4 upgraded, now don't have vfat support rdaves@earthlink.net Linux - Newbie 4 06-09-2001 03:35 PM


All times are GMT -5. The time now is 10:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration