LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2005, 05:30 AM   #1
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Rep: Reputation: 0
simple question


how do i see my windows directories and file in fedora core 3 linux?

All i can see is the linux drive, hardware finder finds the device, and calls it hda and hda1 or something.

but i can't see any of my files and folders,

Please help me. Please. Pretty Please
 
Old 03-12-2005, 05:34 AM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

visit the "My help pages" section at
www.linux-iips.tk
and u can get some docs on mounting drives in linux

regards
 
Old 03-12-2005, 05:41 AM   #3
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Original Poster
Rep: Reputation: 0
will try that out, thankyou times infiniti
 
Old 03-12-2005, 05:56 AM   #4
fssengg
Member
 
Registered: Feb 2005
Location: Kerala(God's own country)
Distribution: Redhat-8
Posts: 35

Rep: Reputation: 15
for viewing a widows drive from linx u have to mount it to linux directory tree.
1)crere a directory say "wind" in ur linux directory.
2)suppose if ur windows is installed in ur first primary partition it will be taken as hda1
so type "mount /dev/hda1 wind" at command prompt
3)now u can see the files in ur windows directory under wind folder
4)usually only root can do this

try this
 
Old 03-12-2005, 06:40 AM   #5
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Original Poster
Rep: Reputation: 0
Well what an experience. figured out after a while what window to get up to enter in these commands. did that, after a while of fumbling around linux i used this thing which asked me for some password then i got into root i think.

Anyway it said and i quote "fs type not supported by kernel" i'm using fedora core 3.

the file system is a standard xp ntfs volume.

Where should i go from here?
 
Old 03-12-2005, 06:56 AM   #6
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Original Poster
Rep: Reputation: 0
fs type not supported by kernel?

Well what an experience. figured out after a while what window to get up to enter in these commands. did that, after a while of fumbling around linux i used this thing which asked me for some password then i got into root i think.

Anyway it said and i quote "fs type not supported by kernel" i'm using fedora core 3.

the file system is a standard xp ntfs volume.

Where should i go from here?
 
Old 03-12-2005, 06:59 AM   #7
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
After becoming root (meaning you have to open up the window you mentioned and which probably it's a console) by using 'su', type 'mount -t ntfs -o ro,noexec,umask=000 /dev/hda1 /mnt/hda1' *if* you have already a /mnt/hda1 directory created. If not, create one with 'mkdir /mnt/hda1'.
This is what fssengg was trying to tell you.

Note that I presumed it is hda1; might be not. Also, instead of /mnt/hda1 you can create a directory with another name and location as you wish. And finally, you can "play" around with the umask settings to allow users certain rights over the partition.
 
Old 03-12-2005, 07:01 AM   #8
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
NTFS is a horrible filesystem and as such isn't directly supported in the linux kernel. There is an RPM kernel module available somewhere which will give you read access, but writing is still not safe.

Try:
modprobe ntfs
as root
 
Old 03-12-2005, 07:04 AM   #9
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Original Poster
Rep: Reputation: 0
is that "-o ro" or "-oro,noexec,unmask"? silly question but it's important i get the syntax right since it takes ages for me to return to windows.

also i created a dir called wind under mnt. the command i used was correct for the hard drive, twas just the ntfs thing.

i typed "mount /dev/hda1 /mnt/wind"
 
Old 03-12-2005, 07:10 AM   #10
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
It is '-o ro...'. This is the syntax most of the command line programs use: 'program_name -option"space"option_value'. I hope it's clearer this time as what I typed as "space" should be interpreted by a single blank character.
And it's not "unmask" but "umask".
 
Old 03-12-2005, 07:13 AM   #11
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Original Poster
Rep: Reputation: 0
Why was i able to read all files from the hard drive when i booted using a knoppix cd? Does the knoppix cd contain the modules you are talking about?
 
Old 03-12-2005, 07:20 AM   #12
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
You shouldn't post more than once for the same thing, not to say three times. Your other threads (which already have been responded to) are at:
http://www.linuxquestions.org/questi...hreadid=300677
and
http://www.linuxquestions.org/questi...hreadid=300669
I think it would be easier for you too to follow the answers.
 
Old 03-12-2005, 07:31 AM   #13
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Quote:
Originally posted by thegreat1
Well what an experience. figured out after a while what window to get up to enter in these commands. did that, after a while of fumbling around linux i used this thing which asked me for some password then i got into root i think.

Anyway it said and i quote "fs type not supported by kernel" i'm using fedora core 3.

the file system is a standard xp ntfs volume.

Where should i go from here?
hi there

for ntfs support on fedora core 3
either recompile ur kernel or get the ntfs module from
linux-ntfs.sourceforge.net

regards
 
Old 03-12-2005, 07:35 AM   #14
thegreat1
LQ Newbie
 
Registered: Mar 2005
Location: UK
Distribution: Sony
Posts: 9

Original Poster
Rep: Reputation: 0
sorry
 
Old 03-12-2005, 07:59 AM   #15
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
The Knoppix kernel is probably configured to read from NTFS partitions and the one from Fedora isn't. If you need this feature in Fedora, you may have to recompile your kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: fs type gmailfs not supported by kernel SilentT Linux - Software 6 10-15-2004 10:45 AM
error:mount:fs type supermount not supported by kernel. shams Mandriva 11 05-14-2004 10:22 PM
mount: fs type adfs not supported by kernel patientzero Linux - Software 15 09-07-2003 08:58 PM
During mounting WinXP fs - fs type ntfs not supported by kernel error (RedHat 9) 3xcalibur Linux - General 4 06-04-2003 06:57 AM
mount: fs type ntfs not supported by kernel <--- help! kublador Linux - Newbie 2 03-28-2003 11:21 PM


All times are GMT -5. The time now is 08:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration