LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2009, 08:07 AM   #1
josh22
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
frustrated and need some pointers


i downloaded "Ubuntu" and have it on my hard drive but am able to still use XP. but when i want to use ubuntu, i go through the password screens and all, then i come to an orange page and does nothing :S i have a mouse pointer but thats all thats on the screen. if i could get some help tht would be great!
 
Old 02-08-2009, 08:27 AM   #2
Isix
Member
 
Registered: Mar 2007
Location: Windhoek, Namibia
Distribution: Slackware, Kubuntu, Mandriva & PCLinuxOS
Posts: 80

Rep: Reputation: 18
Lets see: --- when you get to that point try pressing Ctrl+Alt+F1, which will hopefully drop you to a virtual console. Then try
Code:
startx
Let the community then see any error messages that comes thereafter.

Best of luck ...
 
Old 02-08-2009, 08:45 AM   #3
josh22
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Isix View Post
Lets see: --- when you get to that point try pressing Ctrl+Alt+F1, which will hopefully drop you to a virtual console. Then try
Code:
startx
Let the community then see any error messages that comes thereafter.

Best of luck ...

i did all that, and a message that came after words was as fallows:
Fatal server error:
server is already active for display 0 If this server is no longer running, remove /tmp/.X0 lock.

what now?
 
Old 02-08-2009, 09:23 AM   #4
josh22
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
some one please help!
 
Old 02-08-2009, 09:26 AM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Quote:
i did all that, and a message that came after words was as fallows:
Fatal server error:
server is already active for display 0 If this server is no longer running, remove /tmp/.X0 lock.

what now?
if you use gnome
Code:
sudo killall gdm
if you use kde
Quote:
sudo killall kdm
then
Code:
startx
 
Old 02-08-2009, 09:29 AM   #6
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Well,try;
Code:
rm -f /tmp/.X0-lock
from the command line and then;
Code:
startx
If it works,post the output of /etc/X11/xorg.conf.
Try to press CONTROL-ALT-F7 while at the text login prompt.

Last edited by alan_ri; 02-08-2009 at 09:34 AM.
 
Old 02-08-2009, 09:39 AM   #7
Mohtek
Member
 
Registered: Dec 2004
Location: Denver Colorado
Distribution: Kubuntu/Debian
Posts: 120

Rep: Reputation: 15
A step or two:

One question are you using Wubi to run Ubuntu from XP?

I must ask first if your hardware is fully compatible. For troubleshooting, I always start with square one and go through the process of elimination.

If you have the ubuntu CD, it is a live cd. If you reboot your machine (and make sure it boots to the CD first) you can run the whole thing off the disk.

If everything looks good from the CD, then it could be an installation error of some sort.

I have not used Wubi yet and can't state to its effectiveness. Perhaps other could....
 
Old 02-08-2009, 09:46 AM   #8
josh22
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
thank you all for trying to help!
i just tryed to do input some codes, but i couldnt even get the black screen to do it in, it seemed not to respond, i still have the mouse icon tho?
and yes i did use wubi to download it, i have requested a cd in the mail but that will take weeks.
and for my system im using:
Compact Desktop, intel celeron, 756 ram, 80 g hard drive 2.5 ghz.
 
Old 02-08-2009, 10:02 AM   #9
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
When the GRUB menu bypass screen appears at boot time, press any key to enter the GRUB menu (within the first three seconds).Press the [a] key to append to the kernel command.Press space at the end of the line and add 1.When you're on the command line post the output of;
Code:
ps aux | grep `cat /tmp/.X0-lock`
and then try to startx X with the;
Code:
startx -- :1

Last edited by alan_ri; 02-08-2009 at 11:31 AM. Reason: correction
 
Old 02-08-2009, 11:22 AM   #10
Isix
Member
 
Registered: Mar 2007
Location: Windhoek, Namibia
Distribution: Slackware, Kubuntu, Mandriva & PCLinuxOS
Posts: 80

Rep: Reputation: 18
I think the is a typo in alanri_ri's code:
Code:
ps aux | grep `cat /tmp/.X0-lock`]
remove the "]" at the end, so that it reads
Code:
ps aux | grep `cat /tmp/.X0-lock`
Am I right?
 
Old 02-08-2009, 11:31 AM   #11
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Yes,you're right, ] shouldn't be there.It wasn't a typo mistake,something happend with wraping the code.Fixed.

Last edited by alan_ri; 02-08-2009 at 11:43 AM.
 
Old 02-08-2009, 11:41 AM   #12
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,105
Blog Entries: 3

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
start in recovery mode and fix display

Last edited by Drakeo; 02-08-2009 at 11:42 AM.
 
Old 02-08-2009, 12:06 PM   #13
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi, josh22 -

Here's what I think probably happened:

1. You successfully downloaded and installed "Ubuntu"

2. Ubuntu successfully autoconfigured itself ... almost!
a) You can dual-boot Ubuntu or Windows XP (good)
b) You can start Ubuntu (good)
c) Ubuntu starts the GUI (good)

3. Unfortunately, the problem seems that, once the GUI starts, all you get is the desktop (the "orange screen"). It never gets past that - you don't seem to get any of the menus or icons you need to do anything useful.
<= I'm guessing, like Drakeo, that maybe the install didn't correctly configure your X windows "display"

Please let us know if I'm off-base.

So what are your options?

Sadly, you're in a "Catch-22":
a) the problem might be easily resolved if you had previous Linux experience
... but ...
b) the problem is *preventing* you from *getting* experience!

SUGGESTION:
1. Re-installing might help
"Auto-recovery" would be less drastic ... but it's a lot harder to use, and you might run the risk of "messing things up"

2. You might want to consider downloading an .iso image of Linux, burning a CD from it, and select the "Boot from CD" option (i.e. just *run* Linux, without actually installing it on your hard drive ... for now).

These pages might be of help:

https://help.ubuntu.com/community/GraphicalInstall
https://help.ubuntu.com/8.10/index.html
http://www.ubuntu.com/support
http://www.ubuntu.com/getubuntu/download

Hope that helps .. PSM

PS:
Please also look at this link: it seems to *exactly* describe your problem (and, hopefully, suggests a good solution):

http://ma65p.wordpress.com/2008/08/1...top-in-ubuntu/

Quote:
POSSIBLE SOLUTION:
1. Hold down Ctrl+Alt+F1
<= Like you did in Post#2 above

2. Login
<= Again, just like you did in Post#2

3. Instead of typing "startx", type this:
Quote:
sudo apt-get install ubuntu-desktop
This will (re) install the ubuntu desktop - It should put back the menus and the icons you're mising

4. Reboot

Last edited by paulsm4; 02-08-2009 at 12:10 PM.
 
Old 02-09-2009, 03:01 PM   #14
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi, josh22 -

Any luck?
 
Old 02-10-2009, 06:13 AM   #15
josh22
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hi all, Thank you all for your help in this matter. I have inputted this code:
ps aux | grep 'cat/tmp/.X0-lock'
and everything seems to be running fine now. thank you to all who have helped!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious Frustrated elc0chin0 LinuxQuestions.org Member Intro 2 04-24-2007 05:31 PM
New and frustrated galantesghost LinuxQuestions.org Member Intro 2 09-11-2005 04:16 PM
So Frustrated AxXium Slackware 20 05-17-2005 03:26 AM
I am frustrated (HELP) dimsun Linux - Newbie 3 11-02-2004 08:29 PM
getting really frustrated... minm Linux - Software 17 09-27-2004 10:25 PM


All times are GMT -5. The time now is 08:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration